Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Поиск значения исходя из двух определающих - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск значения исходя из двух определающих (Формулы/Formulas)
Поиск значения исходя из двух определающих
KIMVSR Дата: Вторник, 01.03.2016, 11:18 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 98
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Здравствуйте, ребят.

Помогите пожалуйста с простой формулой.

Есть два листа с данными.
На первом листе - работники и описывающие их критерии (уровень сложности и уровень навыков)
На втором листе - сводная таблица с данными, исходя из которой высчитывается з/п работников

Задача такова, что мне надо исходя из данных на первом листе найти нужную ячейку с з/п на втором листе.

Мне кажется, что проще всего это сделать через функцию ИНДЕКС или ПОИСКПОЗ, но у меня не получается.
Помогите, пожалуйста, решить такую простенькую задачке. Буду очень признателен.
К сообщению приложен файл: 5488319.xlsx(14Kb)
 
Ответить
СообщениеЗдравствуйте, ребят.

Помогите пожалуйста с простой формулой.

Есть два листа с данными.
На первом листе - работники и описывающие их критерии (уровень сложности и уровень навыков)
На втором листе - сводная таблица с данными, исходя из которой высчитывается з/п работников

Задача такова, что мне надо исходя из данных на первом листе найти нужную ячейку с з/п на втором листе.

Мне кажется, что проще всего это сделать через функцию ИНДЕКС или ПОИСКПОЗ, но у меня не получается.
Помогите, пожалуйста, решить такую простенькую задачке. Буду очень признателен.

Автор - KIMVSR
Дата добавления - 01.03.2016 в 11:18
китин Дата: Вторник, 01.03.2016, 11:22 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4106
Репутация: 633 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
Здравствуйте. так надо?
Код
=ИНДЕКС(Матрица!$C$4:$H$10;ПОИСКПОЗ(Работники!$C2;Матрица!$B$4:$B$10;0);ПОИСКПОЗ(Работники!$D2;Матрица!$C$3:$H$3;0))
К сообщению приложен файл: KIMVSR.xlsx(15Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538


Сообщение отредактировал китин - Вторник, 01.03.2016, 11:23
 
Ответить
СообщениеЗдравствуйте. так надо?
Код
=ИНДЕКС(Матрица!$C$4:$H$10;ПОИСКПОЗ(Работники!$C2;Матрица!$B$4:$B$10;0);ПОИСКПОЗ(Работники!$D2;Матрица!$C$3:$H$3;0))

Автор - китин
Дата добавления - 01.03.2016 в 11:22
_Boroda_ Дата: Вторник, 01.03.2016, 11:23 | Сообщение № 3
Группа: Модераторы
Ранг: Экселист
Сообщений: 10334
Репутация: 4357 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Код
=ИНДЕКС(Матрица!C$4:H$10;ПОИСКПОЗ(C2;Матрица!B$4:B$10;);D2+1)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Код
=ИНДЕКС(Матрица!C$4:H$10;ПОИСКПОЗ(C2;Матрица!B$4:B$10;);D2+1)

Автор - _Boroda_
Дата добавления - 01.03.2016 в 11:23
KIMVSR Дата: Вторник, 01.03.2016, 11:29 | Сообщение № 4
Группа: Пользователи
Ранг: Участник
Сообщений: 98
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
китин, _Boroda_, да, ребят, именно то, что надо! Спасибо!

Сам придумал такой вариант:
Код
=VLOOKUP(C2;Матрица!$B$2:$H$10;D2+2;0)

Но вариант с INDEX и MATCH мне нравится намного больше.

Огромное вам спасибо, сейчас буду разбираться, как вы это сделали.
Я пытался, но не получилось. Для меня эти две функции - головная боль shock


Сообщение отредактировал KIMVSR - Вторник, 01.03.2016, 11:31
 
Ответить
Сообщениекитин, _Boroda_, да, ребят, именно то, что надо! Спасибо!

Сам придумал такой вариант:
Код
=VLOOKUP(C2;Матрица!$B$2:$H$10;D2+2;0)

Но вариант с INDEX и MATCH мне нравится намного больше.

Огромное вам спасибо, сейчас буду разбираться, как вы это сделали.
Я пытался, но не получилось. Для меня эти две функции - головная боль shock

Автор - KIMVSR
Дата добавления - 01.03.2016 в 11:29
_Boroda_ Дата: Вторник, 01.03.2016, 11:30 | Сообщение № 5
Группа: Модераторы
Ранг: Экселист
Сообщений: 10334
Репутация: 4357 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Для меня эти две формулы - головная боль.

Тогда держите третью
Код
=ИНДЕКС(Матрица!C$4:H$10;ТЕКСТ(C2;"0;;;\6")+1;D2+1)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение
Для меня эти две формулы - головная боль.

Тогда держите третью
Код
=ИНДЕКС(Матрица!C$4:H$10;ТЕКСТ(C2;"0;;;\6")+1;D2+1)

Автор - _Boroda_
Дата добавления - 01.03.2016 в 11:30
китин Дата: Вторник, 01.03.2016, 11:36 | Сообщение № 6
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4106
Репутация: 633 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
[offtop]
Тогда держите третью

Саш у меня работы по горло а ты задачки подбрасываешь hands hands hands


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщение[offtop]
Тогда держите третью

Саш у меня работы по горло а ты задачки подбрасываешь hands hands hands

Автор - китин
Дата добавления - 01.03.2016 в 11:36
_Boroda_ Дата: Вторник, 01.03.2016, 11:41 | Сообщение № 7
Группа: Модераторы
Ранг: Экселист
Сообщений: 10334
Репутация: 4357 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
[offtop]
у меня работы по горло
Прополоскай горлышко стаканчиком водочки и все пройдет.


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение[offtop]
у меня работы по горло
Прополоскай горлышко стаканчиком водочки и все пройдет.

Автор - _Boroda_
Дата добавления - 01.03.2016 в 11:41
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск значения исходя из двух определающих (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!