Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Замена букв на числа, и разнесения данных по столбцам - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Замена букв на числа, и разнесения данных по столбцам (Формулы/Formulas)
Замена букв на числа, и разнесения данных по столбцам
Vamp Дата: Вторник, 01.03.2016, 15:00 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 13
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Добрый день!
Во вложении файл в котором нужно заменить:1) В листе Даннае в столбцах MC, значение CZ на цифру 1
2) В лист Искомые сложить данные которые соответствуют столбцу OID

В ручную сделала для OID AKXKZ27AV.
К сообщению приложен файл: 8229670.xlsx(12Kb)
 
Ответить
СообщениеДобрый день!
Во вложении файл в котором нужно заменить:1) В листе Даннае в столбцах MC, значение CZ на цифру 1
2) В лист Искомые сложить данные которые соответствуют столбцу OID

В ручную сделала для OID AKXKZ27AV.

Автор - Vamp
Дата добавления - 01.03.2016 в 15:00
_Boroda_ Дата: Вторник, 01.03.2016, 15:08 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 9381
Репутация: 3951 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Код
=СУММПРОИЗВ((B2='Данные '!E$2:E$54)*('Данные '!A$2:D$54="CZ"))

А почему у Вас 2 получилось?
А обязательно менять CZ на 1? Может, сразу посчитать?


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Код
=СУММПРОИЗВ((B2='Данные '!E$2:E$54)*('Данные '!A$2:D$54="CZ"))

А почему у Вас 2 получилось?
А обязательно менять CZ на 1? Может, сразу посчитать?

Автор - _Boroda_
Дата добавления - 01.03.2016 в 15:08
Vamp Дата: Вторник, 01.03.2016, 15:29 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 13
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Можно и сразу посчитать, только в некоторых столбцах попадаются и другое сочетание букв
 
Ответить
СообщениеМожно и сразу посчитать, только в некоторых столбцах попадаются и другое сочетание букв

Автор - Vamp
Дата добавления - 01.03.2016 в 15:29
Vamp Дата: Вторник, 01.03.2016, 15:32 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 13
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Вы правы должно быть 1
 
Ответить
СообщениеВы правы должно быть 1

Автор - Vamp
Дата добавления - 01.03.2016 в 15:32
_Boroda_ Дата: Вторник, 01.03.2016, 15:34 | Сообщение № 5
Группа: Модераторы
Ранг: Экселист
Сообщений: 9381
Репутация: 3951 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
в некоторых столбцах попадаются и другое сочетание букв

Продолжайте - ... и тогда нужно, чтобы формула считала ... (как?)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение
в некоторых столбцах попадаются и другое сочетание букв

Продолжайте - ... и тогда нужно, чтобы формула считала ... (как?)

Автор - _Boroda_
Дата добавления - 01.03.2016 в 15:34
Vamp Дата: Вторник, 01.03.2016, 15:41 | Сообщение № 6
Группа: Пользователи
Ранг: Новичок
Сообщений: 13
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Спасибо огромное!
С формулой разобралась
 
Ответить
СообщениеСпасибо огромное!
С формулой разобралась

Автор - Vamp
Дата добавления - 01.03.2016 в 15:41
Vamp Дата: Вторник, 01.03.2016, 16:34 | Сообщение № 7
Группа: Пользователи
Ранг: Новичок
Сообщений: 13
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
сейчас стала пробовать перенести формулу на рабочий файл не получается так как в столбцах MC попадается другое сочетание букв и CZ уже не срабатывает, но в каждой ячейке будет только две буквы, т.е если в ячейке есть символ его недо заменить на 1
 
Ответить
Сообщениесейчас стала пробовать перенести формулу на рабочий файл не получается так как в столбцах MC попадается другое сочетание букв и CZ уже не срабатывает, но в каждой ячейке будет только две буквы, т.е если в ячейке есть символ его недо заменить на 1

Автор - Vamp
Дата добавления - 01.03.2016 в 16:34
_Boroda_ Дата: Вторник, 01.03.2016, 16:35 | Сообщение № 8
Группа: Модераторы
Ранг: Экселист
Сообщений: 9381
Репутация: 3951 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Код
=СУММПРОИЗВ((B2='Данные '!E$2:E$54)*етекст('Данные '!A$2:D$54))

Код
=СУММПРОИЗВ((B3='Данные '!E$2:E$54)*('Данные '!A$2:D$54<>""))


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение
Код
=СУММПРОИЗВ((B2='Данные '!E$2:E$54)*етекст('Данные '!A$2:D$54))

Код
=СУММПРОИЗВ((B3='Данные '!E$2:E$54)*('Данные '!A$2:D$54<>""))

Автор - _Boroda_
Дата добавления - 01.03.2016 в 16:35
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Замена букв на числа, и разнесения данных по столбцам (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!