Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Подсчёт времени из диапазона (сумма) - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчёт времени из диапазона (сумма) (Формулы/Formulas)
Подсчёт времени из диапазона (сумма)
bradis Дата: Вторник, 01.03.2016, 15:06 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2003
Здравствуйте.

Есть диапазон дат с указанием времени, а именно - постановка на охрану и снятие с охраны
Нужно подсчитать общее количество часов и минут, когда шлейф находился под охраной, подскажите пожалуйста формулу.

Во вложении - даты и время в виде списка.
Спасибо.
[moder]Нету. Макс - 100 кб
К сообщению приложен файл: 2420768.xls(16Kb)


Сообщение отредактировал bradis - Вторник, 01.03.2016, 15:45
 
Ответить
СообщениеЗдравствуйте.

Есть диапазон дат с указанием времени, а именно - постановка на охрану и снятие с охраны
Нужно подсчитать общее количество часов и минут, когда шлейф находился под охраной, подскажите пожалуйста формулу.

Во вложении - даты и время в виде списка.
Спасибо.
[moder]Нету. Макс - 100 кб

Автор - bradis
Дата добавления - 01.03.2016 в 15:06
Manyasha Дата: Вторник, 01.03.2016, 16:51 | Сообщение № 2
Группа: Модераторы
Ранг: Старожил
Сообщений: 1589
Репутация: 669 ±
Замечаний: 0% ±

Excel 2007, 2010
bradis, а что делать с последней строчкой "Постановка зоны под охрану"? Не учитывать ее или считать текущее время - последняя строчка?
У меня считается без нее (формула массива, вводить через ctrl+shift+enter):
Код
=СУММ((A3:A33-A2:A32)*ЕЧЁТН(СТРОКА(A2:A32)))
К сообщению приложен файл: 2420768-1.xls(38Kb)


marinamorozova_box@mail.ru
ЯД: 410013299366744 WM: R193491431804
 
Ответить
Сообщениеbradis, а что делать с последней строчкой "Постановка зоны под охрану"? Не учитывать ее или считать текущее время - последняя строчка?
У меня считается без нее (формула массива, вводить через ctrl+shift+enter):
Код
=СУММ((A3:A33-A2:A32)*ЕЧЁТН(СТРОКА(A2:A32)))

Автор - Manyasha
Дата добавления - 01.03.2016 в 16:51
_Boroda_ Дата: Вторник, 01.03.2016, 17:47 | Сообщение № 3
Группа: Модераторы
Ранг: Экселист
Сообщений: 9377
Репутация: 3950 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Еще вариант обычной формулой
Код
=СУММПРОИЗВ(A2:A33-2*A2:A33*(B2:B33=B2))

Код
=СУММПРОИЗВ((1-2*(B2:B33=B2))*A2:A33)

Ну и формат ячейки
[чч]\ч. мм\м.
К сообщению приложен файл: 2420768_1.xls(30Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЕще вариант обычной формулой
Код
=СУММПРОИЗВ(A2:A33-2*A2:A33*(B2:B33=B2))

Код
=СУММПРОИЗВ((1-2*(B2:B33=B2))*A2:A33)

Ну и формат ячейки
[чч]\ч. мм\м.

Автор - _Boroda_
Дата добавления - 01.03.2016 в 17:47
bradis Дата: Среда, 02.03.2016, 00:57 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2003
_Boroda_, спасибо.

В принципе, я же могу добавить в конце ещё одну строку с временем 23:59, тогда будет считать до конца
 
Ответить
Сообщение_Boroda_, спасибо.

В принципе, я же могу добавить в конце ещё одну строку с временем 23:59, тогда будет считать до конца

Автор - bradis
Дата добавления - 02.03.2016 в 00:57
_Boroda_ Дата: Среда, 02.03.2016, 01:09 | Сообщение № 5
Группа: Модераторы
Ранг: Экселист
Сообщений: 9377
Репутация: 3950 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Конечно можете. Более того, можно автоматически в формуле это обрабатывать, но тогда формула получится больше.
[p.s.]А Маняше спасибо?


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеКонечно можете. Более того, можно автоматически в формуле это обрабатывать, но тогда формула получится больше.
[p.s.]А Маняше спасибо?

Автор - _Boroda_
Дата добавления - 02.03.2016 в 01:09
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчёт времени из диапазона (сумма) (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!