Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Отметить посещение людей в таблице на основе другой таблицы - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Отметить посещение людей в таблице на основе другой таблицы (Формулы/Formulas)
Отметить посещение людей в таблице на основе другой таблицы
Shulga Дата: Вторник, 01.03.2016, 21:45 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Добрый день. Напишите в двух словах, как поступить.
Лучше скачать таблицу. Чтобы понять мой косноязычный замысел
Есть 2 таблицы
1. Столбец с фамилиями всех сотрудников и 31 столбец где необходимо отметить кто из этих дней сотрудников был на работе.
2. 31 столбец в котором указаны кто из сотрудников был на работе.
Задача. Отметить в первой таблице на основе данных второй таблицы кто же был на работе. В идеале цветом, но я готов на любой вариант
Идеи. Единственное. что приходит в голову использовать функцию если. допустим сравнить фио и фио из списка.
эх, в общем есть мысли?

в 1 таблице будет 35-40 человек
во 2 таблице 15-20
К сообщению приложен файл: 252.xlsx(9Kb)


Сообщение отредактировал Shulga - Вторник, 01.03.2016, 21:46
 
Ответить
СообщениеДобрый день. Напишите в двух словах, как поступить.
Лучше скачать таблицу. Чтобы понять мой косноязычный замысел
Есть 2 таблицы
1. Столбец с фамилиями всех сотрудников и 31 столбец где необходимо отметить кто из этих дней сотрудников был на работе.
2. 31 столбец в котором указаны кто из сотрудников был на работе.
Задача. Отметить в первой таблице на основе данных второй таблицы кто же был на работе. В идеале цветом, но я готов на любой вариант
Идеи. Единственное. что приходит в голову использовать функцию если. допустим сравнить фио и фио из списка.
эх, в общем есть мысли?

в 1 таблице будет 35-40 человек
во 2 таблице 15-20

Автор - Shulga
Дата добавления - 01.03.2016 в 21:45
krosav4ig Дата: Вторник, 01.03.2016, 21:55 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1362
Репутация: 548 ±
Замечаний: 0% ±

Excel 2007, 2013
Добрый ... но день ли :)
Условное форматирование по формуле
Код
=ИЛИ(СЧЁТЕСЛИ(Таблица1!$A2;Таблица2!$A$2:$AE$3)*(Таблица2!$A$1:$AE$1=Таблица1!B$1))
К сообщению приложен файл: 3050604.xlsx(10Kb)


(_)Õvõ(_)

Сообщение отредактировал krosav4ig - Вторник, 01.03.2016, 21:55
 
Ответить
СообщениеДобрый ... но день ли :)
Условное форматирование по формуле
Код
=ИЛИ(СЧЁТЕСЛИ(Таблица1!$A2;Таблица2!$A$2:$AE$3)*(Таблица2!$A$1:$AE$1=Таблица1!B$1))

Автор - krosav4ig
Дата добавления - 01.03.2016 в 21:55
Pelena Дата: Вторник, 01.03.2016, 22:23 | Сообщение № 3
Группа: Модераторы
Ранг: Экселист
Сообщений: 9890
Репутация: 2269 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
Немного другое правило Условного форматирования
Код
=($A2<>"")*СУММ(--(B$1=(($A2=Таблица2!$A$2:$AE$20)*$B$1:$AF$1)))

Формула для "+" (для ячейки В2)
Код
=ЕСЛИ(($A2<>"")*СУММ(--(B$1=(($A2=Таблица2!$A$2:$AE$20)*$B$1:$AF$1)));"+";"")
К сообщению приложен файл: 7245581.xlsx(14Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеНемного другое правило Условного форматирования
Код
=($A2<>"")*СУММ(--(B$1=(($A2=Таблица2!$A$2:$AE$20)*$B$1:$AF$1)))

Формула для "+" (для ячейки В2)
Код
=ЕСЛИ(($A2<>"")*СУММ(--(B$1=(($A2=Таблица2!$A$2:$AE$20)*$B$1:$AF$1)));"+";"")

Автор - Pelena
Дата добавления - 01.03.2016 в 22:23
_Boroda_ Дата: Среда, 02.03.2016, 01:23 | Сообщение № 4
Группа: Модераторы
Ранг: Экселист
Сообщений: 9381
Репутация: 3951 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Еще немного другое правило УФ (если я, конечно, правильно понял задачу)
Код
=ПОИСКПОЗ($A2;Таблица2!A$2:A$20;)

И для плюсиков
Код
=ЕСЛИОШИБКА(ПОИСКПОЗ($A2;Таблица2!A$2:A$20;);)

И формат ячеек
+;;;
К сообщению приложен файл: 7245581_1.xlsx(19Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЕще немного другое правило УФ (если я, конечно, правильно понял задачу)
Код
=ПОИСКПОЗ($A2;Таблица2!A$2:A$20;)

И для плюсиков
Код
=ЕСЛИОШИБКА(ПОИСКПОЗ($A2;Таблица2!A$2:A$20;);)

И формат ячеек
+;;;

Автор - _Boroda_
Дата добавления - 02.03.2016 в 01:23
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Отметить посещение людей в таблице на основе другой таблицы (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!