Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Многофункциональный выпадающий список - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Многофункциональный выпадающий список
Многофункциональный выпадающий список
Дерево Дата: Среда, 02.03.2016, 16:12 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 17
Репутация: 0 ±
Замечаний: 20% ±

Excel 2010
Добрый день.
У меня такая проблема, есть три ячейки в двух должен быть выпадающий список, а в третей либо список либо формула выдающая конкретную фамилию. Таблица небольшая, в приложение данные.
К сообщению приложен файл: _Microsoft_Exce.xlsx(11Kb)


Сообщение отредактировал Дерево - Среда, 02.03.2016, 16:22
 
Ответить
СообщениеДобрый день.
У меня такая проблема, есть три ячейки в двух должен быть выпадающий список, а в третей либо список либо формула выдающая конкретную фамилию. Таблица небольшая, в приложение данные.

Автор - Дерево
Дата добавления - 02.03.2016 в 16:12
SLAVICK Дата: Среда, 02.03.2016, 17:27 | Сообщение № 2
Группа: Модераторы
Ранг: Старожил
Сообщений: 1962
Репутация: 669 ±
Замечаний: 0% ±

2007,2010,2013,2016
Смотрите здесь и здесь


Иногда все проще чем кажется с первого взгляда.
 
Ответить
СообщениеСмотрите здесь и здесь

Автор - SLAVICK
Дата добавления - 02.03.2016 в 17:27
Roman777 Дата: Среда, 02.03.2016, 17:36 | Сообщение № 3
Группа: Проверенные
Ранг: Ветеран
Сообщений: 747
Репутация: 81 ±
Замечаний: 0% ±

Excel 2007, Excel 2013
А можно допстолбец и ВПР:
Код
=ЕСЛИОШИБКА(ВПР(B3&C3;H:K;4;0);"")

Если я правильно понял.
К сообщению приложен файл: 6783164.xlsx(12Kb)


Много чего не знаю!!!!
 
Ответить
СообщениеА можно допстолбец и ВПР:
Код
=ЕСЛИОШИБКА(ВПР(B3&C3;H:K;4;0);"")

Если я правильно понял.

Автор - Roman777
Дата добавления - 02.03.2016 в 17:36
SLAVICK Дата: Среда, 02.03.2016, 17:43 | Сообщение № 4
Группа: Модераторы
Ранг: Старожил
Сообщений: 1962
Репутация: 669 ±
Замечаний: 0% ±

2007,2010,2013,2016
допстолбец и ВПР:

Так и без допстолца можно. :D
Просто формулой массива:
Код
=ЕСЛИОШИБКА(ИНДЕКС($K$1:$K$20;ПОИСКПОЗ(B3&C3;$I$1:$I$20&$J$1:$J$20;0);1);"")

Но я сомневаюсь что это нужно - скорее всего нужно зависимый выпадающий список как в ссылках. Просто я из примера не совсем ясно, что нужно.
К сообщению приложен файл: 5644210.xlsx(12Kb)


Иногда все проще чем кажется с первого взгляда.
 
Ответить
Сообщение
допстолбец и ВПР:

Так и без допстолца можно. :D
Просто формулой массива:
Код
=ЕСЛИОШИБКА(ИНДЕКС($K$1:$K$20;ПОИСКПОЗ(B3&C3;$I$1:$I$20&$J$1:$J$20;0);1);"")

Но я сомневаюсь что это нужно - скорее всего нужно зависимый выпадающий список как в ссылках. Просто я из примера не совсем ясно, что нужно.

Автор - SLAVICK
Дата добавления - 02.03.2016 в 17:43
_Boroda_ Дата: Среда, 02.03.2016, 17:46 | Сообщение № 5
Группа: Модераторы
Ранг: Экселист
Сообщений: 10334
Репутация: 4357 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Я бы немного переделал табличку с исходными данными и тогда все просто получается
К сообщению приложен файл: 617749.xlsx(12Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЯ бы немного переделал табличку с исходными данными и тогда все просто получается

Автор - _Boroda_
Дата добавления - 02.03.2016 в 17:46
Дерево Дата: Среда, 02.03.2016, 19:18 | Сообщение № 6
Группа: Пользователи
Ранг: Новичок
Сообщений: 17
Репутация: 0 ±
Замечаний: 20% ±

Excel 2010
hands hands hands спасибо большое
 
Ответить
Сообщениеhands hands hands спасибо большое

Автор - Дерево
Дата добавления - 02.03.2016 в 19:18
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Многофункциональный выпадающий список
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!