Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/впр с доп. функцией - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » впр с доп. функцией (Формулы/Formulas)
впр с доп. функцией
Аналитик2012 Дата: Среда, 02.03.2016, 20:39 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 36
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
выходит н#д при поиске при использовании функции впр. проблема из за того, что искомое значение текстового формата, а в базе где ищет данные числового формата. к сожалению файл очень большой, что из текстового формата менять в числовой. как можно более быстро устранить недочет или заменять впр на другую формулу.
 
Ответить
Сообщениевыходит н#д при поиске при использовании функции впр. проблема из за того, что искомое значение текстового формата, а в базе где ищет данные числового формата. к сожалению файл очень большой, что из текстового формата менять в числовой. как можно более быстро устранить недочет или заменять впр на другую формулу.

Автор - Аналитик2012
Дата добавления - 02.03.2016 в 20:39
МВТ Дата: Среда, 02.03.2016, 20:48 | Сообщение № 2
Группа: Проверенные
Ранг: Обитатель
Сообщений: 475
Репутация: 135 ±
Замечаний: 0% ±

Excel 2007
Попробуйте так, где A1 - искомое значение, B1:C10 - массив, где происходит поиск
Код
=ВПР(--A1;B1:C10;2;0)
 
Ответить
СообщениеПопробуйте так, где A1 - искомое значение, B1:C10 - массив, где происходит поиск
Код
=ВПР(--A1;B1:C10;2;0)

Автор - МВТ
Дата добавления - 02.03.2016 в 20:48
akobir Дата: Четверг, 03.03.2016, 09:17 | Сообщение № 3
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 159
Репутация: 9 ±
Замечаний: 0% ±

Excel 2010
Аналитик2012, Я в таких случаях (когда лень что-то придумывать) преобразовываю текст в число, прибавив к нему 0 в соседнем столбце; протягиваю формулу и ВПР делаю уже по новому столбцу.
Приложите пример, посмотрим что у Вас.


e-mail: akobir.ismailov@gmail.com
 
Ответить
СообщениеАналитик2012, Я в таких случаях (когда лень что-то придумывать) преобразовываю текст в число, прибавив к нему 0 в соседнем столбце; протягиваю формулу и ВПР делаю уже по новому столбцу.
Приложите пример, посмотрим что у Вас.

Автор - akobir
Дата добавления - 03.03.2016 в 09:17
Аналитик2012 Дата: Пятница, 04.03.2016, 20:42 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 36
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
всем спасибо! вариант +0 подошел
 
Ответить
Сообщениевсем спасибо! вариант +0 подошел

Автор - Аналитик2012
Дата добавления - 04.03.2016 в 20:42
Мир MS Excel » Вопросы и решения » Вопросы по Excel » впр с доп. функцией (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!