Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Выбор данных при нескольких условиях - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выбор данных при нескольких условиях (Формулы/Formulas)
Выбор данных при нескольких условиях
tanver Дата: Четверг, 03.03.2016, 11:07 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 53
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Добрый день,

Прошу помочь написать формулу. Данные и условия во вложенном файле.

Заранее благодарю.

Татьяна
К сообщению приложен файл: ___2_.xlsx(12Kb)
 
Ответить
СообщениеДобрый день,

Прошу помочь написать формулу. Данные и условия во вложенном файле.

Заранее благодарю.

Татьяна

Автор - tanver
Дата добавления - 03.03.2016 в 11:07
Manyasha Дата: Четверг, 03.03.2016, 11:36 | Сообщение № 2
Группа: Модераторы
Ранг: Старожил
Сообщений: 1721
Репутация: 722 ±
Замечаний: 0% ±

Excel 2007, 2010
tanver, так подойдет?
формула массива, вводить сочетанием ctrl+shift+enter
Код
=ИНДЕКС($F$4:$I$7;СУММ(ЕЧИСЛО(ПОИСК($E$4:$E$7;B3))*(СТРОКА($E$4:$E$7)-3));МЕСЯЦ(A3))
К сообщению приложен файл: _2-1.xlsx(12Kb)


marinamorozova_box@mail.ru
ЯД: 410013299366744 WM: R193491431804
 
Ответить
Сообщениеtanver, так подойдет?
формула массива, вводить сочетанием ctrl+shift+enter
Код
=ИНДЕКС($F$4:$I$7;СУММ(ЕЧИСЛО(ПОИСК($E$4:$E$7;B3))*(СТРОКА($E$4:$E$7)-3));МЕСЯЦ(A3))

Автор - Manyasha
Дата добавления - 03.03.2016 в 11:36
Nic70y Дата: Четверг, 03.03.2016, 11:40 | Сообщение № 3
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3667
Репутация: 760 ±
Замечаний: 0% ±

Excel 2013
немассивная
Код
=ИНДЕКС(F$4:I$7;ПОИСКПОЗ(СЖПРОБЕЛЫ(ЛЕВБ(ПОДСТАВИТЬ(B3;" ";ПОВТОР(" ";99));99));E$4:E$7;);ПОИСКПОЗ(КОНМЕСЯЦА(A3;0);F$3:I$3;))
К сообщению приложен файл: _2_.xlsx(12Kb)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщениенемассивная
Код
=ИНДЕКС(F$4:I$7;ПОИСКПОЗ(СЖПРОБЕЛЫ(ЛЕВБ(ПОДСТАВИТЬ(B3;" ";ПОВТОР(" ";99));99));E$4:E$7;);ПОИСКПОЗ(КОНМЕСЯЦА(A3;0);F$3:I$3;))

Автор - Nic70y
Дата добавления - 03.03.2016 в 11:40
YouGreed Дата: Четверг, 03.03.2016, 11:47 | Сообщение № 4
Группа: Проверенные
Ранг: Обитатель
Сообщений: 429
Репутация: 93 ±
Замечаний: 0% ±

Excel 2010
tanver,
Код
=ИНДЕКС($F$4:$I$7;ПОИСКПОЗ(ПСТР($B3;1;ЕСЛИОШИБКА(НАЙТИ(" ";$B3;1)-1;ДЛСТР($B3)));$E$4:$E$7;);ПОИСКПОЗ(МЕСЯЦ($A3);МЕСЯЦ($F$3:$I$3);))

Формула массива вводится одновременным нажатием клавиш Ctrl+Shift+Enter
К сообщению приложен файл: ______.xlsx(12Kb)


Сообщение отредактировал YouGreed - Четверг, 03.03.2016, 11:53
 
Ответить
Сообщениеtanver,
Код
=ИНДЕКС($F$4:$I$7;ПОИСКПОЗ(ПСТР($B3;1;ЕСЛИОШИБКА(НАЙТИ(" ";$B3;1)-1;ДЛСТР($B3)));$E$4:$E$7;);ПОИСКПОЗ(МЕСЯЦ($A3);МЕСЯЦ($F$3:$I$3);))

Формула массива вводится одновременным нажатием клавиш Ctrl+Shift+Enter

Автор - YouGreed
Дата добавления - 03.03.2016 в 11:47
jakim Дата: Четверг, 03.03.2016, 11:48 | Сообщение № 5
Группа: Друзья
Ранг: Ветеран
Сообщений: 711
Репутация: 182 ±
Замечаний: 0% ±

Вы в своей задачке можете использовать функцию АГРЕГАТ.
К сообщению приложен файл: telega.xlsx(12Kb)
 
Ответить
Сообщение
Вы в своей задачке можете использовать функцию АГРЕГАТ.

Автор - jakim
Дата добавления - 03.03.2016 в 11:48
китин Дата: Четверг, 03.03.2016, 11:55 | Сообщение № 6
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3719
Репутация: 574 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
и мой вариант. простая
Код
=СУММПРОИЗВ($F$4:$I$7*($E$4:$E$7=ЕСЛИОШИБКА(ЛЕВБ($B3;ПОИСК(" ";$B3)-1);B3))*(ТЕКСТ(A3;"ММММ")=$F$2:$I$2))
К сообщению приложен файл: tanver.xlsx(12Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениеи мой вариант. простая
Код
=СУММПРОИЗВ($F$4:$I$7*($E$4:$E$7=ЕСЛИОШИБКА(ЛЕВБ($B3;ПОИСК(" ";$B3)-1);B3))*(ТЕКСТ(A3;"ММММ")=$F$2:$I$2))

Автор - китин
Дата добавления - 03.03.2016 в 11:55
_Boroda_ Дата: Четверг, 03.03.2016, 12:41 | Сообщение № 7
Группа: Модераторы
Ранг: Экселист
Сообщений: 9827
Репутация: 4148 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
И мой
Для одного слова
Код
=ВПР(ЛЕВБ(B3;ПОИСК(" ";B3&" ")-1);E$4:I$7;МЕСЯЦ(A3)+1;)

Для любого количества (массивная)
Код
=МАКС(ЕЧИСЛО(ПОИСК(E$4:E$7;B3))*F$4:I$7*(КОНМЕСЯЦА(A3;0)=F$3:I$3))
К сообщению приложен файл: 2068063.xlsx(13Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеИ мой
Для одного слова
Код
=ВПР(ЛЕВБ(B3;ПОИСК(" ";B3&" ")-1);E$4:I$7;МЕСЯЦ(A3)+1;)

Для любого количества (массивная)
Код
=МАКС(ЕЧИСЛО(ПОИСК(E$4:E$7;B3))*F$4:I$7*(КОНМЕСЯЦА(A3;0)=F$3:I$3))

Автор - _Boroda_
Дата добавления - 03.03.2016 в 12:41
tanver Дата: Четверг, 03.03.2016, 14:41 | Сообщение № 8
Группа: Пользователи
Ранг: Участник
Сообщений: 53
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Надо же, как много способов! :o

Спасибо всем огромное за помощь!
Попробую все это применить в моей рабочей таблице.

С уважением, Татьяна


Благодарю. С уважением Татьяна В.
 
Ответить
СообщениеНадо же, как много способов! :o

Спасибо всем огромное за помощь!
Попробую все это применить в моей рабочей таблице.

С уважением, Татьяна

Автор - tanver
Дата добавления - 03.03.2016 в 14:41
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выбор данных при нескольких условиях (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!