Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Максимальное число из заданной группы - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Максимальное число из заданной группы (Формулы/Formulas)
Максимальное число из заданной группы
martyr Дата: Четверг, 03.03.2016, 15:15 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 21
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Добрый день, товарищи!
Подскажите как найти максимальное число из группы и вернуть это макс число каждой строке из этой группы (пример как должно получится во вложении)
Заранее спасибо!
К сообщению приложен файл: 7958371.xlsx(12Kb)


Сообщение отредактировал martyr - Четверг, 03.03.2016, 15:15
 
Ответить
СообщениеДобрый день, товарищи!
Подскажите как найти максимальное число из группы и вернуть это макс число каждой строке из этой группы (пример как должно получится во вложении)
Заранее спасибо!

Автор - martyr
Дата добавления - 03.03.2016 в 15:15
китин Дата: Четверг, 03.03.2016, 15:21 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3450
Репутация: 549 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
и вам не хворать :D
так надо? массивная формула
Код
=МАКС(ЕСЛИ($B$2:$B$7=$B2;$C$2:$C$7))
К сообщению приложен файл: martyr.xlsx(13Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538


Сообщение отредактировал китин - Четверг, 03.03.2016, 15:22
 
Ответить
Сообщениеи вам не хворать :D
так надо? массивная формула
Код
=МАКС(ЕСЛИ($B$2:$B$7=$B2;$C$2:$C$7))

Автор - китин
Дата добавления - 03.03.2016 в 15:21
SLAVICK Дата: Четверг, 03.03.2016, 15:23 | Сообщение № 3
Группа: Модераторы
Ранг: Старожил
Сообщений: 1844
Репутация: 614 ±
Замечаний: 0% ±

2007,2010,2013,2016
Формула массива:
Код
=МАКС(($B$2:$B$7=B2)*$C$2:$C$7)
К сообщению приложен файл: 2519244.xlsx(14Kb)


Иногда все проще чем кажется с первого взгляда.
 
Ответить
СообщениеФормула массива:
Код
=МАКС(($B$2:$B$7=B2)*$C$2:$C$7)

Автор - SLAVICK
Дата добавления - 03.03.2016 в 15:23
китин Дата: Четверг, 03.03.2016, 15:24 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3450
Репутация: 549 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
[offtop]опять укоротили формулу, демоны hands


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщение[offtop]опять укоротили формулу, демоны hands

Автор - китин
Дата добавления - 03.03.2016 в 15:24
SLAVICK Дата: Четверг, 03.03.2016, 15:32 | Сообщение № 5
Группа: Модераторы
Ранг: Старожил
Сообщений: 1844
Репутация: 614 ±
Замечаний: 0% ±

2007,2010,2013,2016
[offtop]Да мы такие
[/offtop]
К сообщению приложен файл: 1788294.gif(28Kb)


Иногда все проще чем кажется с первого взгляда.
 
Ответить
Сообщение[offtop]Да мы такие
[/offtop]

Автор - SLAVICK
Дата добавления - 03.03.2016 в 15:32
китин Дата: Четверг, 03.03.2016, 15:47 | Сообщение № 6
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3450
Репутация: 549 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
[offtop]
Да мы такие
ничто ща Борода придет и еще укоротит :p


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщение[offtop]
Да мы такие
ничто ща Борода придет и еще укоротит :p

Автор - китин
Дата добавления - 03.03.2016 в 15:47
Nic70y Дата: Четверг, 03.03.2016, 16:00 | Сообщение № 7
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3487
Репутация: 722 ±
Замечаний: 0% ±

Excel 2013
обычная (ну, какой пример)
Код
=ЕСЛИ(B2=B1;D1;МАКС(C2:C4))


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщениеобычная (ну, какой пример)
Код
=ЕСЛИ(B2=B1;D1;МАКС(C2:C4))

Автор - Nic70y
Дата добавления - 03.03.2016 в 16:00
jakim Дата: Четверг, 03.03.2016, 16:29 | Сообщение № 8
Группа: Друзья
Ранг: Ветеран
Сообщений: 683
Репутация: 172 ±
Замечаний: 0% ±

Тоже обычная

Код
=MAX(INDEX(C$2:C$7*(A$2:A$7=A2);0))
 
Ответить
Сообщение
Тоже обычная

Код
=MAX(INDEX(C$2:C$7*(A$2:A$7=A2);0))

Автор - jakim
Дата добавления - 03.03.2016 в 16:29
_Boroda_ Дата: Четверг, 03.03.2016, 16:43 | Сообщение № 9
Группа: Модераторы
Ранг: Экселист
Сообщений: 9375
Репутация: 3948 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
ща Борода придет и еще укоротит

Не, я самый длинный вариант предложу. Зато довольно быстрый для больших объемов.
Код
=ЕСЛИ(A2=A1;E1;МАКС(C2:ИНДЕКС(C2:C999;СЧЁТЕСЛИ(A2:A999;A2))))
К сообщению приложен файл: 7958371_1.xlsx(14Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение
ща Борода придет и еще укоротит

Не, я самый длинный вариант предложу. Зато довольно быстрый для больших объемов.
Код
=ЕСЛИ(A2=A1;E1;МАКС(C2:ИНДЕКС(C2:C999;СЧЁТЕСЛИ(A2:A999;A2))))

Автор - _Boroda_
Дата добавления - 03.03.2016 в 16:43
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Максимальное число из заданной группы (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!