Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Подсчет кол-ва при нескольких условиях - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчет кол-ва при нескольких условиях (Формулы/Formulas)
Подсчет кол-ва при нескольких условиях
Любознатель Дата: Суббота, 05.03.2016, 15:56 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Добрый день!
Не могу самостоятельно дописать формулу с условиями, чтобы подсчитывалось кол-во из колонки В, если у этого человека есть замещающие.
Необходимо, чтобы считалось сколько у сотрудника задач на определенную дату, если он замещает кого-либо, либо если его переставить на другие задачи, т.е. основные не считать, а считать только в колонке замещающие. У тех у кого изменений нет, также должны отражаться с кол-вом, которое не меняется и соответствует колонке ответственный.
Применила формулы СУММЕСЛИ и ЕСЛИ с ИЛИ. Возможно можно как-то упростить формулу, чтобы не прописывать каждый раз критерий.
Пример во вложении.
К сообщению приложен файл: 6938979.xlsx(10Kb)
 
Ответить
СообщениеДобрый день!
Не могу самостоятельно дописать формулу с условиями, чтобы подсчитывалось кол-во из колонки В, если у этого человека есть замещающие.
Необходимо, чтобы считалось сколько у сотрудника задач на определенную дату, если он замещает кого-либо, либо если его переставить на другие задачи, т.е. основные не считать, а считать только в колонке замещающие. У тех у кого изменений нет, также должны отражаться с кол-вом, которое не меняется и соответствует колонке ответственный.
Применила формулы СУММЕСЛИ и ЕСЛИ с ИЛИ. Возможно можно как-то упростить формулу, чтобы не прописывать каждый раз критерий.
Пример во вложении.

Автор - Любознатель
Дата добавления - 05.03.2016 в 15:56
Pelena Дата: Суббота, 05.03.2016, 16:08 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 9879
Репутация: 2265 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
Не уверена, что правильно поняла
К сообщению приложен файл: 1871251.xlsx(10Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеНе уверена, что правильно поняла

Автор - Pelena
Дата добавления - 05.03.2016 в 16:08
Любознатель Дата: Суббота, 05.03.2016, 20:22 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
С формулой спасибо hands , поняла, как уменьшить кол-во критериев.
Только в колонке за 02.02.2016 не получается у архипова нужное кол-во, т.к у него свои задачи 8, и еще он замещает с 4 задачами, должно стоять 12.
Также не могу сообразить как написать, чтобы если никого не замещает, но есть свои задачи, чтобы тоже в колонке подсчитывалось - для статистики за определенный день. Поэтому хотела записать через условия ЕСЛИ.
Т.е.необходимо, чтобы напротив каждого сотрудника в каждом дне стояла цифра задач, если сотрудник кого-то замещает, ему должны добавляться задачи того, кого он замещает.
Если его замещают, должны его задачи у него не отражаться, а отражаться у того, кто его замещает.
Если только свои задачи без замещения, т должны отражаться только свои задачи, которые стоят как за ответсвенным.
 
Ответить
СообщениеС формулой спасибо hands , поняла, как уменьшить кол-во критериев.
Только в колонке за 02.02.2016 не получается у архипова нужное кол-во, т.к у него свои задачи 8, и еще он замещает с 4 задачами, должно стоять 12.
Также не могу сообразить как написать, чтобы если никого не замещает, но есть свои задачи, чтобы тоже в колонке подсчитывалось - для статистики за определенный день. Поэтому хотела записать через условия ЕСЛИ.
Т.е.необходимо, чтобы напротив каждого сотрудника в каждом дне стояла цифра задач, если сотрудник кого-то замещает, ему должны добавляться задачи того, кого он замещает.
Если его замещают, должны его задачи у него не отражаться, а отражаться у того, кто его замещает.
Если только свои задачи без замещения, т должны отражаться только свои задачи, которые стоят как за ответсвенным.

Автор - Любознатель
Дата добавления - 05.03.2016 в 20:22
Pelena Дата: Суббота, 05.03.2016, 20:37 | Сообщение № 4
Группа: Модераторы
Ранг: Экселист
Сообщений: 9879
Репутация: 2265 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
Как я и подозревала, не правильно поняла. Проверьте так
Код
=СУММЕСЛИ(D$3:D$8;$B14;$B$3:$B$8)+СУММЕСЛИМН($B$3:$B$8;$C$3:$C$8;$B14;D$3:D$8;"=")
К сообщению приложен файл: 5073939.xlsx(11Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеКак я и подозревала, не правильно поняла. Проверьте так
Код
=СУММЕСЛИ(D$3:D$8;$B14;$B$3:$B$8)+СУММЕСЛИМН($B$3:$B$8;$C$3:$C$8;$B14;D$3:D$8;"=")

Автор - Pelena
Дата добавления - 05.03.2016 в 20:37
Любознатель Дата: Воскресенье, 06.03.2016, 19:44 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Pelena, спасибо огромное, все получилось. :D
yahoo respect
 
Ответить
СообщениеPelena, спасибо огромное, все получилось. :D
yahoo respect

Автор - Любознатель
Дата добавления - 06.03.2016 в 19:44
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчет кол-ва при нескольких условиях (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!