Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Преобразовать данные из одного столбца в несколько строк - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Преобразовать данные из одного столбца в несколько строк (Формулы/Formulas)
Преобразовать данные из одного столбца в несколько строк
PreflopLuck Дата: Понедельник, 14.03.2016, 12:19 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Всем привет! Нужна помощь. Возможно не совсем корректно обозвал заголовок темы. Вообщем, суть вопроса.

Имеем один столбец с несколькими тысячами строк. Необходимо каждые девять строк (каждая десятая - пустая) этого столбца преобразовать в одну строку. Т.е. нужен своего рода аналог функции ТРАнСПОРТИРОВАТЬ.
В прикрепленном файле выделил цветом для наглядности.
К сообщению приложен файл: 0404603.xlsx(20Kb)
 
Ответить
СообщениеВсем привет! Нужна помощь. Возможно не совсем корректно обозвал заголовок темы. Вообщем, суть вопроса.

Имеем один столбец с несколькими тысячами строк. Необходимо каждые девять строк (каждая десятая - пустая) этого столбца преобразовать в одну строку. Т.е. нужен своего рода аналог функции ТРАнСПОРТИРОВАТЬ.
В прикрепленном файле выделил цветом для наглядности.

Автор - PreflopLuck
Дата добавления - 14.03.2016 в 12:19
MacSieM Дата: Понедельник, 14.03.2016, 12:30 | Сообщение № 2
Группа: Проверенные
Ранг: Участник
Сообщений: 84
Репутация: 18 ±
Замечаний: 0% ±

Excel 2010
Здравствуйте.
Один из вариантов решения.
К сообщению приложен файл: 0404603_.xlsx(32Kb)
 
Ответить
СообщениеЗдравствуйте.
Один из вариантов решения.

Автор - MacSieM
Дата добавления - 14.03.2016 в 12:30
buchlotnik Дата: Понедельник, 14.03.2016, 12:32 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 2049
Репутация: 613 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
как-то так
Код
=ИНДЕКС($A$2:$A$1000;(СТРОКА(A1)-1)*10+СТОЛБЕЦ(A1))
К сообщению приложен файл: 1318295.xlsx(23Kb)


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru
 
Ответить
Сообщениекак-то так
Код
=ИНДЕКС($A$2:$A$1000;(СТРОКА(A1)-1)*10+СТОЛБЕЦ(A1))

Автор - buchlotnik
Дата добавления - 14.03.2016 в 12:32
PreflopLuck Дата: Понедельник, 14.03.2016, 15:45 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Спасибо, ребят! Оба варианта рабочие. Как-то про ИНДЕКС я не догадался сам.
 
Ответить
СообщениеСпасибо, ребят! Оба варианта рабочие. Как-то про ИНДЕКС я не догадался сам.

Автор - PreflopLuck
Дата добавления - 14.03.2016 в 15:45
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Преобразовать данные из одного столбца в несколько строк (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!