Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Подсчет кол-ва дат за указанный период - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчет кол-ва дат за указанный период (Формулы/Formulas)
Подсчет кол-ва дат за указанный период
Leprotto Дата: Понедельник, 14.03.2016, 14:41 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 78
Репутация: 0 ±
Замечаний: 20% ±

Excel 2013
Добрый день, форумчане! Помогите, пожалуйста, подсчитать сколько дат попадают под указанные периоды.
К сообщению приложен файл: podschet_dat.xlsx(9Kb)
 
Ответить
СообщениеДобрый день, форумчане! Помогите, пожалуйста, подсчитать сколько дат попадают под указанные периоды.

Автор - Leprotto
Дата добавления - 14.03.2016 в 14:41
SLAVICK Дата: Понедельник, 14.03.2016, 14:43 | Сообщение № 2
Группа: Модераторы
Ранг: Старожил
Сообщений: 1849
Репутация: 614 ±
Замечаний: 0% ±

2007,2010,2013,2016
Так:
Код
=СЧЁТЕСЛИМН(A7:A14;">="&D1;A7:A14;"<="&F1)
К сообщению приложен файл: 6360890.xlsx(9Kb)


Иногда все проще чем кажется с первого взгляда.
 
Ответить
СообщениеТак:
Код
=СЧЁТЕСЛИМН(A7:A14;">="&D1;A7:A14;"<="&F1)

Автор - SLAVICK
Дата добавления - 14.03.2016 в 14:43
_Boroda_ Дата: Понедельник, 14.03.2016, 14:51 | Сообщение № 3
Группа: Модераторы
Ранг: Экселист
Сообщений: 9377
Репутация: 3950 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Или
Код
=СУММПРОИЗВ((A7:A14>=D1)*(A7:A14<=F1))

Но у Славика пошустрее на больших объемах
К сообщению приложен файл: podschet_dat_1.xlsx(10Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеИли
Код
=СУММПРОИЗВ((A7:A14>=D1)*(A7:A14<=F1))

Но у Славика пошустрее на больших объемах

Автор - _Boroda_
Дата добавления - 14.03.2016 в 14:51
SLAVICK Дата: Понедельник, 14.03.2016, 14:51 | Сообщение № 4
Группа: Модераторы
Ранг: Старожил
Сообщений: 1849
Репутация: 614 ±
Замечаний: 0% ±

2007,2010,2013,2016
[offtop]
как тут резиденты так быстро отписываются?

Цитата
Ловкость рук и никакого мошенничества :D

Я смотрю сообщения через "ленточный вариант" - так удобнее.[/offtop]


Иногда все проще чем кажется с первого взгляда.
 
Ответить
Сообщение[offtop]
как тут резиденты так быстро отписываются?

Цитата
Ловкость рук и никакого мошенничества :D

Я смотрю сообщения через "ленточный вариант" - так удобнее.[/offtop]

Автор - SLAVICK
Дата добавления - 14.03.2016 в 14:51
китин Дата: Понедельник, 14.03.2016, 14:56 | Сообщение № 5
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3454
Репутация: 549 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
ну или так(для всех версий)
Код
=СУММПРОИЗВ(ЕЧИСЛО($A$7:$A$14)*($A$7:$A$14<=$F$1)*($A$7:$A$14>=$D$1))

[p.s.]блин действительно а нафига тут ЕЧИСЛО?
К сообщению приложен файл: Leprotto.xlsx(10Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538


Сообщение отредактировал китин - Понедельник, 14.03.2016, 14:58
 
Ответить
Сообщениену или так(для всех версий)
Код
=СУММПРОИЗВ(ЕЧИСЛО($A$7:$A$14)*($A$7:$A$14<=$F$1)*($A$7:$A$14>=$D$1))

[p.s.]блин действительно а нафига тут ЕЧИСЛО?

Автор - китин
Дата добавления - 14.03.2016 в 14:56
Che79 Дата: Понедельник, 14.03.2016, 15:03 | Сообщение № 6
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 178
Репутация: 22 ±
Замечаний: 0% ±

Excel 2007, Excel 2010
из серии "а поизвращаться" :D
массивная
Код
=СЧЁТ(ЕСЛИ($A$7:$A$14>=D1;ЕСЛИ($A$7:$A$14<=F1;)))


Делай нормально и будет нормально!
 
Ответить
Сообщениеиз серии "а поизвращаться" :D
массивная
Код
=СЧЁТ(ЕСЛИ($A$7:$A$14>=D1;ЕСЛИ($A$7:$A$14<=F1;)))

Автор - Che79
Дата добавления - 14.03.2016 в 15:03
_Boroda_ Дата: Понедельник, 14.03.2016, 15:06 | Сообщение № 7
Группа: Модераторы
Ранг: Экселист
Сообщений: 9377
Репутация: 3950 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
из серии "а поизвращаться"

Код
=СЧЁТ(1/(A7:A14>=D1)/(A7:A14<=F1))

Массивная


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение
из серии "а поизвращаться"

Код
=СЧЁТ(1/(A7:A14>=D1)/(A7:A14<=F1))

Массивная

Автор - _Boroda_
Дата добавления - 14.03.2016 в 15:06
Che79 Дата: Понедельник, 14.03.2016, 15:13 | Сообщение № 8
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 178
Репутация: 22 ±
Замечаний: 0% ±

Excel 2007, Excel 2010
из серии "а поизвращаться"

для варианта, как в задании
массивная
Код
=СУММ(СЧЁТ(ПОИСК(D1;A7:A14));СЧЁТ(ПОИСК(F1;A7:A14)))+1
:D


Делай нормально и будет нормально!
 
Ответить
Сообщение
из серии "а поизвращаться"

для варианта, как в задании
массивная
Код
=СУММ(СЧЁТ(ПОИСК(D1;A7:A14));СЧЁТ(ПОИСК(F1;A7:A14)))+1
:D

Автор - Che79
Дата добавления - 14.03.2016 в 15:13
vikttur Дата: Понедельник, 14.03.2016, 15:21 | Сообщение № 9
Группа: Друзья
Ранг: Старожил
Сообщений: 2030
Репутация: 355 ±
Замечаний: 0% ±

Вариант для версий 2003 и старше:
Код
=СЧЁТЕСЛИ(A7:A14;">="&D1)-СЧЁТЕСЛИ(A7:A14;">"&F1)
 
Ответить
СообщениеВариант для версий 2003 и старше:
Код
=СЧЁТЕСЛИ(A7:A14;">="&D1)-СЧЁТЕСЛИ(A7:A14;">"&F1)

Автор - vikttur
Дата добавления - 14.03.2016 в 15:21
abtextime Дата: Понедельник, 14.03.2016, 15:21 | Сообщение № 10
Группа: Проверенные
Ранг: Обитатель
Сообщений: 427
Репутация: 60 ±
Замечаний: 0% ±

Excel 2010
[offtop]из серии "поизвращаться - можно все предложенные формулы просуммировать и поделить на 6
 
Ответить
Сообщение[offtop]из серии "поизвращаться - можно все предложенные формулы просуммировать и поделить на 6

Автор - abtextime
Дата добавления - 14.03.2016 в 15:21
buchlotnik Дата: Понедельник, 14.03.2016, 15:26 | Сообщение № 11
Группа: Друзья
Ранг: Старожил
Сообщений: 2049
Репутация: 613 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
Цитата
из серии "а поизвращаться"
вот такую массивку наизвращал B) :
Код
=СУММ(((A7:A14-D1)<=(F1-D1))*((A7:A14-D1)>=0))


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru
 
Ответить
Сообщение
Цитата
из серии "а поизвращаться"
вот такую массивку наизвращал B) :
Код
=СУММ(((A7:A14-D1)<=(F1-D1))*((A7:A14-D1)>=0))

Автор - buchlotnik
Дата добавления - 14.03.2016 в 15:26
Leprotto Дата: Понедельник, 14.03.2016, 15:41 | Сообщение № 12
Группа: Пользователи
Ранг: Участник
Сообщений: 78
Репутация: 0 ±
Замечаний: 20% ±

Excel 2013
SLAVICK, Благодарю, именно то, что нужно.
specool
Всех остальных тоже за оперативность! thumb
 
Ответить
СообщениеSLAVICK, Благодарю, именно то, что нужно.
specool
Всех остальных тоже за оперативность! thumb

Автор - Leprotto
Дата добавления - 14.03.2016 в 15:41
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчет кол-ва дат за указанный период (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!