Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Поиск позиции с несколькими условими - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск позиции с несколькими условими (Формулы/Formulas)
Поиск позиции с несколькими условими
heaven33rus Дата: Понедельник, 14.03.2016, 15:31 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 29
Репутация: 0 ±
Замечаний: 20% ±

Excel 2010
Всем привет, помогите с решением одного вопроса:

Есть 2 таблички в одной имена, рядом надо вставить значения у.е. из другой таблицы, где также есть имена, но у каждого имени 5 значений по 1 к каждому году.

Мне надо вставлять значения из определенного года, к примеру 2015. Как мне в свою формулу вставить еще дополнительный параметр на предмет проверки значения в столбце с годами?
К сообщению приложен файл: _01.xls(28Kb)
 
Ответить
СообщениеВсем привет, помогите с решением одного вопроса:

Есть 2 таблички в одной имена, рядом надо вставить значения у.е. из другой таблицы, где также есть имена, но у каждого имени 5 значений по 1 к каждому году.

Мне надо вставлять значения из определенного года, к примеру 2015. Как мне в свою формулу вставить еще дополнительный параметр на предмет проверки значения в столбце с годами?

Автор - heaven33rus
Дата добавления - 14.03.2016 в 15:31
_Boroda_ Дата: Понедельник, 14.03.2016, 15:43 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 9374
Репутация: 3947 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так хотите?
Код
=ИНДЕКС($J$3:$J$22;ПОИСКПОЗ(B3;$H$3:$H$22;)+n)
, где n - номер года по порядку (начиная с нуля)
или (год в С1) и года всегда в одинаковой последовательности)
Код
=ИНДЕКС($J$3:$J$22;ПОИСКПОЗ(B3;$H$3:$H$22;)+ПОИСКПОЗ(C$1;I$3:I$7;)-1)

А если года в таблице могут быть не по порядку или их для разных фамилий может быть разное количество, то вот так (формула массива, вводится одновременным нажатием Контрл Шифт Ентер)
Код
=ИНДЕКС(J$3:J$22;ПОИСКПОЗ(B3&C$1;ПРОСМОТР(СТРОКА(I$3:I$22);СТРОКА(I$3:I$22)/(H$3:H$22<>"");H$3:H$22)&I$3:I$22;))
К сообщению приложен файл: _01_1.xls(30Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак хотите?
Код
=ИНДЕКС($J$3:$J$22;ПОИСКПОЗ(B3;$H$3:$H$22;)+n)
, где n - номер года по порядку (начиная с нуля)
или (год в С1) и года всегда в одинаковой последовательности)
Код
=ИНДЕКС($J$3:$J$22;ПОИСКПОЗ(B3;$H$3:$H$22;)+ПОИСКПОЗ(C$1;I$3:I$7;)-1)

А если года в таблице могут быть не по порядку или их для разных фамилий может быть разное количество, то вот так (формула массива, вводится одновременным нажатием Контрл Шифт Ентер)
Код
=ИНДЕКС(J$3:J$22;ПОИСКПОЗ(B3&C$1;ПРОСМОТР(СТРОКА(I$3:I$22);СТРОКА(I$3:I$22)/(H$3:H$22<>"");H$3:H$22)&I$3:I$22;))

Автор - _Boroda_
Дата добавления - 14.03.2016 в 15:43
abtextime Дата: Понедельник, 14.03.2016, 15:43 | Сообщение № 3
Группа: Проверенные
Ранг: Обитатель
Сообщений: 427
Репутация: 60 ±
Замечаний: 0% ±

Excel 2010
Так? В ячейке А1 нужный год.
Код
=ИНДЕКС($J$3:$J$22;ПОИСКПОЗ(B3;$H$3:$H$22;0)+$A$1-$I$3)
К сообщению приложен файл: -01.xls(30Kb)
 
Ответить
СообщениеТак? В ячейке А1 нужный год.
Код
=ИНДЕКС($J$3:$J$22;ПОИСКПОЗ(B3;$H$3:$H$22;0)+$A$1-$I$3)

Автор - abtextime
Дата добавления - 14.03.2016 в 15:43
heaven33rus Дата: Понедельник, 14.03.2016, 15:53 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 29
Репутация: 0 ±
Замечаний: 20% ±

Excel 2010
Спасибо, большое работает!!
Но я видимо зря сделал пример с годами, сейчас усложню пример.
 
Ответить
СообщениеСпасибо, большое работает!!
Но я видимо зря сделал пример с годами, сейчас усложню пример.

Автор - heaven33rus
Дата добавления - 14.03.2016 в 15:53
_Boroda_ Дата: Понедельник, 14.03.2016, 15:54 | Сообщение № 5
Группа: Модераторы
Ранг: Экселист
Сообщений: 9374
Репутация: 3947 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Посмотрите, я там у себя в ответе добавил еще формулку для общего случая


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеПосмотрите, я там у себя в ответе добавил еще формулку для общего случая

Автор - _Boroda_
Дата добавления - 14.03.2016 в 15:54
heaven33rus Дата: Понедельник, 14.03.2016, 15:59 | Сообщение № 6
Группа: Пользователи
Ранг: Новичок
Сообщений: 29
Репутация: 0 ±
Замечаний: 20% ±

Excel 2010
Вот.
У меня на самом деле огромные таблицы, с кучей параметров, я постарался их упростить....
К сообщению приложен файл: -02.xls(31Kb)
 
Ответить
СообщениеВот.
У меня на самом деле огромные таблицы, с кучей параметров, я постарался их упростить....

Автор - heaven33rus
Дата добавления - 14.03.2016 в 15:59
_Boroda_ Дата: Понедельник, 14.03.2016, 16:04 | Сообщение № 7
Группа: Модераторы
Ранг: Экселист
Сообщений: 9374
Репутация: 3947 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Код
=ИНДЕКС($L$3:$L$22;ПОИСКПОЗ($B3;$J$3:$J$22;)+ПОИСКПОЗ(C$2;$K$3:$K$7;)-1)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение
Код
=ИНДЕКС($L$3:$L$22;ПОИСКПОЗ($B3;$J$3:$J$22;)+ПОИСКПОЗ(C$2;$K$3:$K$7;)-1)

Автор - _Boroda_
Дата добавления - 14.03.2016 в 16:04
heaven33rus Дата: Понедельник, 14.03.2016, 16:12 | Сообщение № 8
Группа: Пользователи
Ранг: Новичок
Сообщений: 29
Репутация: 0 ±
Замечаний: 20% ±

Excel 2010
Класс!!!!
То что надо, а можно еще вопрос.
В примере с массивами есть ссылка на 2015 С1, если я меняю на С2 к примеру в которую написал 2016, формула перестает работать.
Пропадают фигурные скобки в начале и в конце формулы...
Что я делаю не так?
 
Ответить
СообщениеКласс!!!!
То что надо, а можно еще вопрос.
В примере с массивами есть ссылка на 2015 С1, если я меняю на С2 к примеру в которую написал 2016, формула перестает работать.
Пропадают фигурные скобки в начале и в конце формулы...
Что я делаю не так?

Автор - heaven33rus
Дата добавления - 14.03.2016 в 16:12
_Boroda_ Дата: Понедельник, 14.03.2016, 16:15 | Сообщение № 9
Группа: Модераторы
Ранг: Экселист
Сообщений: 9374
Репутация: 3947 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Что я делаю не так?
Не читаете то, что Вам пишут :D
формула массива, вводится одновременным нажатием Контрл Шифт Ентер


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение
Что я делаю не так?
Не читаете то, что Вам пишут :D
формула массива, вводится одновременным нажатием Контрл Шифт Ентер

Автор - _Boroda_
Дата добавления - 14.03.2016 в 16:15
heaven33rus Дата: Понедельник, 14.03.2016, 16:20 | Сообщение № 10
Группа: Пользователи
Ранг: Новичок
Сообщений: 29
Репутация: 0 ±
Замечаний: 20% ±

Excel 2010
Не читаете то, что Вам пишут


И правда с контрл+шифт+энтер все работает намного лучше!!! :D

Спасибо большое еще раз!!!
 
Ответить
Сообщение
Не читаете то, что Вам пишут


И правда с контрл+шифт+энтер все работает намного лучше!!! :D

Спасибо большое еще раз!!!

Автор - heaven33rus
Дата добавления - 14.03.2016 в 16:20
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск позиции с несколькими условими (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!