Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Изменение формулы массива с добавление дополнительной функци - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Изменение формулы массива с добавление дополнительной функци (Формулы/Formulas)
Изменение формулы массива с добавление дополнительной функци
Сергей2015 Дата: Вторник, 15.03.2016, 14:01 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 35
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Приветствую всех знатоков Excel!
Появилась необходимость немного изменить расчет.
Сам не могу, не обучен этому мастерству ;-)
Файл прилагаю, там и описание.
Коротко: есть формула массива, мне необходимо просто развернуть расчет, чтобы считалось не сверху вниз, а снизу вверх. Ну и внести небольшое изменение для дополнительного расчета целых значений, да и десятичных.
Для знающего человека, это 2 минуты.
По возможности максимально все расписал в файле с указанием что и где.
Большая просьба помочь горююююю.
Заранее благодарен.
С уважением.
[moder]Переназовите тему согласно п.2 Правил форума

ИСПРАВЛЕНО
К сообщению приложен файл: _-.xlsb(70Kb)


Сообщение отредактировал _Boroda_ - Вторник, 15.03.2016, 15:52
 
Ответить
СообщениеПриветствую всех знатоков Excel!
Появилась необходимость немного изменить расчет.
Сам не могу, не обучен этому мастерству ;-)
Файл прилагаю, там и описание.
Коротко: есть формула массива, мне необходимо просто развернуть расчет, чтобы считалось не сверху вниз, а снизу вверх. Ну и внести небольшое изменение для дополнительного расчета целых значений, да и десятичных.
Для знающего человека, это 2 минуты.
По возможности максимально все расписал в файле с указанием что и где.
Большая просьба помочь горююююю.
Заранее благодарен.
С уважением.
[moder]Переназовите тему согласно п.2 Правил форума

ИСПРАВЛЕНО

Автор - Сергей2015
Дата добавления - 15.03.2016 в 14:01
_Boroda_ Дата: Вторник, 15.03.2016, 15:58 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 9352
Репутация: 3924 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Для L2
Код
=ЕСЛИ(ЕЧИСЛО(ПОИСКПОЗ(L$1;$C2:$K2;));ОТБР(МАКС(L3:L$202))+1;ОСТАТ(L3;1)+0,001)
К сообщению приложен файл: -156.xlsb(22Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеДля L2
Код
=ЕСЛИ(ЕЧИСЛО(ПОИСКПОЗ(L$1;$C2:$K2;));ОТБР(МАКС(L3:L$202))+1;ОСТАТ(L3;1)+0,001)

Автор - _Boroda_
Дата добавления - 15.03.2016 в 15:58
Сергей2015 Дата: Вторник, 15.03.2016, 16:17 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 35
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Для L2

Все супер, работает.
Спасибо большое.
С уважением.

Тему можно закрыть вопрос решен.
 
Ответить
Сообщение
Для L2

Все супер, работает.
Спасибо большое.
С уважением.

Тему можно закрыть вопрос решен.

Автор - Сергей2015
Дата добавления - 15.03.2016 в 16:17
Сергей2015 Дата: Среда, 16.03.2016, 14:29 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 35
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Для L2


Уважаемый _Boroda_
большая просьба к вам, можно сделать так, чтобы расчет целых значений можно было вести сверху вниз на увеличение?
Заранее признателен.
С уважением.
 
Ответить
Сообщение
Для L2


Уважаемый _Boroda_
большая просьба к вам, можно сделать так, чтобы расчет целых значений можно было вести сверху вниз на увеличение?
Заранее признателен.
С уважением.

Автор - Сергей2015
Дата добавления - 16.03.2016 в 14:29
_Boroda_ Дата: Среда, 16.03.2016, 14:32 | Сообщение № 5
Группа: Модераторы
Ранг: Экселист
Сообщений: 9352
Репутация: 3924 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так?
Код
=ЕСЛИ(СЧЁТЕСЛИ($C2:$K2;L$1);СЧЁТЕСЛИ($C$2:$K2;L$1);ОСТАТ(L3;1)+0,001)

Основано на том, что где-то в своих предыдущих темах Вы писали, что в одной строке С:К не может быть одинаковых чисел
К сообщению приложен файл: -156_3.xlsb(23Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак?
Код
=ЕСЛИ(СЧЁТЕСЛИ($C2:$K2;L$1);СЧЁТЕСЛИ($C$2:$K2;L$1);ОСТАТ(L3;1)+0,001)

Основано на том, что где-то в своих предыдущих темах Вы писали, что в одной строке С:К не может быть одинаковых чисел

Автор - _Boroda_
Дата добавления - 16.03.2016 в 14:32
Сергей2015 Дата: Среда, 16.03.2016, 14:37 | Сообщение № 6
Группа: Пользователи
Ранг: Новичок
Сообщений: 35
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007

Супер!!!
ОГРОМНОЕ СПАСИБО!!!
С уважением.
 
Ответить
Сообщение
Супер!!!
ОГРОМНОЕ СПАСИБО!!!
С уважением.

Автор - Сергей2015
Дата добавления - 16.03.2016 в 14:37
Сергей2015 Дата: Понедельник, 02.05.2016, 23:00 | Сообщение № 7
Группа: Пользователи
Ранг: Новичок
Сообщений: 35
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Доброго времени суток.
Появилась необходимость подкорректировать формулу массива.
В файле все постарался описать.

Был бы очень признателен, если бы помог именно Boroda, т.к. уже неоднократно помогал именно с этим вопросом.
Если кто откликнется раньше, так же буду признателен за помощь.

Заранее благодарен.

С уважением.
К сообщению приложен файл: 3991251.xlsb(29Kb)


Сообщение отредактировал Сергей2015 - Вторник, 03.05.2016, 11:58
 
Ответить
СообщениеДоброго времени суток.
Появилась необходимость подкорректировать формулу массива.
В файле все постарался описать.

Был бы очень признателен, если бы помог именно Boroda, т.к. уже неоднократно помогал именно с этим вопросом.
Если кто откликнется раньше, так же буду признателен за помощь.

Заранее благодарен.

С уважением.

Автор - Сергей2015
Дата добавления - 02.05.2016 в 23:00
_Boroda_ Дата: Вторник, 03.05.2016, 13:01 | Сообщение № 8
Группа: Модераторы
Ранг: Экселист
Сообщений: 9352
Репутация: 3924 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так?
Код
=ЕСЛИ($A3<>"";ЕСЛИ(ЕЧИСЛО(ПОИСКПОЗ(M$1;$C3:$K3;));ОТБР(МАКС(L2:L$202))+0,04;M3-0,003);2-0,01)

И посмотрите, сколько у Вас там правил условного форматирования. Переходите с 2007 на 2010 - там они (правила) не будут размножаться, условия не те. В файле поудалял всё ненужное
К сообщению приложен файл: 3991251_1.xlsb(24Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак?
Код
=ЕСЛИ($A3<>"";ЕСЛИ(ЕЧИСЛО(ПОИСКПОЗ(M$1;$C3:$K3;));ОТБР(МАКС(L2:L$202))+0,04;M3-0,003);2-0,01)

И посмотрите, сколько у Вас там правил условного форматирования. Переходите с 2007 на 2010 - там они (правила) не будут размножаться, условия не те. В файле поудалял всё ненужное

Автор - _Boroda_
Дата добавления - 03.05.2016 в 13:01
Сергей2015 Дата: Вторник, 03.05.2016, 13:20 | Сообщение № 9
Группа: Пользователи
Ранг: Новичок
Сообщений: 35
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
=ЕСЛИ($A3<>"";ЕСЛИ(ЕЧИСЛО(ПОИСКПОЗ(M$1;$C3:$K3;));ОТБР(МАКС(L2:L$202))+0,04;M3-0,003);2-0,01)

Нет, не то что необходимо. Целые значения не соответствуют. Если заносить число 2 несколько раз, то в самом расчете не соответствует его кол-во в закрашенной ячейке. Не знаю как еще объяснить, в примере вроде и так наглядно все показал.

З.Ы. файл перезалил.
С уважением.
К сообщению приложен файл: 2468500.xlsb(30Kb)


Сообщение отредактировал Сергей2015 - Вторник, 03.05.2016, 14:57
 
Ответить
Сообщение
=ЕСЛИ($A3<>"";ЕСЛИ(ЕЧИСЛО(ПОИСКПОЗ(M$1;$C3:$K3;));ОТБР(МАКС(L2:L$202))+0,04;M3-0,003);2-0,01)

Нет, не то что необходимо. Целые значения не соответствуют. Если заносить число 2 несколько раз, то в самом расчете не соответствует его кол-во в закрашенной ячейке. Не знаю как еще объяснить, в примере вроде и так наглядно все показал.

З.Ы. файл перезалил.
С уважением.

Автор - Сергей2015
Дата добавления - 03.05.2016 в 13:20
_Boroda_ Дата: Вторник, 03.05.2016, 15:05 | Сообщение № 10
Группа: Модераторы
Ранг: Экселист
Сообщений: 9352
Репутация: 3924 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Результат именно такой, как у Вас в примере.
Для М2
Код
=ЕСЛИ(ЕЧИСЛО(ПОИСКПОЗ(M$1;$C2:$K2;));МАКС(M3:M$202)+1;M3)
К сообщению приложен файл: 2468500_1.xlsb(23Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеРезультат именно такой, как у Вас в примере.
Для М2
Код
=ЕСЛИ(ЕЧИСЛО(ПОИСКПОЗ(M$1;$C2:$K2;));МАКС(M3:M$202)+1;M3)

Автор - _Boroda_
Дата добавления - 03.05.2016 в 15:05
Сергей2015 Дата: Вторник, 03.05.2016, 15:14 | Сообщение № 11
Группа: Пользователи
Ранг: Новичок
Сообщений: 35
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
ЕСЛИ(ЕЧИСЛО(ПОИСКПОЗ(M$1;$C2:$K2;));МАКС(M3:M$202)+1;M3)

Да, все верно, огромное спасибо.
С тысячными значениями чуть позже тогда опишу что требуется.
Еще раз огромное спасибо.
С уважением.
 
Ответить
Сообщение
ЕСЛИ(ЕЧИСЛО(ПОИСКПОЗ(M$1;$C2:$K2;));МАКС(M3:M$202)+1;M3)

Да, все верно, огромное спасибо.
С тысячными значениями чуть позже тогда опишу что требуется.
Еще раз огромное спасибо.
С уважением.

Автор - Сергей2015
Дата добавления - 03.05.2016 в 15:14
akkord87 Дата: Среда, 04.05.2016, 11:49 | Сообщение № 12
Группа: Пользователи
Ранг: Новичок
Сообщений: 16
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Отличная формула, себе в копилку)
 
Ответить
СообщениеОтличная формула, себе в копилку)

Автор - akkord87
Дата добавления - 04.05.2016 в 11:49
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Изменение формулы массива с добавление дополнительной функци (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!