Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Не могу понять почему формула (ЕСЛИ) не считает. - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Не могу понять почему формула (ЕСЛИ) не считает. (Формулы/Formulas)
Не могу понять почему формула (ЕСЛИ) не считает.
dkonst Дата: Вторник, 15.03.2016, 21:35 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 40% ±

Excel 2007
В общем суть такова
В ячейке Лист2-Е2 формула
Код
=ЕСЛИ(C2=MC!A$6;ЕСЛИ(D2=MC!B$6;MC!D$6);ЕСЛИ(C2=MC!A$7;ЕСЛИ(D2=MC!B$7;MC!D$7);ЕСЛИ(C2=MC!A$8;ЕСЛИ(D2=MC!B$8;MC!D$8);ЕСЛИ(C2=MC!A$9;ЕСЛИ(D2=MC!B$9;MC!D$9);ЕСЛИ(C2=MC!A$10;ЕСЛИ(D2=MC!B$10;MC!D$10);ЕСЛИ(C2=MC!A$11;ЕСЛИ(D2=MC!B$11;MC!D$11);ЕСЛИ(C2=MC!A$12;ЕСЛИ(D2=MC!B$12;MC!D$12))))))))

выдает "ЛОЖЬ"
хотя точно такая же формула строкой выше работает.
Может кто-нибудь из знатаков уделит пару минут и глянет почему не работает
1. пробел после цифры ="6 "и ="8 " одинаковый
2. если в D2 поменять ="6 " на ="8 ", то считает верно.
Формат значений на листе МС поменять нельзя
[moder]Вообще-то название темы противоречит п.2 Правил форума. Правда, я не представляю, как еще можно назвать, поэтому, в порядке исключения, предлагаю пропустить.
А вот формулы нужно не под спойлер класть, а есть специальный тег для этого - кнопка fx. Об этом в Правилах формума тоже написано. И ссылка-объяснялка есть. Поправил Вам на первый раз
 
Ответить
СообщениеВ общем суть такова
В ячейке Лист2-Е2 формула
Код
=ЕСЛИ(C2=MC!A$6;ЕСЛИ(D2=MC!B$6;MC!D$6);ЕСЛИ(C2=MC!A$7;ЕСЛИ(D2=MC!B$7;MC!D$7);ЕСЛИ(C2=MC!A$8;ЕСЛИ(D2=MC!B$8;MC!D$8);ЕСЛИ(C2=MC!A$9;ЕСЛИ(D2=MC!B$9;MC!D$9);ЕСЛИ(C2=MC!A$10;ЕСЛИ(D2=MC!B$10;MC!D$10);ЕСЛИ(C2=MC!A$11;ЕСЛИ(D2=MC!B$11;MC!D$11);ЕСЛИ(C2=MC!A$12;ЕСЛИ(D2=MC!B$12;MC!D$12))))))))

выдает "ЛОЖЬ"
хотя точно такая же формула строкой выше работает.
Может кто-нибудь из знатаков уделит пару минут и глянет почему не работает
1. пробел после цифры ="6 "и ="8 " одинаковый
2. если в D2 поменять ="6 " на ="8 ", то считает верно.
Формат значений на листе МС поменять нельзя
[moder]Вообще-то название темы противоречит п.2 Правил форума. Правда, я не представляю, как еще можно назвать, поэтому, в порядке исключения, предлагаю пропустить.
А вот формулы нужно не под спойлер класть, а есть специальный тег для этого - кнопка fx. Об этом в Правилах формума тоже написано. И ссылка-объяснялка есть. Поправил Вам на первый раз

Автор - dkonst
Дата добавления - 15.03.2016 в 21:35
buchlotnik Дата: Вторник, 15.03.2016, 21:45 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 2049
Репутация: 613 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
файл будет?


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru
 
Ответить
Сообщениефайл будет?

Автор - buchlotnik
Дата добавления - 15.03.2016 в 21:45
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Не могу понять почему формула (ЕСЛИ) не считает. (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!