Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Найти медиану в каждом месяце в течении 36 лет - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Найти медиану в каждом месяце в течении 36 лет (Формулы/Formulas)
Найти медиану в каждом месяце в течении 36 лет
Anna93Anna Дата: Среда, 16.03.2016, 21:28 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Здравствуйте все! Очень нужна помощь!
У меня есть данные о значениях некого индекса, эти данные ведутся с 1980 год по 2016 почти каждый день, и того ~4000 значений. Нужно изменить частоту с которой велись эти значения, т.е с периодичность не в день, а в месяц. В качестве значения индекса взять медиану за указанный месяц!
Как это реализовать? В ручную находить медиану для такого огромного количества лет невозможно! Предполагаю, что это можно решить через сводные таблицы, но пока ничего не вышло
Очень надеюсь на вашу помощь pray :pray:
[moder]Покажите кусок данных в файле. За год-два. Только в таком же виде, как у Вас в родном файле.
К сообщению приложен файл: 8246177.xlsx(96Kb)


Сообщение отредактировал Anna93Anna - Среда, 16.03.2016, 21:43
 
Ответить
СообщениеЗдравствуйте все! Очень нужна помощь!
У меня есть данные о значениях некого индекса, эти данные ведутся с 1980 год по 2016 почти каждый день, и того ~4000 значений. Нужно изменить частоту с которой велись эти значения, т.е с периодичность не в день, а в месяц. В качестве значения индекса взять медиану за указанный месяц!
Как это реализовать? В ручную находить медиану для такого огромного количества лет невозможно! Предполагаю, что это можно решить через сводные таблицы, но пока ничего не вышло
Очень надеюсь на вашу помощь pray :pray:
[moder]Покажите кусок данных в файле. За год-два. Только в таком же виде, как у Вас в родном файле.

Автор - Anna93Anna
Дата добавления - 16.03.2016 в 21:28
buchlotnik Дата: Среда, 16.03.2016, 21:54 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 2049
Репутация: 613 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
как-то так (массивка)
Код
=МЕДИАНА(ЕСЛИ((ТЕКСТ($A$2:$A$524;"ГГГГ-ММ")=D2)*ЕЧИСЛО($B$2:$B$524);$B$2:$B$524;""))


на формат столбца А не глянул - так, возможно, лучше - даты тягабельны (см. второй файл)
Код
=МЕДИАНА(ЕСЛИ((ТЕКСТ($A$2:$A$524;"ММГГ")=ТЕКСТ(D2;"ММГГ"))*ЕЧИСЛО($B$2:$B$524);$B$2:$B$524;""))
К сообщению приложен файл: 6096314-1-.xlsx(97Kb) · 5473175.xlsx(98Kb)


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru


Сообщение отредактировал buchlotnik - Среда, 16.03.2016, 22:09
 
Ответить
Сообщениекак-то так (массивка)
Код
=МЕДИАНА(ЕСЛИ((ТЕКСТ($A$2:$A$524;"ГГГГ-ММ")=D2)*ЕЧИСЛО($B$2:$B$524);$B$2:$B$524;""))


на формат столбца А не глянул - так, возможно, лучше - даты тягабельны (см. второй файл)
Код
=МЕДИАНА(ЕСЛИ((ТЕКСТ($A$2:$A$524;"ММГГ")=ТЕКСТ(D2;"ММГГ"))*ЕЧИСЛО($B$2:$B$524);$B$2:$B$524;""))

Автор - buchlotnik
Дата добавления - 16.03.2016 в 21:54
Anna93Anna Дата: Среда, 16.03.2016, 22:06 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
buchlotnik, огромное спасибо! Не ожидала столь оперативный ответ! girl_dance
 
Ответить
Сообщениеbuchlotnik, огромное спасибо! Не ожидала столь оперативный ответ! girl_dance

Автор - Anna93Anna
Дата добавления - 16.03.2016 в 22:06
_Boroda_ Дата: Среда, 16.03.2016, 22:14 | Сообщение № 4
Группа: Модераторы
Ранг: Экселист
Сообщений: 9381
Репутация: 3951 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Немассивная формула
Код
=МЕДИАНА(ИНДЕКС(B$2:B$999;ЕСЛИОШИБКА(ПОИСКПОЗ(D2-0,1;A$2:A$999);)+1):ИНДЕКС(B$2:B$999;ПОИСКПОЗ(ДАТАМЕС(D2;1)-1;A$2:A$999)))
К сообщению приложен файл: 6096314_1.xlsx(100Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеНемассивная формула
Код
=МЕДИАНА(ИНДЕКС(B$2:B$999;ЕСЛИОШИБКА(ПОИСКПОЗ(D2-0,1;A$2:A$999);)+1):ИНДЕКС(B$2:B$999;ПОИСКПОЗ(ДАТАМЕС(D2;1)-1;A$2:A$999)))

Автор - _Boroda_
Дата добавления - 16.03.2016 в 22:14
Anna93Anna Дата: Среда, 16.03.2016, 22:23 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
_Boroda_, спасибо! specool
 
Ответить
Сообщение_Boroda_, спасибо! specool

Автор - Anna93Anna
Дата добавления - 16.03.2016 в 22:23
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Найти медиану в каждом месяце в течении 36 лет (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!