Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Замена в номере телефона первой цифры 8 на +7 - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Замена в номере телефона первой цифры 8 на +7 (Замена в номере телефона первой цифры 8 на +7)
Замена в номере телефона первой цифры 8 на +7
qwertyman Дата: Четверг, 17.03.2016, 15:40 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Здравствуйте! Наверное уже обсуждали, но не могу найти на форуме. Как заменить в номере телефона первую цифру 8 на +7
 
Ответить
СообщениеЗдравствуйте! Наверное уже обсуждали, но не могу найти на форуме. Как заменить в номере телефона первую цифру 8 на +7

Автор - qwertyman
Дата добавления - 17.03.2016 в 15:40
qwertyman Дата: Четверг, 17.03.2016, 15:40 | Сообщение № 2
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Спасибо!
 
Ответить
СообщениеСпасибо!

Автор - qwertyman
Дата добавления - 17.03.2016 в 15:40
Udik Дата: Четверг, 17.03.2016, 15:45 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 1586
Репутация: 191 ±
Замечаний: 0% ±

Excel 2016 х 64
Функция ЗАМЕНИТЬ, например


вот вам барабан
яд 41001231307558 wm R419131876897
udik1968@gmail.com
 
Ответить
СообщениеФункция ЗАМЕНИТЬ, например

Автор - Udik
Дата добавления - 17.03.2016 в 15:45
abtextime Дата: Четверг, 17.03.2016, 15:46 | Сообщение № 4
Группа: Проверенные
Ранг: Обитатель
Сообщений: 427
Репутация: 60 ±
Замечаний: 0% ±

Excel 2010
Если телефон ВСЕГДА начинается с 8, то

Код
="+7"&правб(A1;длстр(A1)-1)
 
Ответить
СообщениеЕсли телефон ВСЕГДА начинается с 8, то

Код
="+7"&правб(A1;длстр(A1)-1)

Автор - abtextime
Дата добавления - 17.03.2016 в 15:46
Che79 Дата: Четверг, 17.03.2016, 15:47 | Сообщение № 5
Группа: Проверенные
Ранг: Обитатель
Сообщений: 454
Репутация: 71 ±
Замечаний: 0% ±

Excel 2010 RUS
qwertyman, добрый день.
Если совсем примитивно, то
Код
=ЗАМЕНИТЬ(A1;1;1;"+7")

где в А1 номер телефона без пробелов-дефисов и т.п.


Делай нормально и будет нормально!

Сообщение отредактировал Che79 - Четверг, 17.03.2016, 15:48
 
Ответить
Сообщениеqwertyman, добрый день.
Если совсем примитивно, то
Код
=ЗАМЕНИТЬ(A1;1;1;"+7")

где в А1 номер телефона без пробелов-дефисов и т.п.

Автор - Che79
Дата добавления - 17.03.2016 в 15:47
_Boroda_ Дата: Четверг, 17.03.2016, 15:56 | Сообщение № 6
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11269
Репутация: 4656 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Код
="+7"&ПСТР(A1;2;99)

Код
=ПОДСТАВИТЬ(A1;8;"+7";1)

Код
=ТЕКСТ(ПСТР(A1;2;10);"+70")

Код
="+"&A1-10^10

Код
="+"&A1-1E+10
К сообщению приложен файл: 87952797.xlsx(8Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение
Код
="+7"&ПСТР(A1;2;99)

Код
=ПОДСТАВИТЬ(A1;8;"+7";1)

Код
=ТЕКСТ(ПСТР(A1;2;10);"+70")

Код
="+"&A1-10^10

Код
="+"&A1-1E+10

Автор - _Boroda_
Дата добавления - 17.03.2016 в 15:56
abtextime Дата: Четверг, 17.03.2016, 16:02 | Сообщение № 7
Группа: Проверенные
Ранг: Обитатель
Сообщений: 427
Репутация: 60 ±
Замечаний: 0% ±

Excel 2010
[offtop]Последняя формула самая интуитивно понятная, именно ее и надо применять :)
 
Ответить
Сообщение[offtop]Последняя формула самая интуитивно понятная, именно ее и надо применять :)

Автор - abtextime
Дата добавления - 17.03.2016 в 16:02
qwertyman Дата: Четверг, 17.03.2016, 16:07 | Сообщение № 8
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
_Boroda_, Спасибо!
 
Ответить
Сообщение_Boroda_, Спасибо!

Автор - qwertyman
Дата добавления - 17.03.2016 в 16:07
qwertyman Дата: Четверг, 17.03.2016, 16:09 | Сообщение № 9
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
_Boroda_, Только сейчас увидел все варианты, просто БОМБА) respect
 
Ответить
Сообщение_Boroda_, Только сейчас увидел все варианты, просто БОМБА) respect

Автор - qwertyman
Дата добавления - 17.03.2016 в 16:09
astoxer Дата: Четверг, 17.03.2016, 19:58 | Сообщение № 10
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 20% ±

Excel 2010
=ТЕКСТ(ПСТР(A1;2;10);"+70")

="+"&A1-10^10

эти варианты криво работают если номер не 10 значный :)
[moder]Вы не поверите, но все в курсе.


Сообщение отредактировал _Boroda_ - Четверг, 17.03.2016, 20:56
 
Ответить
Сообщение
=ТЕКСТ(ПСТР(A1;2;10);"+70")

="+"&A1-10^10

эти варианты криво работают если номер не 10 значный :)
[moder]Вы не поверите, но все в курсе.

Автор - astoxer
Дата добавления - 17.03.2016 в 19:58
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Замена в номере телефона первой цифры 8 на +7 (Замена в номере телефона первой цифры 8 на +7)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!