Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Подставить предыдущее число до следующей занятой ячейки. - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подставить предыдущее число до следующей занятой ячейки. (Формулы/Formulas)
Подставить предыдущее число до следующей занятой ячейки.
ShaD Дата: Четверг, 17.03.2016, 16:17 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 22
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Добрый день.
Помогите, пожалуйста, разобраться.
В столбике "A" много пробелов, необходимо подставить в пустую ячейку предыдущее число. Другими словами - число в ячейке: A6,A7,A8 - должно стать таким же как и в ячейке А5.
Заранее спасибо =)
К сообщению приложен файл: test.xlsx(71Kb)
 
Ответить
СообщениеДобрый день.
Помогите, пожалуйста, разобраться.
В столбике "A" много пробелов, необходимо подставить в пустую ячейку предыдущее число. Другими словами - число в ячейке: A6,A7,A8 - должно стать таким же как и в ячейке А5.
Заранее спасибо =)

Автор - ShaD
Дата добавления - 17.03.2016 в 16:17
abtextime Дата: Четверг, 17.03.2016, 16:21 | Сообщение № 2
Группа: Проверенные
Ранг: Обитатель
Сообщений: 427
Репутация: 60 ±
Замечаний: 0% ±

Excel 2010
sry
К сообщению приложен файл: _test.xlsx(76Kb)


Сообщение отредактировал abtextime - Четверг, 17.03.2016, 16:23
 
Ответить
Сообщениеsry

Автор - abtextime
Дата добавления - 17.03.2016 в 16:21
_Boroda_ Дата: Четверг, 17.03.2016, 16:24 | Сообщение № 3
Группа: Модераторы
Ранг: Экселист
Сообщений: 9374
Репутация: 3947 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Выделяем столбец А - F5 (или Главная - Найти и выделить - Группу ячеек) - Выделить - Пустые ячейки - набираем на клавиатуре = и жмем стрелку вверх - жмем одновременно Контрл Ентер.
Снова выделяем столбец А - копируем - Спецвставка - Значения.
Затем удаляем лишнее снизу (если оно вдруг есть).

Или простенький макрос
[vba]
Код
Sub Zapolnenye_Null()
On Error GoTo A
    n = Selection.Address
    If Range(n).Cells.Count - 1 Then
        Selection.SpecialCells(xlCellTypeBlanks).FormulaR1C1 = "=R[-1]C"
        Range(n) = Range(n).Value
    End If
A:     Exit Sub
End Sub
[/vba]


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеВыделяем столбец А - F5 (или Главная - Найти и выделить - Группу ячеек) - Выделить - Пустые ячейки - набираем на клавиатуре = и жмем стрелку вверх - жмем одновременно Контрл Ентер.
Снова выделяем столбец А - копируем - Спецвставка - Значения.
Затем удаляем лишнее снизу (если оно вдруг есть).

Или простенький макрос
[vba]
Код
Sub Zapolnenye_Null()
On Error GoTo A
    n = Selection.Address
    If Range(n).Cells.Count - 1 Then
        Selection.SpecialCells(xlCellTypeBlanks).FormulaR1C1 = "=R[-1]C"
        Range(n) = Range(n).Value
    End If
A:     Exit Sub
End Sub
[/vba]

Автор - _Boroda_
Дата добавления - 17.03.2016 в 16:24
abtextime Дата: Четверг, 17.03.2016, 16:26 | Сообщение № 4
Группа: Проверенные
Ранг: Обитатель
Сообщений: 427
Репутация: 60 ±
Замечаний: 0% ±

Excel 2010
Код
=ЕСЛИ(A3="";C2;A3)
К сообщению приложен файл: 9300931.xlsx(78Kb)


Сообщение отредактировал abtextime - Четверг, 17.03.2016, 16:26
 
Ответить
Сообщение
Код
=ЕСЛИ(A3="";C2;A3)

Автор - abtextime
Дата добавления - 17.03.2016 в 16:26
gling Дата: Четверг, 17.03.2016, 16:26 | Сообщение № 5
Группа: Друзья
Ранг: Старожил
Сообщений: 1351
Репутация: 325 ±
Замечаний: 0% ±

2010
Посмотрите здесь
 
Ответить
СообщениеПосмотрите здесь

Автор - gling
Дата добавления - 17.03.2016 в 16:26
ShaD Дата: Четверг, 17.03.2016, 16:28 | Сообщение № 6
Группа: Пользователи
Ранг: Новичок
Сообщений: 22
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Всем спасибо =) Проблема решена =)
 
Ответить
СообщениеВсем спасибо =) Проблема решена =)

Автор - ShaD
Дата добавления - 17.03.2016 в 16:28
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подставить предыдущее число до следующей занятой ячейки. (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!