Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Вывести сообщение о наличии повторяющихся значений в столбце - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вывести сообщение о наличии повторяющихся значений в столбце (Формулы/Formulas)
Вывести сообщение о наличии повторяющихся значений в столбце
kepkst Дата: Суббота, 19.03.2016, 13:22 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 58
Репутация: 0 ±
Замечаний: 80% ±

Excel 2010
Здравствуйте.
Есть таблица со значениями и формула любезно предоставленная gling в ветке http://www.excelworld.ru/forum/2-22219-1#179251
Но никак не могу решить проблему, чтобы не учитывались значения равные нулю. Т.е. всё работает нормально пока вместо числового значения не появляется ноль (а нулей избежать не удаётся).
Надеюсь на помощь.
Спасибо.
К сообщению приложен файл: ____gling.xls(74Kb)


Сообщение отредактировал kepkst - Суббота, 19.03.2016, 13:23
 
Ответить
СообщениеЗдравствуйте.
Есть таблица со значениями и формула любезно предоставленная gling в ветке http://www.excelworld.ru/forum/2-22219-1#179251
Но никак не могу решить проблему, чтобы не учитывались значения равные нулю. Т.е. всё работает нормально пока вместо числового значения не появляется ноль (а нулей избежать не удаётся).
Надеюсь на помощь.
Спасибо.

Автор - kepkst
Дата добавления - 19.03.2016 в 13:22
Nic70y Дата: Суббота, 19.03.2016, 14:02 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3492
Репутация: 723 ±
Замечаний: 0% ±

Excel 2013
вариант
Код
=ЕСЛИ(СЧЁТ(ЕСЛИ(ПОИСКПОЗ(ЕСЛИ(--(0&A5:A1059)<>0;A5:A1059);A5:A1059;)<>СТРОКА(A5:A1059)-4;СТРОКА(A5:A1059)));"Есть дубликаты";"Нет повторов")
К сообщению приложен файл: 14.xls(74Kb)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщениевариант
Код
=ЕСЛИ(СЧЁТ(ЕСЛИ(ПОИСКПОЗ(ЕСЛИ(--(0&A5:A1059)<>0;A5:A1059);A5:A1059;)<>СТРОКА(A5:A1059)-4;СТРОКА(A5:A1059)));"Есть дубликаты";"Нет повторов")

Автор - Nic70y
Дата добавления - 19.03.2016 в 14:02
_Boroda_ Дата: Суббота, 19.03.2016, 14:26 | Сообщение № 3
Группа: Модераторы
Ранг: Экселист
Сообщений: 9377
Репутация: 3950 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Еще вариант (формула массива, вводится одновременным нажатием Контрл Шифт Ентер)
Код
=СУММ(--(СЧЁТЕСЛИ(A4:A1053;ЕСЛИ(A4:A1053;A4:A1053))>1))

И формат ячеек
"Есть дубликаты";;"Нет повторов"
К сообщению приложен файл: _gling_1.xls(74Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЕще вариант (формула массива, вводится одновременным нажатием Контрл Шифт Ентер)
Код
=СУММ(--(СЧЁТЕСЛИ(A4:A1053;ЕСЛИ(A4:A1053;A4:A1053))>1))

И формат ячеек
"Есть дубликаты";;"Нет повторов"

Автор - _Boroda_
Дата добавления - 19.03.2016 в 14:26
kepkst Дата: Воскресенье, 20.03.2016, 09:45 | Сообщение № 4
Группа: Пользователи
Ранг: Участник
Сообщений: 58
Репутация: 0 ±
Замечаний: 80% ±

Excel 2010
Спасибо за помощь!!!
Работают оба варианта.
Применил вариант от _Boroda_.
Вы мне ОЧЕНЬ помогли.

PS: Почему-то файл 14.xls(74Kb) от Nic70y открывается с предупреждением о вредоносном содержимом (я открывать не стал).
 
Ответить
СообщениеСпасибо за помощь!!!
Работают оба варианта.
Применил вариант от _Boroda_.
Вы мне ОЧЕНЬ помогли.

PS: Почему-то файл 14.xls(74Kb) от Nic70y открывается с предупреждением о вредоносном содержимом (я открывать не стал).

Автор - kepkst
Дата добавления - 20.03.2016 в 09:45
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вывести сообщение о наличии повторяющихся значений в столбце (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!