Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Выборка данных из общего списка - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выборка данных из общего списка (Формулы/Formulas)
Выборка данных из общего списка
Protorivatel Дата: Воскресенье, 20.03.2016, 00:18 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 17
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Здравствуйте форумчане!

Помогите решить данную задачу: Есть данные и соответствующие им исполнители (Таблица 1).
Как сделать автоматическую выборку данных по исполнителям (Таблица 2), т.е. автоматическое заполнение желтых ячеек?

Файл прилагаю.
Благодарю за внимание!
К сообщению приложен файл: _1.xlsx(9Kb)
 
Ответить
СообщениеЗдравствуйте форумчане!

Помогите решить данную задачу: Есть данные и соответствующие им исполнители (Таблица 1).
Как сделать автоматическую выборку данных по исполнителям (Таблица 2), т.е. автоматическое заполнение желтых ячеек?

Файл прилагаю.
Благодарю за внимание!

Автор - Protorivatel
Дата добавления - 20.03.2016 в 00:18
Serge_007 Дата: Воскресенье, 20.03.2016, 00:31 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 13075
Репутация: ±
Замечаний: ±

Excel 2010
Protorivatel, здравствуйте

Формула массива:
Код
=ИНДЕКС($A$3:$A$17;НАИМЕНЬШИЙ(ЕСЛИ($B$3:$B$17=G$2;СТРОКА($1:$15));СТРОКА(A1)))
К сообщению приложен файл: 20160320_Protor.xls(34Kb)


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
СообщениеProtorivatel, здравствуйте

Формула массива:
Код
=ИНДЕКС($A$3:$A$17;НАИМЕНЬШИЙ(ЕСЛИ($B$3:$B$17=G$2;СТРОКА($1:$15));СТРОКА(A1)))

Автор - Serge_007
Дата добавления - 20.03.2016 в 00:31
dima_dan2012 Дата: Воскресенье, 20.03.2016, 13:02 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 36
Репутация: 7 ±
Замечаний: 0% ±

Excel 2003,2007
Здравствуйте!
Снял привязку от ФИО
К сообщению приложен файл: 20160320_Protor.xlsm(16Kb)
 
Ответить
СообщениеЗдравствуйте!
Снял привязку от ФИО

Автор - dima_dan2012
Дата добавления - 20.03.2016 в 13:02
Protorivatel Дата: Воскресенье, 20.03.2016, 18:04 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 17
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Спасибо за ответы!

Но как расширить число строк для выборки? Меняю диапазоны в формуле до, например, 40 и ничего, тупо оставляет Данные1. Что не так меняю?
К сообщению приложен файл: Protor.xlsm(16Kb)
 
Ответить
СообщениеСпасибо за ответы!

Но как расширить число строк для выборки? Меняю диапазоны в формуле до, например, 40 и ничего, тупо оставляет Данные1. Что не так меняю?

Автор - Protorivatel
Дата добавления - 20.03.2016 в 18:04
Pelena Дата: Воскресенье, 20.03.2016, 18:10 | Сообщение № 5
Группа: Модераторы
Ранг: Экселист
Сообщений: 9879
Репутация: 2265 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
Вводите формулу как формулу массива Ctrl+Shift+Enter


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеВводите формулу как формулу массива Ctrl+Shift+Enter

Автор - Pelena
Дата добавления - 20.03.2016 в 18:10
gling Дата: Воскресенье, 20.03.2016, 18:49 | Сообщение № 6
Группа: Друзья
Ранг: Старожил
Сообщений: 1352
Репутация: 326 ±
Замечаний: 0% ±

2010
Здравствуйте.
Цитата
Вводите формулу как формулу массива Ctrl+Shift+Enter
и может для упрощения формулу можно записать так
Код
=ИНДЕКС($A$1:$A$17;НАИМЕНЬШИЙ(ЕСЛИ($B$3:$B$17=G$2;СТРОКА($B$3:$B$17));СТРОКА(A1)))
, чтобы СТРОКА($1:$15) не путала, достаточно сменить везде нижний предел, 17 на 40 например..


Сообщение отредактировал gling - Воскресенье, 20.03.2016, 18:52
 
Ответить
СообщениеЗдравствуйте.
Цитата
Вводите формулу как формулу массива Ctrl+Shift+Enter
и может для упрощения формулу можно записать так
Код
=ИНДЕКС($A$1:$A$17;НАИМЕНЬШИЙ(ЕСЛИ($B$3:$B$17=G$2;СТРОКА($B$3:$B$17));СТРОКА(A1)))
, чтобы СТРОКА($1:$15) не путала, достаточно сменить везде нижний предел, 17 на 40 например..

Автор - gling
Дата добавления - 20.03.2016 в 18:49
Protorivatel Дата: Воскресенье, 20.03.2016, 22:26 | Сообщение № 7
Группа: Пользователи
Ранг: Новичок
Сообщений: 17
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Большое спасибо всем за ответы! Они мне очень помогли! hands
 
Ответить
СообщениеБольшое спасибо всем за ответы! Они мне очень помогли! hands

Автор - Protorivatel
Дата добавления - 20.03.2016 в 22:26
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выборка данных из общего списка (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!