Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Вычленение искомого значения из искомого и диапазона поиска. - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вычленение искомого значения из искомого и диапазона поиска. (Формулы/Formulas)
Вычленение искомого значения из искомого и диапазона поиска.
VIDEO56 Дата: Понедельник, 21.03.2016, 14:51 | Сообщение № 1
Группа: Проверенные
Ранг: Обитатель
Сообщений: 262
Репутация: 23 ±
Замечаний: 0% ±

Excel 2010
Всем добрый день!
Прошу подсказать формулу для решения следующей задачи. Есть диапазон искомых позиций. В диапазоне поиска совпадает только модель искомой позиции. Как написать формулу через индекс и поискпоз для подтягивания остатков.
К сообщению приложен файл: 8049762.xlsm(20Kb)


Всем удачного дня!
 
Ответить
СообщениеВсем добрый день!
Прошу подсказать формулу для решения следующей задачи. Есть диапазон искомых позиций. В диапазоне поиска совпадает только модель искомой позиции. Как написать формулу через индекс и поискпоз для подтягивания остатков.

Автор - VIDEO56
Дата добавления - 21.03.2016 в 14:51
Nic70y Дата: Понедельник, 21.03.2016, 14:57 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3477
Репутация: 722 ±
Замечаний: 0% ±

Excel 2013
Код
=ИНДЕКС(Таблица1[Остаток];ПОИСКПОЗ("*"&ПСТР(A2;ПОИСК("IP";A2);99)&"*";Таблица1[Наименование];))
вдруг правильно не, неправильно


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)


Сообщение отредактировал Nic70y - Понедельник, 21.03.2016, 14:58
 
Ответить
Сообщение
Код
=ИНДЕКС(Таблица1[Остаток];ПОИСКПОЗ("*"&ПСТР(A2;ПОИСК("IP";A2);99)&"*";Таблица1[Наименование];))
вдруг правильно не, неправильно

Автор - Nic70y
Дата добавления - 21.03.2016 в 14:57
_Boroda_ Дата: Понедельник, 21.03.2016, 15:00 | Сообщение № 3
Группа: Модераторы
Ранг: Экселист
Сообщений: 9352
Репутация: 3924 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Да там все просто -
Код
=ИНДЕКС(Таблица1[Остаток];ПОИСКПОЗ("*"&ПСТР(A2;МИН(ЕСЛИ(ЕЧИСЛО(ПОИСКПОЗ("*"&ПСТР(A2;СТРОКА($1:$99);99);Таблица1[Наименование];));СТРОКА($1:$99)));99);Таблица1[Наименование];))
К сообщению приложен файл: 8049762_1.xlsm(21Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеДа там все просто -
Код
=ИНДЕКС(Таблица1[Остаток];ПОИСКПОЗ("*"&ПСТР(A2;МИН(ЕСЛИ(ЕЧИСЛО(ПОИСКПОЗ("*"&ПСТР(A2;СТРОКА($1:$99);99);Таблица1[Наименование];));СТРОКА($1:$99)));99);Таблица1[Наименование];))

Автор - _Boroda_
Дата добавления - 21.03.2016 в 15:00
Nic70y Дата: Понедельник, 21.03.2016, 15:07 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3477
Репутация: 722 ±
Замечаний: 0% ±

Excel 2013
Код
=ИНДЕКС(Таблица1[Остаток];ПОИСКПОЗ("*"&ПСТР(A2;МИН(ЕСЛИ(ЕСЛИОШИБКА(КОДСИМВ(ПСТР(ПОДСТАВИТЬ(A2;" ";"ю");СТРОКА($1:$99);1));192)<192;СТРОКА($1:$99)));99)&"*";Таблица1[Наименование];))
массивная


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)


Сообщение отредактировал Nic70y - Понедельник, 21.03.2016, 15:07
 
Ответить
Сообщение
Код
=ИНДЕКС(Таблица1[Остаток];ПОИСКПОЗ("*"&ПСТР(A2;МИН(ЕСЛИ(ЕСЛИОШИБКА(КОДСИМВ(ПСТР(ПОДСТАВИТЬ(A2;" ";"ю");СТРОКА($1:$99);1));192)<192;СТРОКА($1:$99)));99)&"*";Таблица1[Наименование];))
массивная

Автор - Nic70y
Дата добавления - 21.03.2016 в 15:07
Nic70y Дата: Понедельник, 21.03.2016, 15:12 | Сообщение № 5
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3477
Репутация: 722 ±
Замечаний: 0% ±

Excel 2013
все просто
ну, не знаю :(
К сообщению приложен файл: 3724115.xlsm(21Kb)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщение
все просто
ну, не знаю :(

Автор - Nic70y
Дата добавления - 21.03.2016 в 15:12
_Boroda_ Дата: Понедельник, 21.03.2016, 15:32 | Сообщение № 6
Группа: Модераторы
Ранг: Экселист
Сообщений: 9352
Репутация: 3924 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Заметил уже.
Ве еще проще и даже массив не нужен -
Код
=ИНДЕКС(Таблица1[Остаток];ПОИСКПОЗ("*"&СЖПРОБЕЛЫ(ПРАВБ(ПОДСТАВИТЬ(СЖПРОБЕЛЫ(A2);" ";ПОВТОР(" ";99));99));Таблица1[Наименование];))
К сообщению приложен файл: 3724115_1.xlsm(21Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЗаметил уже.
Ве еще проще и даже массив не нужен -
Код
=ИНДЕКС(Таблица1[Остаток];ПОИСКПОЗ("*"&СЖПРОБЕЛЫ(ПРАВБ(ПОДСТАВИТЬ(СЖПРОБЕЛЫ(A2);" ";ПОВТОР(" ";99));99));Таблица1[Наименование];))

Автор - _Boroda_
Дата добавления - 21.03.2016 в 15:32
Nic70y Дата: Понедельник, 21.03.2016, 15:39 | Сообщение № 7
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3477
Репутация: 722 ±
Замечаний: 0% ±

Excel 2013
ну да я лишнюю фиговину &"*" неподумавши написал :(
Код
=ИНДЕКС(Таблица1[Остаток];ПОИСКПОЗ("*"&ПСТР(A2;МИН(ЕСЛИ(ЕСЛИОШИБКА(КОДСИМВ(ПСТР(ПОДСТАВИТЬ(A2;" ";"ю");СТРОКА($1:$99);1));192)<192;СТРОКА($1:$99)));99);Таблица1[Наименование];))
а если Кабель UTP-5e 4x2x0.5 Cu (indoor) 305м вдруг
К сообщению приложен файл: 7447739.xlsm(21Kb)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)


Сообщение отредактировал Nic70y - Понедельник, 21.03.2016, 15:44
 
Ответить
Сообщениену да я лишнюю фиговину &"*" неподумавши написал :(
Код
=ИНДЕКС(Таблица1[Остаток];ПОИСКПОЗ("*"&ПСТР(A2;МИН(ЕСЛИ(ЕСЛИОШИБКА(КОДСИМВ(ПСТР(ПОДСТАВИТЬ(A2;" ";"ю");СТРОКА($1:$99);1));192)<192;СТРОКА($1:$99)));99);Таблица1[Наименование];))
а если Кабель UTP-5e 4x2x0.5 Cu (indoor) 305м вдруг

Автор - Nic70y
Дата добавления - 21.03.2016 в 15:39
VIDEO56 Дата: Вторник, 22.03.2016, 06:11 | Сообщение № 8
Группа: Проверенные
Ранг: Обитатель
Сообщений: 262
Репутация: 23 ±
Замечаний: 0% ±

Excel 2010
Друзья спасибо всем! Выручили!


Всем удачного дня!
 
Ответить
СообщениеДрузья спасибо всем! Выручили!

Автор - VIDEO56
Дата добавления - 22.03.2016 в 06:11
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вычленение искомого значения из искомого и диапазона поиска. (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!