Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Поиск выбраного из списка значения в диапазоне ячеек - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск выбраного из списка значения в диапазоне ячеек (Формулы/Formulas)
Поиск выбраного из списка значения в диапазоне ячеек
FrameG2 Дата: Четверг, 24.03.2016, 00:42 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 13
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Задачка простая, но что-то не получается её решить.
Есть список, составленный на основе "диапазона 1". Выбираю в нём какое-то значение. Существует также "диапазон 2". И есть ячейка, в которой должно быть условие: если выбранное из списка значение имеется в "диапазоне 2", то, например, вернуть 1, иначе 0. Как это условие сделать? :)
Пример прикрепил.
К сообщению приложен файл: 6755421.xlsx(11Kb)
 
Ответить
СообщениеЗадачка простая, но что-то не получается её решить.
Есть список, составленный на основе "диапазона 1". Выбираю в нём какое-то значение. Существует также "диапазон 2". И есть ячейка, в которой должно быть условие: если выбранное из списка значение имеется в "диапазоне 2", то, например, вернуть 1, иначе 0. Как это условие сделать? :)
Пример прикрепил.

Автор - FrameG2
Дата добавления - 24.03.2016 в 00:42
gling Дата: Четверг, 24.03.2016, 00:58 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1352
Репутация: 326 ±
Замечаний: 0% ±

2010
Так?
Код
=ЕСЛИ(СЧЁТЕСЛИ(F3:F7;B3);"УРА!!!";"НЕТУ буквы "&B3)
К сообщению приложен файл: 3467774.xlsx(12Kb)


Сообщение отредактировал gling - Четверг, 24.03.2016, 00:59
 
Ответить
СообщениеТак?
Код
=ЕСЛИ(СЧЁТЕСЛИ(F3:F7;B3);"УРА!!!";"НЕТУ буквы "&B3)

Автор - gling
Дата добавления - 24.03.2016 в 00:58
Wasilich Дата: Четверг, 24.03.2016, 02:43 | Сообщение № 3
Группа: Друзья
Ранг: Ветеран
Сообщений: 877
Репутация: 222 ±
Замечаний: 0% ±

2003
Код
=ЕСЛИ(СЧЁТЕСЛИ(D13:D14;B3); "Значение справа "&ВПР(B3;D13:E14;2;0); 0)
 
Ответить
Сообщение
Код
=ЕСЛИ(СЧЁТЕСЛИ(D13:D14;B3); "Значение справа "&ВПР(B3;D13:E14;2;0); 0)

Автор - Wasilich
Дата добавления - 24.03.2016 в 02:43
vikttur Дата: Четверг, 24.03.2016, 02:51 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 2030
Репутация: 355 ±
Замечаний: 0% ±

Код
=ЕСЛИОШИБКА(ВПР(B3;D13:E14;2;);)

Код
=ЕСЛИ(B3=D13;E13;ЕСЛИ(B3=D14;E14;))


Сообщение отредактировал vikttur - Четверг, 24.03.2016, 02:52
 
Ответить
Сообщение
Код
=ЕСЛИОШИБКА(ВПР(B3;D13:E14;2;);)

Код
=ЕСЛИ(B3=D13;E13;ЕСЛИ(B3=D14;E14;))

Автор - vikttur
Дата добавления - 24.03.2016 в 02:51
FrameG2 Дата: Четверг, 24.03.2016, 10:25 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 13
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Всем спасибо за помощь, всё работает прекрасно!
 
Ответить
СообщениеВсем спасибо за помощь, всё работает прекрасно!

Автор - FrameG2
Дата добавления - 24.03.2016 в 10:25
_Boroda_ Дата: Четверг, 24.03.2016, 11:03 | Сообщение № 6
Группа: Модераторы
Ранг: Экселист
Сообщений: 9377
Репутация: 3950 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Еще вариантики
Код
=СУММЕСЛИ(D13:D14;B3;E13:E14)
Код
=СУММПРОИЗВ(E13:E14*(D13:D14=B3))
массивная (вводить одновременным нажатием Контрл Шифт Ентер)
Код
=МАКС(E13:E14*(D13:D14=B3))


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЕще вариантики
Код
=СУММЕСЛИ(D13:D14;B3;E13:E14)
Код
=СУММПРОИЗВ(E13:E14*(D13:D14=B3))
массивная (вводить одновременным нажатием Контрл Шифт Ентер)
Код
=МАКС(E13:E14*(D13:D14=B3))

Автор - _Boroda_
Дата добавления - 24.03.2016 в 11:03
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск выбраного из списка значения в диапазоне ячеек (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!