Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Возвращение значения или "нет", в случае его отсутствия - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Возвращение значения или "нет", в случае его отсутствия (Формулы/Formulas)
Возвращение значения или "нет", в случае его отсутствия
Chudson Дата: Четверг, 24.03.2016, 16:45 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Добрый день! Столкнулся с задачкой, очень прошу поспособствовать в ее решении!

В столбце Параметры имеются строки,некоторые из них имеют параметр «Age» и через «=» значение. Необходимо ввести в выделенную ячейку формулу, которая при протягивании её вниз возвращала бы значение параметра “Age”, а если его нет, то слово «нет», например. Ну т.е. примерно так:
41
нет
нет
35
и т.д.
К сообщению приложен файл: 3413620.xlsx(10Kb)
 
Ответить
СообщениеДобрый день! Столкнулся с задачкой, очень прошу поспособствовать в ее решении!

В столбце Параметры имеются строки,некоторые из них имеют параметр «Age» и через «=» значение. Необходимо ввести в выделенную ячейку формулу, которая при протягивании её вниз возвращала бы значение параметра “Age”, а если его нет, то слово «нет», например. Ну т.е. примерно так:
41
нет
нет
35
и т.д.

Автор - Chudson
Дата добавления - 24.03.2016 в 16:45
Nic70y Дата: Четверг, 24.03.2016, 16:51 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3487
Репутация: 722 ±
Замечаний: 0% ±

Excel 2013
Код
=ЕСЛИОШИБКА(ПОДСТАВИТЬ(ПСТР(A2;ПОИСК("Возраст";A2)+8;3);"|";);"нет")


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщение
Код
=ЕСЛИОШИБКА(ПОДСТАВИТЬ(ПСТР(A2;ПОИСК("Возраст";A2)+8;3);"|";);"нет")

Автор - Nic70y
Дата добавления - 24.03.2016 в 16:51
Chudson Дата: Четверг, 24.03.2016, 16:57 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Nic70y, Спасибо большое!!! hands
 
Ответить
СообщениеNic70y, Спасибо большое!!! hands

Автор - Chudson
Дата добавления - 24.03.2016 в 16:57
Nic70y Дата: Четверг, 24.03.2016, 17:16 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3487
Репутация: 722 ±
Замечаний: 0% ±

Excel 2013
так надежнее
Код
=ЕСЛИОШИБКА(--ЛЕВБ(ПОДСТАВИТЬ(ПСТР(A2;ПОИСК("Возраст";A2)+8;3);"|";"  ");3);"нет")
, но думаю не понадобится


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщениетак надежнее
Код
=ЕСЛИОШИБКА(--ЛЕВБ(ПОДСТАВИТЬ(ПСТР(A2;ПОИСК("Возраст";A2)+8;3);"|";"  ");3);"нет")
, но думаю не понадобится

Автор - Nic70y
Дата добавления - 24.03.2016 в 17:16
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Возвращение значения или "нет", в случае его отсутствия (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!