Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Заполнение ячеек при совпадении значений - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Заполнение ячеек при совпадении значений (Формулы/Formulas)
Заполнение ячеек при совпадении значений
kdi45 Дата: Суббота, 26.03.2016, 12:47 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Добрый день, очень надеюсь на вашу помощь. Суть проблемы - необходимо заполнить пустые ячейки в каждой строке столбца C, значениями из того же столбца, но если в строках значение в столбце A совпадает со значением столбца B. Например если А2 совпадает с В14, в С2 заносится значение из С14, если А3 совпадает с В11, то в С3 значение из С11. Во вложении красным текстом так, как должно быть в итоге. Прошу прощения если что то не так, первый раз тут)
К сообщению приложен файл: test.xls(22Kb)
 
Ответить
СообщениеДобрый день, очень надеюсь на вашу помощь. Суть проблемы - необходимо заполнить пустые ячейки в каждой строке столбца C, значениями из того же столбца, но если в строках значение в столбце A совпадает со значением столбца B. Например если А2 совпадает с В14, в С2 заносится значение из С14, если А3 совпадает с В11, то в С3 значение из С11. Во вложении красным текстом так, как должно быть в итоге. Прошу прощения если что то не так, первый раз тут)

Автор - kdi45
Дата добавления - 26.03.2016 в 12:47
vikttur Дата: Суббота, 26.03.2016, 13:01 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 2030
Репутация: 355 ±
Замечаний: 0% ±

Код
=ВПР(RC[-2];R2C1:R9C3;3;)

Код
=ВПР(B10;$A$2:$C$9;3;)
 
Ответить
Сообщение
Код
=ВПР(RC[-2];R2C1:R9C3;3;)

Код
=ВПР(B10;$A$2:$C$9;3;)

Автор - vikttur
Дата добавления - 26.03.2016 в 13:01
kdi45 Дата: Суббота, 26.03.2016, 13:56 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Спасибо, может я что то не так делаю, но по первой формуле выдает значение 0, а по второй ошибку. Еще забыл добавить, что кол-во строк всегда разное.
 
Ответить
СообщениеСпасибо, может я что то не так делаю, но по первой формуле выдает значение 0, а по второй ошибку. Еще забыл добавить, что кол-во строк всегда разное.

Автор - kdi45
Дата добавления - 26.03.2016 в 13:56
Pelena Дата: Суббота, 26.03.2016, 14:17 | Сообщение № 4
Группа: Модераторы
Ранг: Экселист
Сообщений: 9890
Репутация: 2269 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
Для С2
Код
=ВПР([@art];$B$10:$C$14;2;0)

Но вообще странно организована таблица: формулы и числа в одном столбце?


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеДля С2
Код
=ВПР([@art];$B$10:$C$14;2;0)

Но вообще странно организована таблица: формулы и числа в одном столбце?

Автор - Pelena
Дата добавления - 26.03.2016 в 14:17
kdi45 Дата: Суббота, 26.03.2016, 14:39 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
не, в принципе формулы можно в отдельный столбец отнести. главное чтоб в конце каждой строки так сказать верхней части была ячейка со значением из столбца С (во вложении)
К сообщению приложен файл: 3083120.xls(22Kb)
 
Ответить
Сообщениене, в принципе формулы можно в отдельный столбец отнести. главное чтоб в конце каждой строки так сказать верхней части была ячейка со значением из столбца С (во вложении)

Автор - kdi45
Дата добавления - 26.03.2016 в 14:39
vikttur Дата: Суббота, 26.03.2016, 14:40 | Сообщение № 6
Группа: Друзья
Ранг: Старожил
Сообщений: 2030
Репутация: 355 ±
Замечаний: 0% ±

Цитата
по первой формуле выдает значение 0

Смещение на два столбца, т.к. формулу писал в соседнам столбце. Так правильно:
Код
=ВПР(RC[-1];R2C1:R9C3;3;)


Цитата
...а по второй ошибку

В Вашем файле тип ссылок R1C1, вторая формула для типа А1
 
Ответить
Сообщение
Цитата
по первой формуле выдает значение 0

Смещение на два столбца, т.к. формулу писал в соседнам столбце. Так правильно:
Код
=ВПР(RC[-1];R2C1:R9C3;3;)


Цитата
...а по второй ошибку

В Вашем файле тип ссылок R1C1, вторая формула для типа А1

Автор - vikttur
Дата добавления - 26.03.2016 в 14:40
kdi45 Дата: Суббота, 26.03.2016, 14:50 | Сообщение № 7
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
я извиняюсь, может я безнадежен, но нет. Ошибка. Формулу ставлю в С2
 
Ответить
Сообщениея извиняюсь, может я безнадежен, но нет. Ошибка. Формулу ставлю в С2

Автор - kdi45
Дата добавления - 26.03.2016 в 14:50
gling Дата: Суббота, 26.03.2016, 14:54 | Сообщение № 8
Группа: Друзья
Ранг: Старожил
Сообщений: 1352
Репутация: 326 ±
Замечаний: 0% ±

2010
Здравствуйте. Может так надо?
Код
=ЕСЛИОШИБКА(ВПР(A2;$B$2:$C$14;2;);ВПР(A2;$A$2:$C$14;3;))
Для 2003
Код
=ЕСЛИ(ЕОШИБКА(ВПР(A2;$B$2:$C$14;2;));ВПР(A2;$A$2:$C$14;3;);ВПР(A2;$B$2:$C$14;2;))


Сообщение отредактировал gling - Суббота, 26.03.2016, 14:59
 
Ответить
СообщениеЗдравствуйте. Может так надо?
Код
=ЕСЛИОШИБКА(ВПР(A2;$B$2:$C$14;2;);ВПР(A2;$A$2:$C$14;3;))
Для 2003
Код
=ЕСЛИ(ЕОШИБКА(ВПР(A2;$B$2:$C$14;2;));ВПР(A2;$A$2:$C$14;3;);ВПР(A2;$B$2:$C$14;2;))

Автор - gling
Дата добавления - 26.03.2016 в 14:54
kdi45 Дата: Суббота, 26.03.2016, 14:58 | Сообщение № 9
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Здравствуйте, нет ошибка. И, кстати на самом деле удобней наверно в отдельный столбец эти формулы пихать чтоб не парится, т.к. кол-во строк всегда разное
 
Ответить
СообщениеЗдравствуйте, нет ошибка. И, кстати на самом деле удобней наверно в отдельный столбец эти формулы пихать чтоб не парится, т.к. кол-во строк всегда разное

Автор - kdi45
Дата добавления - 26.03.2016 в 14:58
vikttur Дата: Суббота, 26.03.2016, 15:00 | Сообщение № 10
Группа: Друзья
Ранг: Старожил
Сообщений: 2030
Репутация: 355 ±
Замечаний: 0% ±

Цитата
Ошибка. Формулу ставлю в С2

Ну, так... сами создаете циклическую ссылку... Ниже надо ставить.

И, правильно: лучше разные данные по разным столбцам, иначе может получиться прокисший винегрет
К сообщению приложен файл: 7255646.xls(23Kb)


Сообщение отредактировал vikttur - Суббота, 26.03.2016, 15:02
 
Ответить
Сообщение
Цитата
Ошибка. Формулу ставлю в С2

Ну, так... сами создаете циклическую ссылку... Ниже надо ставить.

И, правильно: лучше разные данные по разным столбцам, иначе может получиться прокисший винегрет

Автор - vikttur
Дата добавления - 26.03.2016 в 15:00
kdi45 Дата: Суббота, 26.03.2016, 15:09 | Сообщение № 11
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
вот вроде то, что нужно, только наоборот. Получилось, что формулы проставлены там, где исходные данные. Нужно наоборот - внизу исходные данные, вверху формулы)
 
Ответить
Сообщениевот вроде то, что нужно, только наоборот. Получилось, что формулы проставлены там, где исходные данные. Нужно наоборот - внизу исходные данные, вверху формулы)

Автор - kdi45
Дата добавления - 26.03.2016 в 15:09
vikttur Дата: Суббота, 26.03.2016, 15:14 | Сообщение № 12
Группа: Друзья
Ранг: Старожил
Сообщений: 2030
Репутация: 355 ±
Замечаний: 0% ±

Неужели самостоятельно трудно разобраться? Ведь пример рабочий есть. Посмотрите справку по предложенным функциям, разберите по косточкам... В другой раз не придется бежать на форум с похожим вопросом.
 
Ответить
СообщениеНеужели самостоятельно трудно разобраться? Ведь пример рабочий есть. Посмотрите справку по предложенным функциям, разберите по косточкам... В другой раз не придется бежать на форум с похожим вопросом.

Автор - vikttur
Дата добавления - 26.03.2016 в 15:14
kdi45 Дата: Суббота, 26.03.2016, 15:16 | Сообщение № 13
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
да да, я уже) спасибо огромное


Сообщение отредактировал kdi45 - Суббота, 26.03.2016, 15:17
 
Ответить
Сообщениеда да, я уже) спасибо огромное

Автор - kdi45
Дата добавления - 26.03.2016 в 15:16
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Заполнение ячеек при совпадении значений (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!