Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Суммировать столбец по условию - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Суммировать столбец по условию (Формулы/Formulas)
Суммировать столбец по условию
l-lisa Дата: Суббота, 26.03.2016, 13:23 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 150
Репутация: 1 ±
Замечаний: 20% ±

Excel 2010
Здравствуйте, помогите пожалуйста написать формулу, суммирующую только итоговые значения,то есть брать нужно те строки в которых встречается слово "Итоги"
К сообщению приложен файл: 7681147.xlsx(9Kb)


Сообщение отредактировал l-lisa - Суббота, 26.03.2016, 13:23
 
Ответить
СообщениеЗдравствуйте, помогите пожалуйста написать формулу, суммирующую только итоговые значения,то есть брать нужно те строки в которых встречается слово "Итоги"

Автор - l-lisa
Дата добавления - 26.03.2016 в 13:23
Pelena Дата: Суббота, 26.03.2016, 13:39 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 9848
Репутация: 2254 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
Здравствуйте
Код
=СУММЕСЛИ(A2:A33;"*Итог";B2:B33)

Только у Вас не все строки с итогом выделены желтым


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЗдравствуйте
Код
=СУММЕСЛИ(A2:A33;"*Итог";B2:B33)

Только у Вас не все строки с итогом выделены желтым

Автор - Pelena
Дата добавления - 26.03.2016 в 13:39
vikttur Дата: Суббота, 26.03.2016, 13:42 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 2029
Репутация: 355 ±
Замечаний: 0% ±

Код
=СУММПРОИЗВ(--ЕЧИСЛО(ПОИСК("Итог";A2:A33));B2:B33)
 
Ответить
Сообщение
Код
=СУММПРОИЗВ(--ЕЧИСЛО(ПОИСК("Итог";A2:A33));B2:B33)

Автор - vikttur
Дата добавления - 26.03.2016 в 13:42
l-lisa Дата: Суббота, 26.03.2016, 13:57 | Сообщение № 4
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 150
Репутация: 1 ±
Замечаний: 20% ±

Excel 2010
Спасибо вам за помощь!
А почему не срабатывает такая формула:
Код
=СУММЕСЛИ(A2:A33;ПРАВСИМВ(A2;4)="Итог";B2:B33)
 
Ответить
СообщениеСпасибо вам за помощь!
А почему не срабатывает такая формула:
Код
=СУММЕСЛИ(A2:A33;ПРАВСИМВ(A2;4)="Итог";B2:B33)

Автор - l-lisa
Дата добавления - 26.03.2016 в 13:57
Pelena Дата: Суббота, 26.03.2016, 14:08 | Сообщение № 5
Группа: Модераторы
Ранг: Экселист
Сообщений: 9848
Репутация: 2254 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
В Вашей формуле в качестве критерия отбора выступает значение ИСТИНА, а такого значения нет в столбце А
Думаю, Вы имели в виду такую логику (формула массива)
Код
=СУММ(ЕСЛИ(ПРАВСИМВ(A2:A33;4)="Итог";B2:B33))


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеВ Вашей формуле в качестве критерия отбора выступает значение ИСТИНА, а такого значения нет в столбце А
Думаю, Вы имели в виду такую логику (формула массива)
Код
=СУММ(ЕСЛИ(ПРАВСИМВ(A2:A33;4)="Итог";B2:B33))

Автор - Pelena
Дата добавления - 26.03.2016 в 14:08
l-lisa Дата: Суббота, 26.03.2016, 14:16 | Сообщение № 6
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 150
Репутация: 1 ±
Замечаний: 20% ±

Excel 2010
В Вашей формуле в качестве критерия отбора выступает значение ИСТИНА

Спасибо за разъяснение :)
 
Ответить
Сообщение
В Вашей формуле в качестве критерия отбора выступает значение ИСТИНА

Спасибо за разъяснение :)

Автор - l-lisa
Дата добавления - 26.03.2016 в 14:16
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Суммировать столбец по условию (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!