Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Убрать дубликаты с зеркальным отображением по двум столбцам - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Убрать дубликаты с зеркальным отображением по двум столбцам (Формулы/Formulas)
Убрать дубликаты с зеркальным отображением по двум столбцам
elita86 Дата: Понедельник, 28.03.2016, 07:04 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 71
Репутация: 0 ±
Замечаний: 0% ±

2010
Добрый день!
Существует таблица с двумя колонками и в ней есть дубликаты, но они зеркально отражены, пример во вложении.
Не знаю, каким способом убрать данные дубликаты.
Список очень большой, поэтому руками слишком долго и можно допустить ошибку.
Путь решения не важен (макрос или формулы), главное результат.
К сообщению приложен файл: 2524806.xlsx(9Kb)
 
Ответить
СообщениеДобрый день!
Существует таблица с двумя колонками и в ней есть дубликаты, но они зеркально отражены, пример во вложении.
Не знаю, каким способом убрать данные дубликаты.
Список очень большой, поэтому руками слишком долго и можно допустить ошибку.
Путь решения не важен (макрос или формулы), главное результат.

Автор - elita86
Дата добавления - 28.03.2016 в 07:04
Nic70y Дата: Понедельник, 28.03.2016, 07:15 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3918
Репутация: 829 ±
Замечаний: 0% ±

Excel 2013
Список очень большой
наверное макрос надо,
ну может и формулы справятся:
Код
=ЕСЛИ(D3=A3;B3;A3)
Код
=ЕСЛИОШИБКА(ИНДЕКС(B$3:B3;ПОИСКПОЗ(A3;B$3:B3;));B3)
перед удалением дубликатов перевести их в значения
К сообщению приложен файл: 4620159.xlsx(10Kb)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)


Сообщение отредактировал Nic70y - Понедельник, 28.03.2016, 07:16
 
Ответить
Сообщение
Список очень большой
наверное макрос надо,
ну может и формулы справятся:
Код
=ЕСЛИ(D3=A3;B3;A3)
Код
=ЕСЛИОШИБКА(ИНДЕКС(B$3:B3;ПОИСКПОЗ(A3;B$3:B3;));B3)
перед удалением дубликатов перевести их в значения

Автор - Nic70y
Дата добавления - 28.03.2016 в 07:15
Pelena Дата: Понедельник, 28.03.2016, 07:19 | Сообщение № 3
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11007
Репутация: 2459 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
Ещё вариант: в доп. столбец формулу массива
Код
=ИЛИ(B3&A3=$A$3:$A3&$B$3:B3)

потом отфильтровать по критерию ИСТИНА и удалить строки
К сообщению приложен файл: 2192097.xlsx(10Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЕщё вариант: в доп. столбец формулу массива
Код
=ИЛИ(B3&A3=$A$3:$A3&$B$3:B3)

потом отфильтровать по критерию ИСТИНА и удалить строки

Автор - Pelena
Дата добавления - 28.03.2016 в 07:19
elita86 Дата: Понедельник, 28.03.2016, 07:23 | Сообщение № 4
Группа: Пользователи
Ранг: Участник
Сообщений: 71
Репутация: 0 ±
Замечаний: 0% ±

2010
Огромное спасибо! Всё работает!
 
Ответить
СообщениеОгромное спасибо! Всё работает!

Автор - elita86
Дата добавления - 28.03.2016 в 07:23
elita86 Дата: Понедельник, 28.03.2016, 07:24 | Сообщение № 5
Группа: Пользователи
Ранг: Участник
Сообщений: 71
Репутация: 0 ±
Замечаний: 0% ±

2010
Второй вариант тоже замечательный!
 
Ответить
СообщениеВторой вариант тоже замечательный!

Автор - elita86
Дата добавления - 28.03.2016 в 07:24
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Убрать дубликаты с зеркальным отображением по двум столбцам (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!