Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Сравнить столбцы и заменить значения ячеек по условию - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сравнить столбцы и заменить значения ячеек по условию (Формулы/Formulas)
Сравнить столбцы и заменить значения ячеек по условию
1Anastasia1 Дата: Вторник, 29.03.2016, 15:38 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Уважаемые форумчане, очень нужна ваша помощь по Excel!

Вопрос такой: требуется заменить в третьем столбце (С) значения ячеек на числовые из первого столбца (А).
Условие: Если Иванов из столбца С существует в столбце В, то этого Иванова из столбца С заменить цифрой из столбца А,
указанной напротив Иванова из столбца В.

Пример прикрепила к сообщению.
Очень нужно решение, поскольку реальная таблица, для которой требуется формула, просто гигантская.
К сообщению приложен файл: 6898434.xlsx(9Kb)
 
Ответить
СообщениеУважаемые форумчане, очень нужна ваша помощь по Excel!

Вопрос такой: требуется заменить в третьем столбце (С) значения ячеек на числовые из первого столбца (А).
Условие: Если Иванов из столбца С существует в столбце В, то этого Иванова из столбца С заменить цифрой из столбца А,
указанной напротив Иванова из столбца В.

Пример прикрепила к сообщению.
Очень нужно решение, поскольку реальная таблица, для которой требуется формула, просто гигантская.

Автор - 1Anastasia1
Дата добавления - 29.03.2016 в 15:38
Pelena Дата: Вторник, 29.03.2016, 15:46 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11041
Репутация: 2465 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
Код
=ИНДЕКС($A$1:$A$6;ПОИСКПОЗ(C1;$B$1:$B$6;0))
К сообщению приложен файл: 1282358.xlsx(9Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщение
Код
=ИНДЕКС($A$1:$A$6;ПОИСКПОЗ(C1;$B$1:$B$6;0))

Автор - Pelena
Дата добавления - 29.03.2016 в 15:46
_Boroda_ Дата: Вторник, 29.03.2016, 16:27 | Сообщение № 3
Группа: Модераторы
Ранг: Экселист
Сообщений: 10334
Репутация: 4357 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Еще вариант
Код
=ПРОСМОТР(;-1/(B$1:B$6=C1);A$1:A$6)
К сообщению приложен файл: 6898434_1.xlsx(10Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЕще вариант
Код
=ПРОСМОТР(;-1/(B$1:B$6=C1);A$1:A$6)

Автор - _Boroda_
Дата добавления - 29.03.2016 в 16:27
1Anastasia1 Дата: Среда, 30.03.2016, 09:00 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Друзья! Спасибо огромное за решение - все подошло! hands
 
Ответить
СообщениеДрузья! Спасибо огромное за решение - все подошло! hands

Автор - 1Anastasia1
Дата добавления - 30.03.2016 в 09:00
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сравнить столбцы и заменить значения ячеек по условию (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!