Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Вставка аргумента "Имя_Листа" в функции АДРЕС - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вставка аргумента "Имя_Листа" в функции АДРЕС (Формулы/Formulas)
Вставка аргумента "Имя_Листа" в функции АДРЕС
IgorPIN Дата: Вторник, 29.03.2016, 22:15 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Здравствуйте!
Никак не могу заставить функцию АДРЕС (ADDRESS) взять аргумент "имя_листа" (Sheet_text) из ячейки. если прописываю имя листа напрямую (в кавычках, как по синтаксису), то работает. как только меняю аргумент на ссылку из соседней ячейки - не работает, пишет #REF!. Пробовал и с кавычками, и без, при этом другие аргументы со ссылками на столбцы через ДВССЫЛ (INDIRECT) воспринимает нормально.
Код
=IF(Q2=-2;INDIRECT(ADDRESS(MATCH(108;INDIRECT(H2);0);COLUMN(INDIRECT(I2));4;1;"[abontariffs.xlsx]1028"));Q2)
формула работает, а
Код
=IF(Q3=-2;INDIRECT(ADDRESS(MATCH(108;INDIRECT(H3);0);COLUMN(INDIRECT(I3));4;1;INDIRECT(J3)));Q3)
не работает.
содержимое ячеек откуда берутся ссылки:
H2/3 = '[AbonTariffs.xlsx]1028'!$B:$B - результат работы формулы
Код
= "'[AbonTariffs.xlsx]" & TEXT(G2;0) & "'!"  & "$B:$B"

I2/3 = '[AbonTariffs.xlsx]1028'!$E:$E - результат работы формулы
Код
= "'[AbonTariffs.xlsx]" & TEXT(G2;0) & "'!"  & "$E:$E"

J2/3 = "[AbonTariffs.xlsx]1028" - результат работы формулы
Код
=CHAR(34)&"[AbonTariffs.xlsx]"&TEXT(G2;0)&CHAR(34)


Как-то так...

Сообщение отредактировал IgorPIN - Вторник, 29.03.2016, 23:11
 
Ответить
СообщениеЗдравствуйте!
Никак не могу заставить функцию АДРЕС (ADDRESS) взять аргумент "имя_листа" (Sheet_text) из ячейки. если прописываю имя листа напрямую (в кавычках, как по синтаксису), то работает. как только меняю аргумент на ссылку из соседней ячейки - не работает, пишет #REF!. Пробовал и с кавычками, и без, при этом другие аргументы со ссылками на столбцы через ДВССЫЛ (INDIRECT) воспринимает нормально.
Код
=IF(Q2=-2;INDIRECT(ADDRESS(MATCH(108;INDIRECT(H2);0);COLUMN(INDIRECT(I2));4;1;"[abontariffs.xlsx]1028"));Q2)
формула работает, а
Код
=IF(Q3=-2;INDIRECT(ADDRESS(MATCH(108;INDIRECT(H3);0);COLUMN(INDIRECT(I3));4;1;INDIRECT(J3)));Q3)
не работает.
содержимое ячеек откуда берутся ссылки:
H2/3 = '[AbonTariffs.xlsx]1028'!$B:$B - результат работы формулы
Код
= "'[AbonTariffs.xlsx]" & TEXT(G2;0) & "'!"  & "$B:$B"

I2/3 = '[AbonTariffs.xlsx]1028'!$E:$E - результат работы формулы
Код
= "'[AbonTariffs.xlsx]" & TEXT(G2;0) & "'!"  & "$E:$E"

J2/3 = "[AbonTariffs.xlsx]1028" - результат работы формулы
Код
=CHAR(34)&"[AbonTariffs.xlsx]"&TEXT(G2;0)&CHAR(34)

Автор - IgorPIN
Дата добавления - 29.03.2016 в 22:15
bobrenja Дата: Вторник, 29.03.2016, 22:35 | Сообщение № 2
Группа: Пользователи
Ранг: Участник
Сообщений: 68
Репутация: 0 ±
Замечаний: 20% ±

Excel для Mac
IgorPIN, попробуйте так узнать имя листа
В любую ячейку формулу.

[vba]
Код
=ПСТР(ЯЧЕЙКА("ИМЯФАЙЛА";A1);ПОИСК("]";ЯЧЕЙКА("ИМЯФАЙЛА";A1))+1;255)
[/vba]
 
Ответить
СообщениеIgorPIN, попробуйте так узнать имя листа
В любую ячейку формулу.

[vba]
Код
=ПСТР(ЯЧЕЙКА("ИМЯФАЙЛА";A1);ПОИСК("]";ЯЧЕЙКА("ИМЯФАЙЛА";A1))+1;255)
[/vba]

Автор - bobrenja
Дата добавления - 29.03.2016 в 22:35
IgorPIN Дата: Вторник, 29.03.2016, 22:43 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Спасибо за совет!
Но мне не надо "узнавать" имя листа, я его задаю исходя из значения ячейки.
например, если значение равно 1023, то и имя листа во внешнем файле должно быть Имя_Файла!1023.
Все дело в том, что во всех других местах формул, где вставляются адреса - все работает по INDIRECT, и только в единственном месте не работает - параметр "Имя_листа" в формуле ADDRESS. Не понимаю, почему.
[moder]Исправьте свой первый пост. Формулы нужно заключать в теги - кнопка fx. И файлик бы не помешал.


Как-то так...

Сообщение отредактировал _Boroda_ - Вторник, 29.03.2016, 22:58
 
Ответить
СообщениеСпасибо за совет!
Но мне не надо "узнавать" имя листа, я его задаю исходя из значения ячейки.
например, если значение равно 1023, то и имя листа во внешнем файле должно быть Имя_Файла!1023.
Все дело в том, что во всех других местах формул, где вставляются адреса - все работает по INDIRECT, и только в единственном месте не работает - параметр "Имя_листа" в формуле ADDRESS. Не понимаю, почему.
[moder]Исправьте свой первый пост. Формулы нужно заключать в теги - кнопка fx. И файлик бы не помешал.

Автор - IgorPIN
Дата добавления - 29.03.2016 в 22:43
Pelena Дата: Среда, 30.03.2016, 07:45 | Сообщение № 4
Группа: Модераторы
Ранг: Экселист
Сообщений: 9856
Репутация: 2254 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
Непонятно, зачем там ДВССЫЛ(), если просто надо взять имя листа
В J2 формула
Код
="[AbonTariffs.xlsx]"&ТЕКСТ(G2;0)

и
Код
=ЕСЛИ(Q2=-2;ДВССЫЛ(АДРЕС(ПОИСКПОЗ(108;ДВССЫЛ(H2);0);СТОЛБЕЦ(ДВССЫЛ(I2));4;1;J2));Q2)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеНепонятно, зачем там ДВССЫЛ(), если просто надо взять имя листа
В J2 формула
Код
="[AbonTariffs.xlsx]"&ТЕКСТ(G2;0)

и
Код
=ЕСЛИ(Q2=-2;ДВССЫЛ(АДРЕС(ПОИСКПОЗ(108;ДВССЫЛ(H2);0);СТОЛБЕЦ(ДВССЫЛ(I2));4;1;J2));Q2)

Автор - Pelena
Дата добавления - 30.03.2016 в 07:45
IgorPIN Дата: Среда, 30.03.2016, 11:08 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Магия, Pelena!
Огромное спасибо!
Вчера все перепробовал, и с кавычками, и без - не работало...


Как-то так...
 
Ответить
СообщениеМагия, Pelena!
Огромное спасибо!
Вчера все перепробовал, и с кавычками, и без - не работало...

Автор - IgorPIN
Дата добавления - 30.03.2016 в 11:08
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вставка аргумента "Имя_Листа" в функции АДРЕС (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!