Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Выборка значений по нескольким критериям. - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выборка значений по нескольким критериям. (Формулы/Formulas)
Выборка значений по нескольким критериям.
rohen Дата: Среда, 30.03.2016, 11:55 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Здравствуйте!

Есть таблица-учёт по остаткам товара. Товар имеет такую структуру:

1)Тип (Молоко, Сок, Вода)
2)Объём
3)Производитель

Каждая строка такой таблицы уникальна, повторов нет.

Нужно сделать что-то наподобие сводной таблицы, но формулами.

То есть сгруппировать данные таким образом. Выбрать сначала тип, потом производителя, дальше объём. Т.е. в определённую ячейку поставить остаток товара с параметрами "Молоко - Вкуснотеево - 1 Литр".

У меня трудность возникла именно с формированием нескольких условий и поиску данной позиции.
К сообщению приложен файл: Example.xlsx(11Kb)


Сообщение отредактировал rohen - Среда, 30.03.2016, 11:56
 
Ответить
СообщениеЗдравствуйте!

Есть таблица-учёт по остаткам товара. Товар имеет такую структуру:

1)Тип (Молоко, Сок, Вода)
2)Объём
3)Производитель

Каждая строка такой таблицы уникальна, повторов нет.

Нужно сделать что-то наподобие сводной таблицы, но формулами.

То есть сгруппировать данные таким образом. Выбрать сначала тип, потом производителя, дальше объём. Т.е. в определённую ячейку поставить остаток товара с параметрами "Молоко - Вкуснотеево - 1 Литр".

У меня трудность возникла именно с формированием нескольких условий и поиску данной позиции.

Автор - rohen
Дата добавления - 30.03.2016 в 11:55
Nic70y Дата: Среда, 30.03.2016, 11:59 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3925
Репутация: 832 ±
Замечаний: 0% ±

Excel 2013
Код
=СУММПРОИЗВ(($B$6:$B$22=$I$6)*(J$6=$C$6:$C$22)*($I7=$D$6:$D$22)*$E$6:$E$22)
К сообщению приложен файл: 2563198.xlsx(11Kb)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщение
Код
=СУММПРОИЗВ(($B$6:$B$22=$I$6)*(J$6=$C$6:$C$22)*($I7=$D$6:$D$22)*$E$6:$E$22)

Автор - Nic70y
Дата добавления - 30.03.2016 в 11:59
rohen Дата: Среда, 30.03.2016, 12:06 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Здорово! hands

Всё так просто.

А через ПОИСКПОЗ и ИНДЕКС тоже же есть решение?
 
Ответить
СообщениеЗдорово! hands

Всё так просто.

А через ПОИСКПОЗ и ИНДЕКС тоже же есть решение?

Автор - rohen
Дата добавления - 30.03.2016 в 12:06
китин Дата: Среда, 30.03.2016, 12:18 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4117
Репутация: 636 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
ПОИСКПОЗ и ИНДЕКС тоже же есть решение?

а как же!!! формула массива
Код
=ЕСЛИОШИБКА(ИНДЕКС($E$6:$E$22;ПОИСКПОЗ($I$6&J$6&$I7;$B$6:$B$22&$C$6:$C$22&$D$6:$D$22;0));"")
или простая
Код
=ЕСЛИОШИБКА(ПРОСМОТР(1;1/(($B$6:$B$22=$I$6)*($C$6:$C$22=J$6)*($D$6:$D$22=$I7));$E$6:$E$22);"")
К сообщению приложен файл: 3694302.xlsx(11Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538


Сообщение отредактировал китин - Среда, 30.03.2016, 13:06
 
Ответить
Сообщение
ПОИСКПОЗ и ИНДЕКС тоже же есть решение?

а как же!!! формула массива
Код
=ЕСЛИОШИБКА(ИНДЕКС($E$6:$E$22;ПОИСКПОЗ($I$6&J$6&$I7;$B$6:$B$22&$C$6:$C$22&$D$6:$D$22;0));"")
или простая
Код
=ЕСЛИОШИБКА(ПРОСМОТР(1;1/(($B$6:$B$22=$I$6)*($C$6:$C$22=J$6)*($D$6:$D$22=$I7));$E$6:$E$22);"")

Автор - китин
Дата добавления - 30.03.2016 в 12:18
zaak88 Дата: Среда, 30.03.2016, 13:19 | Сообщение № 5
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 121
Репутация: 1 ±
Замечаний: 0% ±

Excel 2013
можно просто с помощью функции СУММЕСЛИМН:
Код
=СУММЕСЛИМН($E$6:$E$22;$B$6:$B$22;$I$6;$C$6:$C$22;J$6;$D$6:$D$22;$I7)
К сообщению приложен файл: 8511310.xlsx(11Kb)


Сообщение отредактировал Manyasha - Среда, 30.03.2016, 13:37
 
Ответить
Сообщениеможно просто с помощью функции СУММЕСЛИМН:
Код
=СУММЕСЛИМН($E$6:$E$22;$B$6:$B$22;$I$6;$C$6:$C$22;J$6;$D$6:$D$22;$I7)

Автор - zaak88
Дата добавления - 30.03.2016 в 13:19
китин Дата: Среда, 30.03.2016, 13:21 | Сообщение № 6
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4117
Репутация: 636 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
zaak88, есть тэги.в них надо обрамлять код (кнопочка fx выделяете формулу и нажимаете кнопачку) Реально очень неудобно читать :'(


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538


Сообщение отредактировал китин - Среда, 30.03.2016, 13:22
 
Ответить
Сообщениеzaak88, есть тэги.в них надо обрамлять код (кнопочка fx выделяете формулу и нажимаете кнопачку) Реально очень неудобно читать :'(

Автор - китин
Дата добавления - 30.03.2016 в 13:21
zaak88 Дата: Среда, 30.03.2016, 14:07 | Сообщение № 7
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 121
Репутация: 1 ±
Замечаний: 0% ±

Excel 2013
китин, согласен, извиняюсь... недавно местный, исправлюсь, только не нашёл волшебную кнопочку....
 
Ответить
Сообщениекитин, согласен, извиняюсь... недавно местный, исправлюсь, только не нашёл волшебную кнопочку....

Автор - zaak88
Дата добавления - 30.03.2016 в 14:07
jakim Дата: Среда, 30.03.2016, 14:19 | Сообщение № 8
Группа: Друзья
Ранг: Ветеран
Сообщений: 764
Репутация: 197 ±
Замечаний: 0% ±

Предлагаю вариант с выбором продукта в желтой ячейке, а дальше автоматически.
К сообщению приложен файл: 2851420.xlsx(12Kb)
 
Ответить
Сообщение
Предлагаю вариант с выбором продукта в желтой ячейке, а дальше автоматически.

Автор - jakim
Дата добавления - 30.03.2016 в 14:19
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выборка значений по нескольким критериям. (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!