Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/суммирование до пробела - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » суммирование до пробела (Формулы/Formulas)
суммирование до пробела
Dimon2512 Дата: Пятница, 01.04.2016, 07:30 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 42
Репутация: 0 ±
Замечаний: 0% ±

2007
Добрый день, подскажите пжл, можно ли так сделать, например в файле ИП валиев ниже него надо суммировать сумму по нему, и прописать такую формулу что бы я мог ее скопировать и вставить следующему ИП Самрук и Ип Тимофеев и он суммировал их суммы. Суть такая у меня большой список и хочется такую формулу что бы он суммировал копировать вставить все значения до пробела автоматом

Думаю конечно не очень понятно объяснил но может кто то поймет и поможет, Заранее спасибо
К сообщению приложен файл: 2880736.xlsx(9Kb)
 
Ответить
СообщениеДобрый день, подскажите пжл, можно ли так сделать, например в файле ИП валиев ниже него надо суммировать сумму по нему, и прописать такую формулу что бы я мог ее скопировать и вставить следующему ИП Самрук и Ип Тимофеев и он суммировал их суммы. Суть такая у меня большой список и хочется такую формулу что бы он суммировал копировать вставить все значения до пробела автоматом

Думаю конечно не очень понятно объяснил но может кто то поймет и поможет, Заранее спасибо

Автор - Dimon2512
Дата добавления - 01.04.2016 в 07:30
Pelena Дата: Пятница, 01.04.2016, 07:37 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 9864
Репутация: 2255 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
Здравствуйте.
Формула массива
Код
=СУММ(C3:ИНДЕКС(C3:$C$23;ПОИСКПОЗ(ИСТИНА;C3:$C$23="";0)))
К сообщению приложен файл: 0668788.xlsx(10Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Формула массива
Код
=СУММ(C3:ИНДЕКС(C3:$C$23;ПОИСКПОЗ(ИСТИНА;C3:$C$23="";0)))

Автор - Pelena
Дата добавления - 01.04.2016 в 07:37
Dimon2512 Дата: Пятница, 01.04.2016, 07:52 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 42
Репутация: 0 ±
Замечаний: 0% ±

2007
Pelena, я добавил ниже новые строки и вставил вашу первую формулу но он не посчитал мне, у меня большой список точек и ниже их суммы, разделяет их пробел но кол-во под ними строк разная с суммами, хочется одну формулу берешь ее везде вставляешь а он считает ) извиняюсь если не правильно объясняю :( :( :(
К сообщению приложен файл: 0668788-1-.xlsx(10Kb)
 
Ответить
СообщениеPelena, я добавил ниже новые строки и вставил вашу первую формулу но он не посчитал мне, у меня большой список точек и ниже их суммы, разделяет их пробел но кол-во под ними строк разная с суммами, хочется одну формулу берешь ее везде вставляешь а он считает ) извиняюсь если не правильно объясняю :( :( :(

Автор - Dimon2512
Дата добавления - 01.04.2016 в 07:52
_Boroda_ Дата: Пятница, 01.04.2016, 07:55 | Сообщение № 4
Группа: Модераторы
Ранг: Экселист
Сообщений: 9371
Репутация: 3947 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Поъожий вариант. Тоже формула массива, вводится одновременным нажатием Контрл Шифт Ентер

Код
=СУММ(C3:ИНДЕКС(C3:C999;ПОИСКПОЗ(;--C3:C999;)))


Для нового файла диапазон-то нужно изменить в формуле
К сообщению приложен файл: 0668788-1-1.xlsx(10Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеПоъожий вариант. Тоже формула массива, вводится одновременным нажатием Контрл Шифт Ентер

Код
=СУММ(C3:ИНДЕКС(C3:C999;ПОИСКПОЗ(;--C3:C999;)))


Для нового файла диапазон-то нужно изменить в формуле

Автор - _Boroda_
Дата добавления - 01.04.2016 в 07:55
Pelena Дата: Пятница, 01.04.2016, 07:56 | Сообщение № 5
Группа: Модераторы
Ранг: Экселист
Сообщений: 9864
Репутация: 2255 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
Ну так увеличьте диапазон в формуле, возьмите с запасом, я же не знаю, сколько у Вас может быть строк
Код
=СУММ(C3:ИНДЕКС(C3:$C$1000;ПОИСКПОЗ(ИСТИНА;C3:$C$1000="";0)))


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеНу так увеличьте диапазон в формуле, возьмите с запасом, я же не знаю, сколько у Вас может быть строк
Код
=СУММ(C3:ИНДЕКС(C3:$C$1000;ПОИСКПОЗ(ИСТИНА;C3:$C$1000="";0)))

Автор - Pelena
Дата добавления - 01.04.2016 в 07:56
Dimon2512 Дата: Пятница, 01.04.2016, 10:56 | Сообщение № 6
Группа: Пользователи
Ранг: Новичок
Сообщений: 42
Репутация: 0 ±
Замечаний: 0% ±

2007
Pelena, а в данной формуле можно использовать не сумм а ПРОМЕЖУТОЧНЫЕ.ИТОГИ ???
 
Ответить
СообщениеPelena, а в данной формуле можно использовать не сумм а ПРОМЕЖУТОЧНЫЕ.ИТОГИ ???

Автор - Dimon2512
Дата добавления - 01.04.2016 в 10:56
Pelena Дата: Пятница, 01.04.2016, 11:06 | Сообщение № 7
Группа: Модераторы
Ранг: Экселист
Сообщений: 9864
Репутация: 2255 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
Почему нет? Попробуйте


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеПочему нет? Попробуйте

Автор - Pelena
Дата добавления - 01.04.2016 в 11:06
Dimon2512 Дата: Пятница, 01.04.2016, 11:12 | Сообщение № 8
Группа: Пользователи
Ранг: Новичок
Сообщений: 42
Репутация: 0 ±
Замечаний: 0% ±

2007
Pelena, просто у меня не получается )))
 
Ответить
СообщениеPelena, просто у меня не получается )))

Автор - Dimon2512
Дата добавления - 01.04.2016 в 11:12
Pelena Дата: Пятница, 01.04.2016, 11:14 | Сообщение № 9
Группа: Модераторы
Ранг: Экселист
Сообщений: 9864
Репутация: 2255 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
Код
=ПРОМЕЖУТОЧНЫЕ.ИТОГИ(109;C3:ИНДЕКС(C3:$C$24;ПОИСКПОЗ(ИСТИНА;C3:$C$24="";0)))

И вводим как формулу массива Ctrl+Shift+Enter


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщение
Код
=ПРОМЕЖУТОЧНЫЕ.ИТОГИ(109;C3:ИНДЕКС(C3:$C$24;ПОИСКПОЗ(ИСТИНА;C3:$C$24="";0)))

И вводим как формулу массива Ctrl+Shift+Enter

Автор - Pelena
Дата добавления - 01.04.2016 в 11:14
Dimon2512 Дата: Пятница, 01.04.2016, 11:27 | Сообщение № 10
Группа: Пользователи
Ранг: Новичок
Сообщений: 42
Репутация: 0 ±
Замечаний: 0% ±

2007
Pelena, вот же СПАСИБО ОГРОМНОЕ
 
Ответить
СообщениеPelena, вот же СПАСИБО ОГРОМНОЕ

Автор - Dimon2512
Дата добавления - 01.04.2016 в 11:27
Wasilich Дата: Пятница, 01.04.2016, 12:57 | Сообщение № 11
Группа: Друзья
Ранг: Ветеран
Сообщений: 871
Репутация: 221 ±
Замечаний: 0% ±

2003
Ну вот почему обязательно формулами? Макросом же проще. :)
[vba]
Код
Sub Суммировать()
  sm = 0
  For i = 2 To 50
    If Cells(i, 3) > 0 Then
       sm = sm + Cells(i, 3)
    Else
      If sm > 0 Then
        Cells(i - 1, 4) = sm
        sm = 0
      End If
    End If
  Next
End Sub
[/vba]
К сообщению приложен файл: Dimon2512.xls(30Kb)
 
Ответить
СообщениеНу вот почему обязательно формулами? Макросом же проще. :)
[vba]
Код
Sub Суммировать()
  sm = 0
  For i = 2 To 50
    If Cells(i, 3) > 0 Then
       sm = sm + Cells(i, 3)
    Else
      If sm > 0 Then
        Cells(i - 1, 4) = sm
        sm = 0
      End If
    End If
  Next
End Sub
[/vba]

Автор - Wasilich
Дата добавления - 01.04.2016 в 12:57
Pelena Дата: Пятница, 01.04.2016, 13:13 | Сообщение № 12
Группа: Модераторы
Ранг: Экселист
Сообщений: 9864
Репутация: 2255 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
Макросом же проще

Ну, кому как :D


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщение
Макросом же проще

Ну, кому как :D

Автор - Pelena
Дата добавления - 01.04.2016 в 13:13
Мир MS Excel » Вопросы и решения » Вопросы по Excel » суммирование до пробела (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!