Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/заполнение полей поставщик с другого файла..... - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » заполнение полей поставщик с другого файла..... (Формулы/Formulas)
заполнение полей поставщик с другого файла.....
botveen Дата: Понедельник, 04.04.2016, 10:18 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Подскажите как реализовать заполнение полей...
Есть два файла 1.csv и поставщики гарант сервис.xlsx, нужно чтобы макрос в файле 1.csv прочитал второй столбец и сравнил с данными из первого столбца файла поставщик, если фирмы совпадают то скопировал данные со второго, третьего и четвертого столбца данной строки в 8,9,10 столбец файла 1.csv
[moder]Если без конкретики (а ее в Вашем вопросе нет - это я про файлы), то общая рекомендация - воспользуйтесь поиском, таких тем немереная куча.


Сообщение отредактировал _Boroda_ - Понедельник, 04.04.2016, 10:22
 
Ответить
СообщениеПодскажите как реализовать заполнение полей...
Есть два файла 1.csv и поставщики гарант сервис.xlsx, нужно чтобы макрос в файле 1.csv прочитал второй столбец и сравнил с данными из первого столбца файла поставщик, если фирмы совпадают то скопировал данные со второго, третьего и четвертого столбца данной строки в 8,9,10 столбец файла 1.csv
[moder]Если без конкретики (а ее в Вашем вопросе нет - это я про файлы), то общая рекомендация - воспользуйтесь поиском, таких тем немереная куча.

Автор - botveen
Дата добавления - 04.04.2016 в 10:18
botveen Дата: Понедельник, 04.04.2016, 10:43 | Сообщение № 2
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
вроде прикреплял файлы
К сообщению приложен файл: 7292032.csv(6Kb) · __.xlsx(19Kb)
 
Ответить
Сообщениевроде прикреплял файлы

Автор - botveen
Дата добавления - 04.04.2016 в 10:43
SLAVICK Дата: Понедельник, 04.04.2016, 11:04 | Сообщение № 3
Группа: Модераторы
Ранг: Старожил
Сообщений: 1849
Репутация: 614 ±
Замечаний: 0% ±

2007,2010,2013,2016
Откройте свой CSV в Excel.
Он откроется как обычный файл, с разбивкой по колонкам.
пропишите формулу:
Код
=ЕСЛИОШИБКА(ВПР($B1;[__.xlsx]Лист1!$A$1:$E$88;СТОЛБЕЦ(B1);0);"")

Сохраните файл.
В приложении что получилось - сохранил как обычный файл и как CSV

Подправил формулу - была не с 1-й строки.
К сообщению приложен файл: 8844891.csv(16Kb) · 7292032-1-.xlsx(29Kb)


Иногда все проще чем кажется с первого взгляда.

Сообщение отредактировал SLAVICK - Понедельник, 04.04.2016, 11:13
 
Ответить
СообщениеОткройте свой CSV в Excel.
Он откроется как обычный файл, с разбивкой по колонкам.
пропишите формулу:
Код
=ЕСЛИОШИБКА(ВПР($B1;[__.xlsx]Лист1!$A$1:$E$88;СТОЛБЕЦ(B1);0);"")

Сохраните файл.
В приложении что получилось - сохранил как обычный файл и как CSV

Подправил формулу - была не с 1-й строки.

Автор - SLAVICK
Дата добавления - 04.04.2016 в 11:04
Мир MS Excel » Вопросы и решения » Вопросы по Excel » заполнение полей поставщик с другого файла..... (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!