Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Функция срзнач без учета ошибок #н/д и дел/0 - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Функция срзнач без учета ошибок #н/д и дел/0 (Формулы/Formulas)
Функция срзнач без учета ошибок #н/д и дел/0
alisa111111 Дата: Понедельник, 04.04.2016, 13:54 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Нужно посчитать сред. значение по строке. Проблема в том, что некоторые ячейки содержать ошибки. Нужно, чтобы среднее значение считалось без их учета.
Не понимаю как указать это условие.
Прописала в таком виде - =СРЗНАЧ(СРЗНАЧЕСЛИ(C3:I3;">0");СРЗНАЧЕСЛИ(C3:I3;"<0"))
Но где-то считает, а где то нет
К сообщению приложен файл: 1698700.xlsx(19Kb)
 
Ответить
СообщениеНужно посчитать сред. значение по строке. Проблема в том, что некоторые ячейки содержать ошибки. Нужно, чтобы среднее значение считалось без их учета.
Не понимаю как указать это условие.
Прописала в таком виде - =СРЗНАЧ(СРЗНАЧЕСЛИ(C3:I3;">0");СРЗНАЧЕСЛИ(C3:I3;"<0"))
Но где-то считает, а где то нет

Автор - alisa111111
Дата добавления - 04.04.2016 в 13:54
Gustav Дата: Понедельник, 04.04.2016, 14:04 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1211
Репутация: 484 ±
Замечаний: 0% ±

начинал с Excel 4.0...
Формула массива (Ctrl+Shift+Enter)
Код
=СРЗНАЧ(ЕСЛИОШИБКА(C2:I2; ""))


До 2007 года (тоже формула массива):
Код
=СРЗНАЧ(ЕСЛИ(ЕОШИБКА(C2:I2); "";C2:I2))


Мой tip box - яд 41001663842605

Сообщение отредактировал Gustav - Понедельник, 04.04.2016, 14:06
 
Ответить
СообщениеФормула массива (Ctrl+Shift+Enter)
Код
=СРЗНАЧ(ЕСЛИОШИБКА(C2:I2; ""))


До 2007 года (тоже формула массива):
Код
=СРЗНАЧ(ЕСЛИ(ЕОШИБКА(C2:I2); "";C2:I2))

Автор - Gustav
Дата добавления - 04.04.2016 в 14:04
_Boroda_ Дата: Понедельник, 04.04.2016, 14:05 | Сообщение № 3
Группа: Модераторы
Ранг: Экселист
Сообщений: 9381
Репутация: 3951 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Код
=СРЗНАЧ(ЕСЛИОШИБКА(C2:I2;""))
Формула массива, вводится одновременным нажатием Контрл Шифт Ентер
А если по феншую делать, то нужно поправить те формулы, которые у Вас в столбцах С:I, чтобы они давали не ошибку, а пустое значение "". Тогда можно будет нормально считать.
Типа вот так
Код
=ЕСЛИОШИБКА(формула;"")


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Код
=СРЗНАЧ(ЕСЛИОШИБКА(C2:I2;""))
Формула массива, вводится одновременным нажатием Контрл Шифт Ентер
А если по феншую делать, то нужно поправить те формулы, которые у Вас в столбцах С:I, чтобы они давали не ошибку, а пустое значение "". Тогда можно будет нормально считать.
Типа вот так
Код
=ЕСЛИОШИБКА(формула;"")

Автор - _Boroda_
Дата добавления - 04.04.2016 в 14:05
Nic70y Дата: Понедельник, 04.04.2016, 14:05 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3493
Репутация: 724 ±
Замечаний: 0% ±

Excel 2013
формула массива
Код
=СРЗНАЧ(ЕСЛИ(ЕЧИСЛО(C2:I2);C2:I2))
Код
=ЕСЛИОШИБКА(СРЗНАЧ(ЕСЛИ(ЕЧИСЛО(C2:I2);C2:I2));"")
обратите внимание на B10
Прописала в таком виде
так вам среднее надо или среднее средних?

еще варианты, немассивной
Код
=СУММЕСЛИ(C2:I2;">-9E+307")/СЧЁТЕСЛИ(C2:I2;">-9E+307")
Код
=СРЗНАЧЕСЛИ(C2:I2;">-9E+307")
Код
=ЕСЛИОШИБКА(СУММЕСЛИ(C2:I2;">-9E+307")/СЧЁТЕСЛИ(C2:I2;">-9E+307");"")
Код
=ЕСЛИОШИБКА(СРЗНАЧЕСЛИ(C2:I2;">-9E+307");"")
К сообщению приложен файл: 5249727.xlsx(20Kb)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)


Сообщение отредактировал Nic70y - Понедельник, 04.04.2016, 14:42
 
Ответить
Сообщениеформула массива
Код
=СРЗНАЧ(ЕСЛИ(ЕЧИСЛО(C2:I2);C2:I2))
Код
=ЕСЛИОШИБКА(СРЗНАЧ(ЕСЛИ(ЕЧИСЛО(C2:I2);C2:I2));"")
обратите внимание на B10
Прописала в таком виде
так вам среднее надо или среднее средних?

еще варианты, немассивной
Код
=СУММЕСЛИ(C2:I2;">-9E+307")/СЧЁТЕСЛИ(C2:I2;">-9E+307")
Код
=СРЗНАЧЕСЛИ(C2:I2;">-9E+307")
Код
=ЕСЛИОШИБКА(СУММЕСЛИ(C2:I2;">-9E+307")/СЧЁТЕСЛИ(C2:I2;">-9E+307");"")
Код
=ЕСЛИОШИБКА(СРЗНАЧЕСЛИ(C2:I2;">-9E+307");"")

Автор - Nic70y
Дата добавления - 04.04.2016 в 14:05
jakim Дата: Понедельник, 04.04.2016, 17:06 | Сообщение № 5
Группа: Друзья
Ранг: Ветеран
Сообщений: 683
Репутация: 172 ±
Замечаний: 0% ±

Ещё одна обычная формула

Код
=SUMIF(B2:B97;"<1E100")/COUNT(B2:B97)


Сообщение отредактировал jakim - Понедельник, 04.04.2016, 17:07
 
Ответить
Сообщение
Ещё одна обычная формула

Код
=SUMIF(B2:B97;"<1E100")/COUNT(B2:B97)

Автор - jakim
Дата добавления - 04.04.2016 в 17:06
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Функция срзнач без учета ошибок #н/д и дел/0 (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!