Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/поиск значений в таблице ближайших к искомому - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » поиск значений в таблице ближайших к искомому (Формулы/Formulas)
поиск значений в таблице ближайших к искомому
makkc Дата: Понедельник, 04.04.2016, 15:33 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 10
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Уважаемые господа,
Поиск результатов не принес, поэтому прошу Вас помочь в решении следующей проблемы:
есть таблица с набором значений - из двух столбцов и 4х рядов ячеек и некое число. Необходимо выбрать из первого столбца ближайшие значения к числу, соответственно ближайшее большее и ближайшее меньшее. И выбрать из второго столбца соответствующие значения первому столбцу,
Заранее благодарен за потраченное Вами время,
Максим
[moder]Искомое число всегда меньше максимального и больше минимального? Если нет, то что тогда выводить?
И что делать при четком равенстве?[/moder]
Если искомое число точно равно одному из чисел в таблице, тогда выводится только одно число, и соответственно подбирается только одно число из столбца 2 ему соответствующее
К сообщению приложен файл: excelworld1.xlsx(10Kb)


Сообщение отредактировал makkc - Понедельник, 04.04.2016, 15:43
 
Ответить
СообщениеУважаемые господа,
Поиск результатов не принес, поэтому прошу Вас помочь в решении следующей проблемы:
есть таблица с набором значений - из двух столбцов и 4х рядов ячеек и некое число. Необходимо выбрать из первого столбца ближайшие значения к числу, соответственно ближайшее большее и ближайшее меньшее. И выбрать из второго столбца соответствующие значения первому столбцу,
Заранее благодарен за потраченное Вами время,
Максим
[moder]Искомое число всегда меньше максимального и больше минимального? Если нет, то что тогда выводить?
И что делать при четком равенстве?[/moder]
Если искомое число точно равно одному из чисел в таблице, тогда выводится только одно число, и соответственно подбирается только одно число из столбца 2 ему соответствующее

Автор - makkc
Дата добавления - 04.04.2016 в 15:33
Pelena Дата: Понедельник, 04.04.2016, 15:39 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11493
Репутация: 2556 ±
Замечаний: 0% ±

Excel 2010, 2016 & Mac Excel
Формула массива
Код
=МАКС(ЕСЛИ($C$9:$C$12<=C16;$C$9:$C$12))

и
Код
=ВПР(K18;$C$9:$D$12;2;0)
К сообщению приложен файл: 3635073.xlsx(10Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеФормула массива
Код
=МАКС(ЕСЛИ($C$9:$C$12<=C16;$C$9:$C$12))

и
Код
=ВПР(K18;$C$9:$D$12;2;0)

Автор - Pelena
Дата добавления - 04.04.2016 в 15:39
SLAVICK Дата: Понедельник, 04.04.2016, 15:42 | Сообщение № 3
Группа: Модераторы
Ранг: Старожил
Сообщений: 2003
Репутация: 674 ±
Замечаний: 0% ±

2007,2010,2013,2016
Формулы массива:
Для меньшего
Код
=МАКС(ЕСЛИ(C9:C12<C16;C9:C12;0))

Для большего
Код
=МИН(ЕСЛИ(C9:C12>C16;C9:C12;9^9))


Поиск значений:
Код
=ВПР(L18;$C$9:$D$12;2;0)
К сообщению приложен файл: 4281095.xlsx(10Kb)


Иногда все проще чем кажется с первого взгляда.
 
Ответить
СообщениеФормулы массива:
Для меньшего
Код
=МАКС(ЕСЛИ(C9:C12<C16;C9:C12;0))

Для большего
Код
=МИН(ЕСЛИ(C9:C12>C16;C9:C12;9^9))


Поиск значений:
Код
=ВПР(L18;$C$9:$D$12;2;0)

Автор - SLAVICK
Дата добавления - 04.04.2016 в 15:42
_Boroda_ Дата: Понедельник, 04.04.2016, 15:46 | Сообщение № 4
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11332
Репутация: 4677 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
обычные формулы
Код
=ПРОСМОТР(;-1/(C9:C12<=C16);C9:C12)

Код
=ЕСЛИ(K18=C16;"";ПРОСМОТР(;-1/(C9:C12<=C16);C10:C13))
К сообщению приложен файл: excelworld1_1.xlsx(10Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщениеобычные формулы
Код
=ПРОСМОТР(;-1/(C9:C12<=C16);C9:C12)

Код
=ЕСЛИ(K18=C16;"";ПРОСМОТР(;-1/(C9:C12<=C16);C10:C13))

Автор - _Boroda_
Дата добавления - 04.04.2016 в 15:46
Udik Дата: Понедельник, 04.04.2016, 15:54 | Сообщение № 5
Группа: Друзья
Ранг: Старожил
Сообщений: 1588
Репутация: 191 ±
Замечаний: 0% ±

Excel 2016 х 64
makkc, данные всегда отсортированы?


вот вам барабан
яд 41001231307558 wm R419131876897
udik1968@gmail.com
 
Ответить
Сообщениеmakkc, данные всегда отсортированы?

Автор - Udik
Дата добавления - 04.04.2016 в 15:54
makkc Дата: Понедельник, 04.04.2016, 15:57 | Сообщение № 6
Группа: Пользователи
Ранг: Новичок
Сообщений: 10
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Udik, да. Содержимое таблицы не меняется
 
Ответить
СообщениеUdik, да. Содержимое таблицы не меняется

Автор - makkc
Дата добавления - 04.04.2016 в 15:57
Мир MS Excel » Вопросы и решения » Вопросы по Excel » поиск значений в таблице ближайших к искомому (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!