Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/подбор позиций из списка - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » подбор позиций из списка (Формулы/Formulas)
подбор позиций из списка
zaak88 Дата: Вторник, 05.04.2016, 14:30 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 94
Репутация: 1 ±
Замечаний: 40% ±

Excel 2013
Добрый день! Друзья, выручайте, хочется вывести позиции из списка листа 1 (зелёным цветом) в аналоги листа 2 - жёлтая колонка, в соответствии с названиями.
К сообщению приложен файл: 0616614.xlsx(13Kb)
 
Ответить
СообщениеДобрый день! Друзья, выручайте, хочется вывести позиции из списка листа 1 (зелёным цветом) в аналоги листа 2 - жёлтая колонка, в соответствии с названиями.

Автор - zaak88
Дата добавления - 05.04.2016 в 14:30
китин Дата: Вторник, 05.04.2016, 14:38 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3454
Репутация: 549 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
так?
Код
=ЕСЛИ(C3="";"";ЕСЛИОШИБКА(ИНДЕКС(Лист1!$D$5:$D$47;ПОИСКПОЗ(Лист2!$C3;Лист1!$F$5:$F$47;0));"Нет остатков"))
К сообщению приложен файл: 16614.xlsx(14Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениетак?
Код
=ЕСЛИ(C3="";"";ЕСЛИОШИБКА(ИНДЕКС(Лист1!$D$5:$D$47;ПОИСКПОЗ(Лист2!$C3;Лист1!$F$5:$F$47;0));"Нет остатков"))

Автор - китин
Дата добавления - 05.04.2016 в 14:38
zaak88 Дата: Вторник, 05.04.2016, 14:41 | Сообщение № 3
Группа: Пользователи
Ранг: Участник
Сообщений: 94
Репутация: 1 ±
Замечаний: 40% ±

Excel 2013
китин, спасибо, нет остатков не нужно вписывать, просто кавычки... очень помогли!!!
 
Ответить
Сообщениекитин, спасибо, нет остатков не нужно вписывать, просто кавычки... очень помогли!!!

Автор - zaak88
Дата добавления - 05.04.2016 в 14:41
zaak88 Дата: Вторник, 05.04.2016, 14:57 | Сообщение № 4
Группа: Пользователи
Ранг: Участник
Сообщений: 94
Репутация: 1 ±
Замечаний: 40% ±

Excel 2013
немного только не до конца, в некоторых позициях хочется видеть по 2,3, 4 аналога... например липосан выделил цветов... то есть перечисление в колонке аналог выводить через запятую все позиции зелёного списка! Спасибо!
К сообщению приложен файл: 8212508.xlsx(14Kb)
 
Ответить
Сообщениенемного только не до конца, в некоторых позициях хочется видеть по 2,3, 4 аналога... например липосан выделил цветов... то есть перечисление в колонке аналог выводить через запятую все позиции зелёного списка! Спасибо!

Автор - zaak88
Дата добавления - 05.04.2016 в 14:57
zaak88 Дата: Среда, 06.04.2016, 08:20 | Сообщение № 5
Группа: Пользователи
Ранг: Участник
Сообщений: 94
Репутация: 1 ±
Замечаний: 40% ±

Excel 2013
нет вариантов?
 
Ответить
Сообщениенет вариантов?

Автор - zaak88
Дата добавления - 06.04.2016 в 08:20
китин Дата: Среда, 06.04.2016, 08:48 | Сообщение № 6
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3454
Репутация: 549 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
нет вариантов?

на формулах это трудновато. %) слишком много условий.Потерпите может кому будет когда нечего делать. :D а так наберите в Поиске СцепитьЕсли. Там варианты на макросах


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538


Сообщение отредактировал китин - Среда, 06.04.2016, 08:49
 
Ответить
Сообщение
нет вариантов?

на формулах это трудновато. %) слишком много условий.Потерпите может кому будет когда нечего делать. :D а так наберите в Поиске СцепитьЕсли. Там варианты на макросах

Автор - китин
Дата добавления - 06.04.2016 в 08:48
zaak88 Дата: Среда, 06.04.2016, 10:04 | Сообщение № 7
Группа: Пользователи
Ранг: Участник
Сообщений: 94
Репутация: 1 ±
Замечаний: 40% ±

Excel 2013
китин, ок! благодарю!
 
Ответить
Сообщениекитин, ок! благодарю!

Автор - zaak88
Дата добавления - 06.04.2016 в 10:04
Мир MS Excel » Вопросы и решения » Вопросы по Excel » подбор позиций из списка (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!