Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/вывести ненулевые позиции отдельным списком - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » вывести ненулевые позиции отдельным списком (Формулы/Formulas)
вывести ненулевые позиции отдельным списком
zaak88 Дата: Вторник, 05.04.2016, 14:35 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 94
Репутация: 1 ±
Замечаний: 40% ±

Excel 2013
Добрый день! Помогите, друзья, хочется вывести ненулевые позиции 2-го листа отдельным списком на первом листе. Зелёным то откуда брать данные, жёлтым то, куда вставлять.
К сообщению приложен файл: 1228205.xlsx(10Kb)
 
Ответить
СообщениеДобрый день! Помогите, друзья, хочется вывести ненулевые позиции 2-го листа отдельным списком на первом листе. Зелёным то откуда брать данные, жёлтым то, куда вставлять.

Автор - zaak88
Дата добавления - 05.04.2016 в 14:35
akobir Дата: Вторник, 05.04.2016, 14:46 | Сообщение № 2
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 159
Репутация: 9 ±
Замечаний: 0% ±

Excel 2010
Зачем усложнять?
Поставьте фильтр, уберите пустые ячейки и скопируйте данные на другой лист...


e-mail: akobir.ismailov@gmail.com
 
Ответить
СообщениеЗачем усложнять?
Поставьте фильтр, уберите пустые ячейки и скопируйте данные на другой лист...

Автор - akobir
Дата добавления - 05.04.2016 в 14:46
китин Дата: Вторник, 05.04.2016, 14:49 | Сообщение № 3
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3413
Репутация: 543 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
Зачем усложнять?

а если очень хочется? :D
Код
=ЕСЛИОШИБКА(ИНДЕКС(Лист2!$A$6:$A$26;НАИМЕНЬШИЙ(ЕСЛИ(ЕЧИСЛО(Лист2!$G$6:$G$26);СТРОКА(Лист2!$G$6:$G$26)-5);СТРОКА(A1)));"")
формула массива
К сообщению приложен файл: 28205.xlsx(12Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщение
Зачем усложнять?

а если очень хочется? :D
Код
=ЕСЛИОШИБКА(ИНДЕКС(Лист2!$A$6:$A$26;НАИМЕНЬШИЙ(ЕСЛИ(ЕЧИСЛО(Лист2!$G$6:$G$26);СТРОКА(Лист2!$G$6:$G$26)-5);СТРОКА(A1)));"")
формула массива

Автор - китин
Дата добавления - 05.04.2016 в 14:49
_Boroda_ Дата: Вторник, 05.04.2016, 14:55 | Сообщение № 4
Группа: Модераторы
Ранг: Экселист
Сообщений: 9348
Репутация: 3923 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Или по возрастанию остатка. Обычные формулы
Код
=ЕСЛИОШИБКА(НАИМЕНЬШИЙ(Лист2!G$6:G$99;СТРОКА(A1));"")

Код
=ЕСЛИОШИБКА(ИНДЕКС(Лист2!A$6:A$99;ПОИСКПОЗ(C4;Лист2!G$6:G$99;));"")
К сообщению приложен файл: 1228205_1.xlsx(11Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеИли по возрастанию остатка. Обычные формулы
Код
=ЕСЛИОШИБКА(НАИМЕНЬШИЙ(Лист2!G$6:G$99;СТРОКА(A1));"")

Код
=ЕСЛИОШИБКА(ИНДЕКС(Лист2!A$6:A$99;ПОИСКПОЗ(C4;Лист2!G$6:G$99;));"")

Автор - _Boroda_
Дата добавления - 05.04.2016 в 14:55
akobir Дата: Вторник, 05.04.2016, 15:22 | Сообщение № 5
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 159
Репутация: 9 ±
Замечаний: 0% ±

Excel 2010
китин, Так а смысл? Формулу нужно будет либо выучить, либо понять как ей пользоваться, либо огромное количество раз задавать вопрос на форуме. Фильтр нужно просто поставить...
[moder]Правильно, и навсегда остаться неучем.


e-mail: akobir.ismailov@gmail.com

Сообщение отредактировал _Boroda_ - Вторник, 05.04.2016, 15:24
 
Ответить
Сообщениекитин, Так а смысл? Формулу нужно будет либо выучить, либо понять как ей пользоваться, либо огромное количество раз задавать вопрос на форуме. Фильтр нужно просто поставить...
[moder]Правильно, и навсегда остаться неучем.

Автор - akobir
Дата добавления - 05.04.2016 в 15:22
zaak88 Дата: Вторник, 05.04.2016, 16:38 | Сообщение № 6
Группа: Пользователи
Ранг: Участник
Сообщений: 94
Репутация: 1 ±
Замечаний: 40% ±

Excel 2013
_Boroda_, спасибо!!! круто!
 
Ответить
Сообщение_Boroda_, спасибо!!! круто!

Автор - zaak88
Дата добавления - 05.04.2016 в 16:38
zaak88 Дата: Среда, 06.04.2016, 08:24 | Сообщение № 7
Группа: Пользователи
Ранг: Участник
Сообщений: 94
Репутация: 1 ±
Замечаний: 40% ±

Excel 2013
akobir, те формулы, что здесь пишут (например boroda) многому учат и помогают в конкретных ситуациях, мне например помогли и во многих аналогичных ситуациях... а разово фильтрануть можно конечно, но вот исходная информация может поменяться...
 
Ответить
Сообщениеakobir, те формулы, что здесь пишут (например boroda) многому учат и помогают в конкретных ситуациях, мне например помогли и во многих аналогичных ситуациях... а разово фильтрануть можно конечно, но вот исходная информация может поменяться...

Автор - zaak88
Дата добавления - 06.04.2016 в 08:24
китин Дата: Среда, 06.04.2016, 08:45 | Сообщение № 8
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3413
Репутация: 543 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
ормулу нужно будет либо выучить, либо понять как ей пользоваться

ну это то как раз не так уж и сложно. :D


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщение
ормулу нужно будет либо выучить, либо понять как ей пользоваться

ну это то как раз не так уж и сложно. :D

Автор - китин
Дата добавления - 06.04.2016 в 08:45
Мир MS Excel » Вопросы и решения » Вопросы по Excel » вывести ненулевые позиции отдельным списком (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!