Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Подсчет количества чисел соответствующих диапазону - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчет количества чисел соответствующих диапазону (Формулы/Formulas)
Подсчет количества чисел соответствующих диапазону
Sancho Дата: Среда, 06.04.2016, 23:04 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 88
Репутация: 0 ±
Замечаний: 0% ±

2007, 2010, 2013
Что то я споткнулся сегодня на казалось бы элементарном. нужно подсчитать количество человек соответствующего возраста:
до 35 лет
Код
=СУММПРОИЗВ(($A$1:$A$26=$E3)*($B$1:$B$26<=35))

более 45 лет
Код
=СУММПРОИЗВ(($A$1:$A$26=$E3)*($B$1:$B$26>45))

а вот подсчитать количество соответствующих диапазону от 36 до 45 лет не смог. конечно нашел выход отняв от общей численности полученные суммы. Но вот если таких диапазонов будет несколько то боюсь представить.
Подскажите пожалуйста.
[moder]Формулы нужно сувать в теги.
К сообщению приложен файл: -__.xlsx(9Kb)


Сообщение отредактировал _Boroda_ - Среда, 06.04.2016, 23:08
 
Ответить
СообщениеЧто то я споткнулся сегодня на казалось бы элементарном. нужно подсчитать количество человек соответствующего возраста:
до 35 лет
Код
=СУММПРОИЗВ(($A$1:$A$26=$E3)*($B$1:$B$26<=35))

более 45 лет
Код
=СУММПРОИЗВ(($A$1:$A$26=$E3)*($B$1:$B$26>45))

а вот подсчитать количество соответствующих диапазону от 36 до 45 лет не смог. конечно нашел выход отняв от общей численности полученные суммы. Но вот если таких диапазонов будет несколько то боюсь представить.
Подскажите пожалуйста.
[moder]Формулы нужно сувать в теги.

Автор - Sancho
Дата добавления - 06.04.2016 в 23:04
_Boroda_ Дата: Среда, 06.04.2016, 23:09 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 9367
Репутация: 3940 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно? Файл не смотрел
Код
=СУММПРОИЗВ((A1:A26=E4)*(B1:B26>35)*(B1:B26<=45))

Посмотрел.
Еще так можно
Код
=СЧЁТЕСЛИМН(A1:A26;E3;B1:B26;">35";B1:B26;"<=45")
К сообщению приложен файл: -1.xlsx(9Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно? Файл не смотрел
Код
=СУММПРОИЗВ((A1:A26=E4)*(B1:B26>35)*(B1:B26<=45))

Посмотрел.
Еще так можно
Код
=СЧЁТЕСЛИМН(A1:A26;E3;B1:B26;">35";B1:B26;"<=45")

Автор - _Boroda_
Дата добавления - 06.04.2016 в 23:09
IgorStorm Дата: Среда, 06.04.2016, 23:11 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 26
Репутация: 1 ±
Замечаний: 0% ±

Excel 2007
СЧЕТЕЕСЛИМН?
К сообщению приложен файл: 3922161.xlsx(9Kb)
 
Ответить
СообщениеСЧЕТЕЕСЛИМН?

Автор - IgorStorm
Дата добавления - 06.04.2016 в 23:11
Sancho Дата: Среда, 06.04.2016, 23:22 | Сообщение № 4
Группа: Пользователи
Ранг: Участник
Сообщений: 88
Репутация: 0 ±
Замечаний: 0% ±

2007, 2010, 2013
Так нужно? Файл не смотрел

=СУММПРОИЗВ(($A$1:$A$26=$E3)*($B$1:$B$26>35)*($B$1:$B$26<=45))


ХМ, да так. Я думал что получится подсчет не в диапазоне, а подсчет суммы более 35 + суммы менее 45, поэтому так даже не пробовал. Спасибо, теперь буду знать.
 
Ответить
Сообщение
Так нужно? Файл не смотрел

=СУММПРОИЗВ(($A$1:$A$26=$E3)*($B$1:$B$26>35)*($B$1:$B$26<=45))


ХМ, да так. Я думал что получится подсчет не в диапазоне, а подсчет суммы более 35 + суммы менее 45, поэтому так даже не пробовал. Спасибо, теперь буду знать.

Автор - Sancho
Дата добавления - 06.04.2016 в 23:22
zaak88 Дата: Четверг, 07.04.2016, 08:31 | Сообщение № 5
Группа: Пользователи
Ранг: Участник
Сообщений: 94
Репутация: 1 ±
Замечаний: 40% ±

Excel 2013
_Boroda_, а чего разными способами разный итог?
 
Ответить
Сообщение_Boroda_, а чего разными способами разный итог?

Автор - zaak88
Дата добавления - 07.04.2016 в 08:31
китин Дата: Четверг, 07.04.2016, 08:36 | Сообщение № 6
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3433
Репутация: 544 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
zaak88, с чего бы это разный? там цеха разные, поэтому и итог разный :D :p


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениеzaak88, с чего бы это разный? там цеха разные, поэтому и итог разный :D :p

Автор - китин
Дата добавления - 07.04.2016 в 08:36
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчет количества чисел соответствующих диапазону (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!