Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Перемножение массивов - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Перемножение массивов (Формулы/Formulas)
Перемножение массивов
GAS1979 Дата: Четверг, 14.04.2016, 12:53 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 13
Репутация: 0 ±
Замечаний: 20% ±

Excel 2013
Здравствуйте. Столкнулся с такой проблемой, как упростить формулу:
Код
=C11*$B$4+D11*$B$3+E11*$B$7+F11*$B$6+G11*$B$5

Так как это пример из 5 переменных, а если их сотни.
Вроде должно быть просто, но не могу сообразить.
Заранее спасибо.
[moder]Оформляйте формулы тегами (кнопка fx). Исправила на первый раз[/moder]
К сообщению приложен файл: 6486166.xlsx(9Kb)


Сообщение отредактировал Pelena - Четверг, 14.04.2016, 13:11
 
Ответить
СообщениеЗдравствуйте. Столкнулся с такой проблемой, как упростить формулу:
Код
=C11*$B$4+D11*$B$3+E11*$B$7+F11*$B$6+G11*$B$5

Так как это пример из 5 переменных, а если их сотни.
Вроде должно быть просто, но не могу сообразить.
Заранее спасибо.
[moder]Оформляйте формулы тегами (кнопка fx). Исправила на первый раз[/moder]

Автор - GAS1979
Дата добавления - 14.04.2016 в 12:53
akobir Дата: Четверг, 14.04.2016, 12:57 | Сообщение № 2
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 159
Репутация: 9 ±
Замечаний: 0% ±

Excel 2010
GAS1979,
Код
СУММПРОИЗВ()

Код
=СУММПРОИЗВ(B3:B7;ТРАНСП(C11:G11))


UPD: Разные массивы. Формулу исправил. Формула массивная: одновременно нужно нажать ctrl+shift+enter


e-mail: akobir.ismailov@gmail.com

Сообщение отредактировал akobir - Четверг, 14.04.2016, 13:01
 
Ответить
СообщениеGAS1979,
Код
СУММПРОИЗВ()

Код
=СУММПРОИЗВ(B3:B7;ТРАНСП(C11:G11))


UPD: Разные массивы. Формулу исправил. Формула массивная: одновременно нужно нажать ctrl+shift+enter

Автор - akobir
Дата добавления - 14.04.2016 в 12:57
GAS1979 Дата: Четверг, 14.04.2016, 13:07 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 13
Репутация: 0 ±
Замечаний: 20% ±

Excel 2013
=СУММПРОИЗВ(B3:B7;ТРАНСП(C11:G11))

Это если порядок одинаковый в первом и втором массивах, а если разный?
 
Ответить
Сообщение
=СУММПРОИЗВ(B3:B7;ТРАНСП(C11:G11))

Это если порядок одинаковый в первом и втором массивах, а если разный?

Автор - GAS1979
Дата добавления - 14.04.2016 в 13:07
китин Дата: Четверг, 14.04.2016, 13:08 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3423
Репутация: 543 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
ну наверно вот так
Код
=СУММПРОИЗВ($C11:$G11*ЕСЛИ($A$3:$A$7=ЕСЛИ(ЕЧИСЛО($C11:$G11);$C$10:$G$10);$B$3:$B$7))
не забываем что это формула массива(одновременно нужно нажать ctrl+shift+enter
)
[moder] GAS1979, поправьте свой первый пост - формулы нужно обрамлять тегами - см. Правила форума.
А akobirу и китину должно быть стыдно - видите же, что нарушение Правил, а все равно отвечаете.
Ладно, добрая Лена уже поправила.
К сообщению приложен файл: 86166.xlsx(9Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538


Сообщение отредактировал _Boroda_ - Четверг, 14.04.2016, 13:14
 
Ответить
Сообщениену наверно вот так
Код
=СУММПРОИЗВ($C11:$G11*ЕСЛИ($A$3:$A$7=ЕСЛИ(ЕЧИСЛО($C11:$G11);$C$10:$G$10);$B$3:$B$7))
не забываем что это формула массива(одновременно нужно нажать ctrl+shift+enter
)
[moder] GAS1979, поправьте свой первый пост - формулы нужно обрамлять тегами - см. Правила форума.
А akobirу и китину должно быть стыдно - видите же, что нарушение Правил, а все равно отвечаете.
Ладно, добрая Лена уже поправила.

Автор - китин
Дата добавления - 14.04.2016 в 13:08
akobir Дата: Четверг, 14.04.2016, 13:24 | Сообщение № 5
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 159
Репутация: 9 ±
Замечаний: 0% ±

Excel 2010
Это если порядок одинаковый в первом и втором массивах, а если разный?

А я и не заметил, что порядок разный.

@Boroda, Прошу прощения. :)


e-mail: akobir.ismailov@gmail.com
 
Ответить
Сообщение
Это если порядок одинаковый в первом и втором массивах, а если разный?

А я и не заметил, что порядок разный.

@Boroda, Прошу прощения. :)

Автор - akobir
Дата добавления - 14.04.2016 в 13:24
_Boroda_ Дата: Четверг, 14.04.2016, 13:24 | Сообщение № 6
Группа: Модераторы
Ранг: Экселист
Сообщений: 9354
Репутация: 3924 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Вариант обычной формулой
Код
=СУММПРОИЗВ((C$10:G$10=A$3:A$7)*B$3:B$7*C11:G11)
К сообщению приложен файл: 6486166_1.xlsx(9Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеВариант обычной формулой
Код
=СУММПРОИЗВ((C$10:G$10=A$3:A$7)*B$3:B$7*C11:G11)

Автор - _Boroda_
Дата добавления - 14.04.2016 в 13:24
китин Дата: Четверг, 14.04.2016, 13:29 | Сообщение № 7
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3423
Репутация: 543 ±
Замечаний: 0% ±

Excel 2007;Excel 2010


К сообщению приложен файл: 7866209.gif(41Kb) · 1467349.gif(33Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538


Сообщение отредактировал китин - Четверг, 14.04.2016, 13:30
 
Ответить
Сообщение


Автор - китин
Дата добавления - 14.04.2016 в 13:29
GAS1979 Дата: Четверг, 14.04.2016, 15:39 | Сообщение № 8
Группа: Пользователи
Ранг: Новичок
Сообщений: 13
Репутация: 0 ±
Замечаний: 20% ±

Excel 2013
Спасибо всем. Извините за оформление.
Получил, что требовалось.
 
Ответить
СообщениеСпасибо всем. Извините за оформление.
Получил, что требовалось.

Автор - GAS1979
Дата добавления - 14.04.2016 в 15:39
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Перемножение массивов (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!