Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/как не трогать содержимое ячейки если ложь? - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » как не трогать содержимое ячейки если ложь? (Формулы/Formulas)
как не трогать содержимое ячейки если ложь?
vladislaf Дата: Суббота, 16.04.2016, 16:45 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 29
Репутация: 0 ±
Замечаний: 20% ±

Excel 2013
Добрый день!
Помогите пожалуйста с формулой.
Если находим в столбце 2 текст вместе с квадратными скобками:
[Модели диванов и мягкой мебели снятые с производства],
то в ячейке с той же строке, но 11 столце пишем 1, если нет, то оставляем ячейку с тем же с чем она и была.
Не знаю как сделать чтобы не трогать содержимое ячейки, если ложь.
Файлик в приложении.
К сообщению приложен файл: 2009375.xlsx(25Kb)
 
Ответить
СообщениеДобрый день!
Помогите пожалуйста с формулой.
Если находим в столбце 2 текст вместе с квадратными скобками:
[Модели диванов и мягкой мебели снятые с производства],
то в ячейке с той же строке, но 11 столце пишем 1, если нет, то оставляем ячейку с тем же с чем она и была.
Не знаю как сделать чтобы не трогать содержимое ячейки, если ложь.
Файлик в приложении.

Автор - vladislaf
Дата добавления - 16.04.2016 в 16:45
Manyasha Дата: Суббота, 16.04.2016, 17:03 | Сообщение № 2
Группа: Модераторы
Ранг: Старожил
Сообщений: 1589
Репутация: 669 ±
Замечаний: 0% ±

Excel 2007, 2010
vladislaf, вариант выбрать фильтром по столбцу 2 строки с "[" и проставить единички не подходит?
Можно еще в доп. столбец формулу:
Код
=ЕСЛИОШИБКА(ПОИСК("[";B3)^0;K3)


Если оба варианта не подходят, тогда макросом.
К сообщению приложен файл: 2009375-1.xlsx(27Kb)


marinamorozova_box@mail.ru
ЯД: 410013299366744 WM: R193491431804
 
Ответить
Сообщениеvladislaf, вариант выбрать фильтром по столбцу 2 строки с "[" и проставить единички не подходит?
Можно еще в доп. столбец формулу:
Код
=ЕСЛИОШИБКА(ПОИСК("[";B3)^0;K3)


Если оба варианта не подходят, тогда макросом.

Автор - Manyasha
Дата добавления - 16.04.2016 в 17:03
Мир MS Excel » Вопросы и решения » Вопросы по Excel » как не трогать содержимое ячейки если ложь? (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!