Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Подобрать на основе одного ряда данных другой меньше даты - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подобрать на основе одного ряда данных другой меньше даты (Формулы/Formulas)
Подобрать на основе одного ряда данных другой меньше даты
zaak88 Дата: Понедельник, 18.04.2016, 18:24 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 121
Репутация: 1 ±
Замечаний: 0% ±

Excel 2013
Добрый день, друзья! Помогите, пожалуйста! Требуется вывести список позиций на листе 2 (выделено красным) таким образом, чтобы список был сформирован на дату - выделено жёлтым и менее. Аналогично просуммировать по этим позициям (план и факт), не суммируя те же позиции в будущем периоде. Спасибо!
К сообщению приложен файл: 9049539.xlsx(72Kb)


Сообщение отредактировал zaak88 - Понедельник, 18.04.2016, 18:25
 
Ответить
СообщениеДобрый день, друзья! Помогите, пожалуйста! Требуется вывести список позиций на листе 2 (выделено красным) таким образом, чтобы список был сформирован на дату - выделено жёлтым и менее. Аналогично просуммировать по этим позициям (план и факт), не суммируя те же позиции в будущем периоде. Спасибо!

Автор - zaak88
Дата добавления - 18.04.2016 в 18:24
_Boroda_ Дата: Понедельник, 18.04.2016, 20:02 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 10334
Репутация: 4357 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Код
=ЕСЛИОШИБКА(ИНДЕКС(Лист1!E$3:E$682;ПОИСКПОЗ(;СЧЁТЕСЛИ(A$4:A4;ЕСЛИ(Лист1!M$3:M$682<=A$2;Лист1!E$3:E$682;A$4));));"")

Код
=СУММЕСЛИМН(Лист1!$O$3:$O$682;Лист1!$M$3:$M$682;"<"&$A$2;Лист1!$E$3:$E$682;$A5;Лист1!$K$3:$K$682;ПРАВБ(B$4;4))

Первая формула массивная, вводится одновременным нажатием Контрл Шифт Ентер
К сообщению приложен файл: 9049539_1.xlsx(82Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Код
=ЕСЛИОШИБКА(ИНДЕКС(Лист1!E$3:E$682;ПОИСКПОЗ(;СЧЁТЕСЛИ(A$4:A4;ЕСЛИ(Лист1!M$3:M$682<=A$2;Лист1!E$3:E$682;A$4));));"")

Код
=СУММЕСЛИМН(Лист1!$O$3:$O$682;Лист1!$M$3:$M$682;"<"&$A$2;Лист1!$E$3:$E$682;$A5;Лист1!$K$3:$K$682;ПРАВБ(B$4;4))

Первая формула массивная, вводится одновременным нажатием Контрл Шифт Ентер

Автор - _Boroda_
Дата добавления - 18.04.2016 в 20:02
zaak88 Дата: Понедельник, 18.04.2016, 21:12 | Сообщение № 3
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 121
Репутация: 1 ±
Замечаний: 0% ±

Excel 2013
_Boroda_, респект в очередной раз!!!
список класс!!! а вот сумма немного не то... максим экстрим должен 0 выводить в плане, а он суммирует....
 
Ответить
Сообщение_Boroda_, респект в очередной раз!!!
список класс!!! а вот сумма немного не то... максим экстрим должен 0 выводить в плане, а он суммирует....

Автор - zaak88
Дата добавления - 18.04.2016 в 21:12
zaak88 Дата: Понедельник, 18.04.2016, 21:55 | Сообщение № 4
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 121
Репутация: 1 ±
Замечаний: 0% ±

Excel 2013
_Boroda_, сумма только по г.Курск, а там другие... город над таблицей, ячейка B3....
 
Ответить
Сообщение_Boroda_, сумма только по г.Курск, а там другие... город над таблицей, ячейка B3....

Автор - zaak88
Дата добавления - 18.04.2016 в 21:55
_Boroda_ Дата: Понедельник, 18.04.2016, 22:03 | Сообщение № 5
Группа: Модераторы
Ранг: Экселист
Сообщений: 10334
Репутация: 4357 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
А, ну тогда просто добавляем еще условие
Код
=СУММЕСЛИМН(Лист1!$O$3:$O$682;Лист1!$M$3:$M$682;"<"&$A$2;Лист1!$E$3:$E$682;$A5;Лист1!$K$3:$K$682;ПРАВБ(B$4;4);Лист1!$N$3:$N$682;ЛЕВБ(B$4;ПОИСК("-";B$4)-1))

Только смотрите, сильно вниз не размахивайтесь - формулы тяжелые, тормозить будут.
К сообщению приложен файл: 9049539_2.xlsx(82Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеА, ну тогда просто добавляем еще условие
Код
=СУММЕСЛИМН(Лист1!$O$3:$O$682;Лист1!$M$3:$M$682;"<"&$A$2;Лист1!$E$3:$E$682;$A5;Лист1!$K$3:$K$682;ПРАВБ(B$4;4);Лист1!$N$3:$N$682;ЛЕВБ(B$4;ПОИСК("-";B$4)-1))

Только смотрите, сильно вниз не размахивайтесь - формулы тяжелые, тормозить будут.

Автор - _Boroda_
Дата добавления - 18.04.2016 в 22:03
zaak88 Дата: Вторник, 19.04.2016, 08:16 | Сообщение № 6
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 121
Репутация: 1 ±
Замечаний: 0% ±

Excel 2013
_Boroda_, спасибо огромнейшее!
 
Ответить
Сообщение_Boroda_, спасибо огромнейшее!

Автор - zaak88
Дата добавления - 19.04.2016 в 08:16
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подобрать на основе одного ряда данных другой меньше даты (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!