Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Перенос данных с одного листа на другой. ВПР. - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Перенос данных с одного листа на другой. ВПР. (Формулы/Formulas)
Перенос данных с одного листа на другой. ВПР.
ncpol Дата: Понедельник, 18.04.2016, 19:39 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Добрый день!

Не могу собрать формулу для следующей задачи:
Имеется 2 массива данных на 2-х листах. Первый лист список товаров с названиями из моей базы, 2 лист список товаров из данных поставщика. Точного совпадения наименований нет, но, есть точные вхождения. Как прописать формулу, чтобы перенести цены с одного листа в другой?

Заранее спасибо за ответы и решения!
К сообщению приложен файл: price-site.xlsx(19Kb)
 
Ответить
СообщениеДобрый день!

Не могу собрать формулу для следующей задачи:
Имеется 2 массива данных на 2-х листах. Первый лист список товаров с названиями из моей базы, 2 лист список товаров из данных поставщика. Точного совпадения наименований нет, но, есть точные вхождения. Как прописать формулу, чтобы перенести цены с одного листа в другой?

Заранее спасибо за ответы и решения!

Автор - ncpol
Дата добавления - 18.04.2016 в 19:39
Pelena Дата: Понедельник, 18.04.2016, 19:46 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 9856
Репутация: 2254 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
есть точные вхождения

не всегда. Например, в Базе Caleo GOLD 170-0,5-10,0, а в Прайсе Caleo GOLD 170-0,5-10
Можно привести к единому виду? Тогда формула простая
Код
=ВПР("*"&A2;'Прайс поставщика'!$A$2:$B$152;2;0)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщение
есть точные вхождения

не всегда. Например, в Базе Caleo GOLD 170-0,5-10,0, а в Прайсе Caleo GOLD 170-0,5-10
Можно привести к единому виду? Тогда формула простая
Код
=ВПР("*"&A2;'Прайс поставщика'!$A$2:$B$152;2;0)

Автор - Pelena
Дата добавления - 18.04.2016 в 19:46
ncpol Дата: Понедельник, 18.04.2016, 19:51 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Pelena, спасибо, привести к единому виду можно, естественно!

Поясните, плиз, а что значит оператор - "*"&
 
Ответить
СообщениеPelena, спасибо, привести к единому виду можно, естественно!

Поясните, плиз, а что значит оператор - "*"&

Автор - ncpol
Дата добавления - 18.04.2016 в 19:51
Pelena Дата: Понедельник, 18.04.2016, 19:58 | Сообщение № 4
Группа: Модераторы
Ранг: Экселист
Сообщений: 9856
Репутация: 2254 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
* - это подстановочный знак, заменяет любую последовательность символов
& - сцепление строк
"*"&A2 означает, что перед А2 может стоять любой текст


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщение* - это подстановочный знак, заменяет любую последовательность символов
& - сцепление строк
"*"&A2 означает, что перед А2 может стоять любой текст

Автор - Pelena
Дата добавления - 18.04.2016 в 19:58
ncpol Дата: Понедельник, 18.04.2016, 20:05 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Pelena, спасибо за подробное объяснение thumb

А если данные А2 в середине текста?
 
Ответить
СообщениеPelena, спасибо за подробное объяснение thumb

А если данные А2 в середине текста?

Автор - ncpol
Дата добавления - 18.04.2016 в 20:05
Pelena Дата: Понедельник, 18.04.2016, 20:08 | Сообщение № 6
Группа: Модераторы
Ранг: Экселист
Сообщений: 9856
Репутация: 2254 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
Ну, прицепите ещё одну звёздочку после А2 ;)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеНу, прицепите ещё одну звёздочку после А2 ;)

Автор - Pelena
Дата добавления - 18.04.2016 в 20:08
ncpol Дата: Понедельник, 18.04.2016, 20:44 | Сообщение № 7
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
спасибо!!! respect
 
Ответить
Сообщениеспасибо!!! respect

Автор - ncpol
Дата добавления - 18.04.2016 в 20:44
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Перенос данных с одного листа на другой. ВПР. (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!