Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Ссылка на книгу исходя из выбранного параметра. - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Ссылка на книгу исходя из выбранного параметра. (Формулы/Formulas)
Ссылка на книгу исходя из выбранного параметра.
GaLaXoN Дата: Вторник, 19.04.2016, 16:04 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 101
Репутация: 1 ±
Замечаний: 0% ±

Excel 2010
Всем доброго времени суток!

Суть вопроса такова - можно ли каким-то образом заменить в формуле:
Код
=[Книга1.xlsx]Лист1!$A$1:$C$10

значение "Книга1" и (или) "Лист1", на значение из ячейки листа?
как это сделать функцией
Код
=ДВССЫЛ(....
я знаю, а есть ли какой-нибудь более простой способ?
желательно чтоб прямая ссылка была.

Скидываю пример главной книги.
К сообщению приложен файл: 333333.xlsx(10Kb)


Сообщение отредактировал GaLaXoN - Вторник, 19.04.2016, 16:04
 
Ответить
СообщениеВсем доброго времени суток!

Суть вопроса такова - можно ли каким-то образом заменить в формуле:
Код
=[Книга1.xlsx]Лист1!$A$1:$C$10

значение "Книга1" и (или) "Лист1", на значение из ячейки листа?
как это сделать функцией
Код
=ДВССЫЛ(....
я знаю, а есть ли какой-нибудь более простой способ?
желательно чтоб прямая ссылка была.

Скидываю пример главной книги.

Автор - GaLaXoN
Дата добавления - 19.04.2016 в 16:04
GaLaXoN Дата: Четверг, 05.05.2016, 16:30 | Сообщение № 2
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 101
Репутация: 1 ±
Замечаний: 0% ±

Excel 2010
Проблема до сих пор актуальная!.....
не могу найти решения......
 
Ответить
СообщениеПроблема до сих пор актуальная!.....
не могу найти решения......

Автор - GaLaXoN
Дата добавления - 05.05.2016 в 16:30
buchlotnik Дата: Четверг, 05.05.2016, 16:35 | Сообщение № 3
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3004
Репутация: 839 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
GaLaXoN, чем вас не устраивает ДВССЫЛ?


каждому For - Next!
платная помощь:
ЯД: 410012595572239
buchlotnik@mail.ru
 
Ответить
СообщениеGaLaXoN, чем вас не устраивает ДВССЫЛ?

Автор - buchlotnik
Дата добавления - 05.05.2016 в 16:35
GaLaXoN Дата: Четверг, 05.05.2016, 16:37 | Сообщение № 4
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 101
Репутация: 1 ±
Замечаний: 0% ±

Excel 2010
buchlotnik, просто приходится открывать книгу, для вывода значений.
хочется упростить это все, ну и на будущее уметь применить.


Сообщение отредактировал GaLaXoN - Четверг, 05.05.2016, 16:37
 
Ответить
Сообщениеbuchlotnik, просто приходится открывать книгу, для вывода значений.
хочется упростить это все, ну и на будущее уметь применить.

Автор - GaLaXoN
Дата добавления - 05.05.2016 в 16:37
GaLaXoN Дата: Четверг, 05.05.2016, 16:52 | Сообщение № 5
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 101
Репутация: 1 ±
Замечаний: 0% ±

Excel 2010
buchlotnik,

Вот так я умею:
Код
=ВПР(СЦЕПИТЬ("Данныетрра_";$I$12;$I$13;$I$14;$I$15;$I$16;$I$17;$I$18);ДВССЫЛ("'[3_Трансформатор.xlsx]"&$I$13&"'!"&"$A:$AC");21;)


но хочется избавиться от ДВССЫЛ.
Чтобы ссылка была напрямую.
 
Ответить
Сообщениеbuchlotnik,

Вот так я умею:
Код
=ВПР(СЦЕПИТЬ("Данныетрра_";$I$12;$I$13;$I$14;$I$15;$I$16;$I$17;$I$18);ДВССЫЛ("'[3_Трансформатор.xlsx]"&$I$13&"'!"&"$A:$AC");21;)


но хочется избавиться от ДВССЫЛ.
Чтобы ссылка была напрямую.

Автор - GaLaXoN
Дата добавления - 05.05.2016 в 16:52
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Ссылка на книгу исходя из выбранного параметра. (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!