Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/перенос значений из одной страницы в другую - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » перенос значений из одной страницы в другую (Формулы/Formulas)
перенос значений из одной страницы в другую
alexzg Дата: Среда, 20.04.2016, 17:43 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Дорогие друзья, помогайте "Старому".
Есть таблица с двумя листами. Первый лист База Данных, в которую каждый месяц заносятся определенные показания.
Второй лист некая таблица, в которую при помощи ВПР подставляются данные из первого листа, причем на первом листе в горизонтальной строке достаточно проставить определенный символ, в данном случае "Х".
Если есть возможность оказать помощь, буду признателен.
К сообщению приложен файл: 1135052.xlsx(10Kb)
 
Ответить
СообщениеДорогие друзья, помогайте "Старому".
Есть таблица с двумя листами. Первый лист База Данных, в которую каждый месяц заносятся определенные показания.
Второй лист некая таблица, в которую при помощи ВПР подставляются данные из первого листа, причем на первом листе в горизонтальной строке достаточно проставить определенный символ, в данном случае "Х".
Если есть возможность оказать помощь, буду признателен.

Автор - alexzg
Дата добавления - 20.04.2016 в 17:43
pabchek Дата: Среда, 20.04.2016, 17:53 | Сообщение № 2
Группа: Проверенные
Ранг: Ветеран
Сообщений: 646
Репутация: 146 ±
Замечаний: 0% ±

Excel 2007
Здравствуйте. Вариант (формула массива)
Код
=ИНДЕКС(БазаДанных!$C$3:$M$10;СТРОКА(A1);ПОИСКПОЗ(1;--(БазаДанных!C$1:M$1<>0);0))

Код
=ИНДЕКС(БазаДанных!$C$3:$M$10;СТРОКА(A1);ПОИСКПОЗ(1;--ЕОШ(1-БазаДанных!$C$1:$M$1);0))

если знак определен, то можно
Код
=ГПР("х";БазаДанных!$C$1:$M$10;СТРОКА(A3))


"Учиться, учиться и еще раз учиться!"
WM: R399923528092


Сообщение отредактировал pabchek - Среда, 20.04.2016, 18:01
 
Ответить
СообщениеЗдравствуйте. Вариант (формула массива)
Код
=ИНДЕКС(БазаДанных!$C$3:$M$10;СТРОКА(A1);ПОИСКПОЗ(1;--(БазаДанных!C$1:M$1<>0);0))

Код
=ИНДЕКС(БазаДанных!$C$3:$M$10;СТРОКА(A1);ПОИСКПОЗ(1;--ЕОШ(1-БазаДанных!$C$1:$M$1);0))

если знак определен, то можно
Код
=ГПР("х";БазаДанных!$C$1:$M$10;СТРОКА(A3))

Автор - pabchek
Дата добавления - 20.04.2016 в 17:53
buchlotnik Дата: Среда, 20.04.2016, 17:53 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 2049
Репутация: 613 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
так нужно? (массивка сразу на столбец)
Код
=ИНДЕКС(БазаДанных!C3:M10;;ПОИСКПОЗ("х";БазаДанных!C1:M1;0))
(нули форматом убрал)
К сообщению приложен файл: 2402284.xlsx(10Kb)


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru


Сообщение отредактировал buchlotnik - Среда, 20.04.2016, 17:54
 
Ответить
Сообщениетак нужно? (массивка сразу на столбец)
Код
=ИНДЕКС(БазаДанных!C3:M10;;ПОИСКПОЗ("х";БазаДанных!C1:M1;0))
(нули форматом убрал)

Автор - buchlotnik
Дата добавления - 20.04.2016 в 17:53
Manyasha Дата: Среда, 20.04.2016, 17:55 | Сообщение № 4
Группа: Модераторы
Ранг: Старожил
Сообщений: 1590
Репутация: 669 ±
Замечаний: 0% ±

Excel 2007, 2010
и еще вариант:
Код
=ВПР(B4;БазаДанных!$B$2:$M$100;ПОИСКПОЗ("х";БазаДанных!$B$1:$M$1;0);0)


marinamorozova_box@mail.ru
ЯД: 410013299366744 WM: R193491431804
 
Ответить
Сообщениеи еще вариант:
Код
=ВПР(B4;БазаДанных!$B$2:$M$100;ПОИСКПОЗ("х";БазаДанных!$B$1:$M$1;0);0)

Автор - Manyasha
Дата добавления - 20.04.2016 в 17:55
_Boroda_ Дата: Среда, 20.04.2016, 18:02 | Сообщение № 5
Группа: Модераторы
Ранг: Экселист
Сообщений: 9377
Репутация: 3950 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
И еще (почти как у Михаила, только немассивка и без ;)
Код
=ИНДЕКС(БазаДанных!C3:M3;ПОИСКПОЗ("х";БазаДанных!C$1:M$1;))

Если только числовые значения, то вот такой еще варианты
Код
=СУММПРОИЗВ(БазаДанных!D3:M3*(БазаДанных!D$1:M$1="х"))

Код
=СУММЕСЛИ(БазаДанных!D$1:M$1;"х";БазаДанных!D3:M3)

Добавлено на мотивы формулы Виктора из поста ниже
Код
=ПРОСМОТР(;-ПОИСК(;БазаДанных!C$1:M$1);БазаДанных!C3:M3)
К сообщению приложен файл: 1135052_2.xlsx(10Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995


Сообщение отредактировал _Boroda_ - Среда, 20.04.2016, 18:13
 
Ответить
СообщениеИ еще (почти как у Михаила, только немассивка и без ;)
Код
=ИНДЕКС(БазаДанных!C3:M3;ПОИСКПОЗ("х";БазаДанных!C$1:M$1;))

Если только числовые значения, то вот такой еще варианты
Код
=СУММПРОИЗВ(БазаДанных!D3:M3*(БазаДанных!D$1:M$1="х"))

Код
=СУММЕСЛИ(БазаДанных!D$1:M$1;"х";БазаДанных!D3:M3)

Добавлено на мотивы формулы Виктора из поста ниже
Код
=ПРОСМОТР(;-ПОИСК(;БазаДанных!C$1:M$1);БазаДанных!C3:M3)

Автор - _Boroda_
Дата добавления - 20.04.2016 в 18:02
pabchek Дата: Среда, 20.04.2016, 18:06 | Сообщение № 6
Группа: Проверенные
Ранг: Ветеран
Сообщений: 646
Репутация: 146 ±
Замечаний: 0% ±

Excel 2007
Вот еще, тоже не массивка
Код
=ПРОСМОТР(1;1/ЕОШ(1-БазаДанных!$C$1:$M$1);БазаДанных!C3:M3)

и снова не привязана к обязательному знаку "х"
и еще (если маркер текстовый)
Код
=ПРОСМОТР(1;1/ЕТЕКСТ(БазаДанных!C$1:M$1);БазаДанных!C3:M3)


"Учиться, учиться и еще раз учиться!"
WM: R399923528092


Сообщение отредактировал pabchek - Среда, 20.04.2016, 18:21
 
Ответить
СообщениеВот еще, тоже не массивка
Код
=ПРОСМОТР(1;1/ЕОШ(1-БазаДанных!$C$1:$M$1);БазаДанных!C3:M3)

и снова не привязана к обязательному знаку "х"
и еще (если маркер текстовый)
Код
=ПРОСМОТР(1;1/ЕТЕКСТ(БазаДанных!C$1:M$1);БазаДанных!C3:M3)

Автор - pabchek
Дата добавления - 20.04.2016 в 18:06
alexzg Дата: Среда, 20.04.2016, 18:34 | Сообщение № 7
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Большое спасибо, дорогие друзья, дайте дальше своей головой додумать, а то не красиво получится.
 
Ответить
СообщениеБольшое спасибо, дорогие друзья, дайте дальше своей головой додумать, а то не красиво получится.

Автор - alexzg
Дата добавления - 20.04.2016 в 18:34
Мир MS Excel » Вопросы и решения » Вопросы по Excel » перенос значений из одной страницы в другую (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!