Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Процент исполнения прогноза, если в условии присутствует 0. - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Процент исполнения прогноза, если в условии присутствует 0. (Формулы/Formulas)
Процент исполнения прогноза, если в условии присутствует 0.
olegus Дата: Четверг, 21.04.2016, 11:32 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 45
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Добрый день форумчане!
Полазил по форуму но решения не нашел.
Помогите пожалуйста.
Хотелось бы чтобы в ячейке D4 стояло 100%.
К сообщению приложен файл: 6266057.xlsx(10Kb)
 
Ответить
СообщениеДобрый день форумчане!
Полазил по форуму но решения не нашел.
Помогите пожалуйста.
Хотелось бы чтобы в ячейке D4 стояло 100%.

Автор - olegus
Дата добавления - 21.04.2016 в 11:32
_Boroda_ Дата: Четверг, 21.04.2016, 11:45 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 9377
Репутация: 3950 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Код
=ЕСЛИОШИБКА(C2/B2;)

Код
=ЕСЛИ(B2;C2/B2;)
К сообщению приложен файл: 6266057_1.xlsx(10Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение
Код
=ЕСЛИОШИБКА(C2/B2;)

Код
=ЕСЛИ(B2;C2/B2;)

Автор - _Boroda_
Дата добавления - 21.04.2016 в 11:45
olegus Дата: Четверг, 21.04.2016, 12:33 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 45
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
спасибо boroda, но не подойдет. Данные динамичны и меняются каждый месяц через ссылки на ячейки из других книг.
 
Ответить
Сообщениеспасибо boroda, но не подойдет. Данные динамичны и меняются каждый месяц через ссылки на ячейки из других книг.

Автор - olegus
Дата добавления - 21.04.2016 в 12:33
olegus Дата: Четверг, 21.04.2016, 12:40 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 45
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Извиняюсь boroda, разобрался.
 
Ответить
СообщениеИзвиняюсь boroda, разобрался.

Автор - olegus
Дата добавления - 21.04.2016 в 12:40
olegus Дата: Четверг, 21.04.2016, 12:52 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 45
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
а возможно ли плюсом сделать так, чтобы при прогнозе = 0, а факте = 30, выдавало 0?
 
Ответить
Сообщениеа возможно ли плюсом сделать так, чтобы при прогнозе = 0, а факте = 30, выдавало 0?

Автор - olegus
Дата добавления - 21.04.2016 в 12:52
_Boroda_ Дата: Четверг, 21.04.2016, 12:59 | Сообщение № 6
Группа: Модераторы
Ранг: Экселист
Сообщений: 9377
Репутация: 3950 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так хотите? Если хоть где-то ноль, то ноль, иначе - процент
Код
=ЕСЛИ(B2*C2;C2/B2;)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак хотите? Если хоть где-то ноль, то ноль, иначе - процент
Код
=ЕСЛИ(B2*C2;C2/B2;)

Автор - _Boroda_
Дата добавления - 21.04.2016 в 12:59
olegus Дата: Четверг, 21.04.2016, 13:06 | Сообщение № 7
Группа: Пользователи
Ранг: Новичок
Сообщений: 45
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
не совсем. хотелось, чтобы первое условие (где прогноз и факт = 0, а исполнение 100%) тоже выполнялось.
 
Ответить
Сообщениене совсем. хотелось, чтобы первое условие (где прогноз и факт = 0, а исполнение 100%) тоже выполнялось.

Автор - olegus
Дата добавления - 21.04.2016 в 13:06
Manyasha Дата: Четверг, 21.04.2016, 13:14 | Сообщение № 8
Группа: Модераторы
Ранг: Старожил
Сообщений: 1590
Репутация: 669 ±
Замечаний: 0% ±

Excel 2007, 2010
olegus, может так?
Код
=ЕСЛИОШИБКА(C2/B2;(B2=0)*(C2=0))


marinamorozova_box@mail.ru
ЯД: 410013299366744 WM: R193491431804
 
Ответить
Сообщениеolegus, может так?
Код
=ЕСЛИОШИБКА(C2/B2;(B2=0)*(C2=0))

Автор - Manyasha
Дата добавления - 21.04.2016 в 13:14
_Boroda_ Дата: Четверг, 21.04.2016, 13:16 | Сообщение № 9
Группа: Модераторы
Ранг: Экселист
Сообщений: 9377
Репутация: 3950 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так?
Код
=ВЫБОР(СЧЁТЕСЛИ(B2:C2;)+1;C2/B2;;1)


Марина, точно!
А я сегодня не тормоз, я медленный газ.
К сообщению приложен файл: 6266057_2.xlsx(11Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995


Сообщение отредактировал _Boroda_ - Четверг, 21.04.2016, 13:19
 
Ответить
СообщениеТак?
Код
=ВЫБОР(СЧЁТЕСЛИ(B2:C2;)+1;C2/B2;;1)


Марина, точно!
А я сегодня не тормоз, я медленный газ.

Автор - _Boroda_
Дата добавления - 21.04.2016 в 13:16
olegus Дата: Четверг, 21.04.2016, 14:08 | Сообщение № 10
Группа: Пользователи
Ранг: Новичок
Сообщений: 45
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Спасибо boroda и manyasha! то, что нужно.
 
Ответить
СообщениеСпасибо boroda и manyasha! то, что нужно.

Автор - olegus
Дата добавления - 21.04.2016 в 14:08
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Процент исполнения прогноза, если в условии присутствует 0. (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!