Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Преобразовать одну таблицу в другую, см. описание темы - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Преобразовать одну таблицу в другую, см. описание темы (Формулы/Formulas)
Преобразовать одну таблицу в другую, см. описание темы
andrewklips Дата: Четверг, 21.04.2016, 19:59 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Здравствуйте!
Интересует возможность сделать из файла 1 файл 2:
а) сцепить столбцы B и С
б) сцепить столбцы D и E, объединив их в одну строку

Проблема: в файле 1 даны не прямые ссылки на фото, а на страницу сайта с товаром. Можно ли каким-то образом вытащить "прямую" ссылку, как это сделано в файле 2 ?

P.S. если такая возможность есть, но сделать это не очень легко - озвучьте цену )
К сообщению приложен файл: 3064652.xls(50Kb) · 5502036.xls(26Kb)


Сообщение отредактировал andrewklips - Четверг, 21.04.2016, 20:00
 
Ответить
СообщениеЗдравствуйте!
Интересует возможность сделать из файла 1 файл 2:
а) сцепить столбцы B и С
б) сцепить столбцы D и E, объединив их в одну строку

Проблема: в файле 1 даны не прямые ссылки на фото, а на страницу сайта с товаром. Можно ли каким-то образом вытащить "прямую" ссылку, как это сделано в файле 2 ?

P.S. если такая возможность есть, но сделать это не очень легко - озвучьте цену )

Автор - andrewklips
Дата добавления - 21.04.2016 в 19:59
китин Дата: Пятница, 22.04.2016, 08:13 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4099
Репутация: 632 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
по а) и б)(использовал UDF СцепитЕсли от The_Prist ОТСЮДА. Формула массива моя
Код
=ЕСЛИОШИБКА(ИНДЕКС($B$2:$B$63&" "&$C$2:$C$63;НАИМЕНЬШИЙ(ЕСЛИ(ПОИСКПОЗ($B$2:$B$63&$C$2:$C$63;$B$2:$B$63&$C$2:$C$63;0)=СТРОКА($B$2:$B$63)-1;СТРОКА($B$2:$B$63)-1);СТРОКА(A1)));"")

про прямую ссылку поподробнее плз %)
К сообщению приложен файл: 64652.xlsm(26Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538


Сообщение отредактировал китин - Пятница, 22.04.2016, 08:14
 
Ответить
Сообщениепо а) и б)(использовал UDF СцепитЕсли от The_Prist ОТСЮДА. Формула массива моя
Код
=ЕСЛИОШИБКА(ИНДЕКС($B$2:$B$63&" "&$C$2:$C$63;НАИМЕНЬШИЙ(ЕСЛИ(ПОИСКПОЗ($B$2:$B$63&$C$2:$C$63;$B$2:$B$63&$C$2:$C$63;0)=СТРОКА($B$2:$B$63)-1;СТРОКА($B$2:$B$63)-1);СТРОКА(A1)));"")

про прямую ссылку поподробнее плз %)

Автор - китин
Дата добавления - 22.04.2016 в 08:13
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Преобразовать одну таблицу в другую, см. описание темы (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!