Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Ячейка ссылается на недопустимое значение - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Ячейка ссылается на недопустимое значение (Формулы/Formulas)
Ячейка ссылается на недопустимое значение
Anatoly88 Дата: Суббота, 30.04.2016, 21:04 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 39
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
В одной книги есть несколько листов: Площадь основания, Объем, Данные.

На листе Площадь основания находится справочная таблица где исходя из длины и ширины определяется площадь основания.

На листе Объем находится справочная таблица где исходя из высоты и площади основания определяется объем.

На листе Данные находится таблица. Вручную вводятся ДЛИНА, ШИРИНА, ВЫСОТА а в ячейках ПЛОЩАДЬ ОСНОВАНИЯ И ОБЪЕМ должны автоматически появится определенные значения.

Для ячейки ПЛОЩАДЬ ОСНОВАНИЯ я написал формулу и она работает:
Код
=ИНДЕКС('Площадь основания'!B5:BZ131;(ПОИСКПОЗ(Данные!A3;'Площадь основания'!B4:BZ4;1));(ПОИСКПОЗ(Данные!B3;'Площадь основания'!A5:A131;1)))


Для ячейки Объем попробовал написать похожую формулу:
Код
=ИНДЕКС(Объем!B5:CX335;(ПОИСКПОЗ(Данные!C3;Объем!B4:CX4;1));(ПОИСКПОЗ(Данные!D3;Объем!A5:A335;1)))


Но вместо значения в этой ячейке появляется ОШИБКА #CCЫЛКА!

Может у кого нибудь есть мысли где я допустил ошибку или просто невнимательность. Спасибо.

Файл слишком большой и не копируется. Уменьшаю таблицу и меняю значения в таблицах чтобы прислать сюда и ошибка пропадает.
 
Ответить
СообщениеВ одной книги есть несколько листов: Площадь основания, Объем, Данные.

На листе Площадь основания находится справочная таблица где исходя из длины и ширины определяется площадь основания.

На листе Объем находится справочная таблица где исходя из высоты и площади основания определяется объем.

На листе Данные находится таблица. Вручную вводятся ДЛИНА, ШИРИНА, ВЫСОТА а в ячейках ПЛОЩАДЬ ОСНОВАНИЯ И ОБЪЕМ должны автоматически появится определенные значения.

Для ячейки ПЛОЩАДЬ ОСНОВАНИЯ я написал формулу и она работает:
Код
=ИНДЕКС('Площадь основания'!B5:BZ131;(ПОИСКПОЗ(Данные!A3;'Площадь основания'!B4:BZ4;1));(ПОИСКПОЗ(Данные!B3;'Площадь основания'!A5:A131;1)))


Для ячейки Объем попробовал написать похожую формулу:
Код
=ИНДЕКС(Объем!B5:CX335;(ПОИСКПОЗ(Данные!C3;Объем!B4:CX4;1));(ПОИСКПОЗ(Данные!D3;Объем!A5:A335;1)))


Но вместо значения в этой ячейке появляется ОШИБКА #CCЫЛКА!

Может у кого нибудь есть мысли где я допустил ошибку или просто невнимательность. Спасибо.

Файл слишком большой и не копируется. Уменьшаю таблицу и меняю значения в таблицах чтобы прислать сюда и ошибка пропадает.

Автор - Anatoly88
Дата добавления - 30.04.2016 в 21:04
buchlotnik Дата: Суббота, 30.04.2016, 21:08 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 2209
Репутация: 659 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
у ИНДЕКС так:
Код
=ИНДЕКС(массив;СТРОКА;столбец)
а у вас наоборот столбец-строка вот она и ругается - нету в массиве 131 столбца B)


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru


Сообщение отредактировал buchlotnik - Суббота, 30.04.2016, 21:09
 
Ответить
Сообщениеу ИНДЕКС так:
Код
=ИНДЕКС(массив;СТРОКА;столбец)
а у вас наоборот столбец-строка вот она и ругается - нету в массиве 131 столбца B)

Автор - buchlotnik
Дата добавления - 30.04.2016 в 21:08
Anatoly88 Дата: Суббота, 30.04.2016, 21:52 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 39
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Спасибо ДОБРЫЙ ЧЕЛОВЕК - все получилось.
 
Ответить
СообщениеСпасибо ДОБРЫЙ ЧЕЛОВЕК - все получилось.

Автор - Anatoly88
Дата добавления - 30.04.2016 в 21:52
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Ячейка ссылается на недопустимое значение (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!