Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Сумма строки без скрытых столбцов - Страница 2 - Мир MS Excel

Старая форма входа
  • Страница 2 из 2
  • «
  • 1
  • 2
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сумма строки без скрытых столбцов
Сумма строки без скрытых столбцов
Serge_007 Дата: Четверг, 01.08.2013, 10:58 | Сообщение № 21
Группа: Админы
Ранг: Местный житель
Сообщений: 15647
Репутация: 2575 ±
Замечаний: ±

Excel 2016
выдает ошибки
Какие?!
К сообщению приложен файл: user0_CV.xls(36.5 Kb)


ЮMoney:41001419691823 | WMR:126292472390
 
Ответить
Сообщение
выдает ошибки
Какие?!

Автор - Serge_007
Дата добавления - 01.08.2013 в 10:58
user0 Дата: Четверг, 01.08.2013, 13:39 | Сообщение № 22
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 152
Репутация: 8 ±
Замечаний: 0% ±

Excel 2013, 2016
Какие?!
упс.. это я ошибся при переводе формулы в англоязычный вариант.

Формула работает, но я так понял, она считает кол-во видимых столбцов, вместо кол-ва встречающихся значений c1, c2 - c10 на видимых столбцах. Мне бы второе посчитать )
 
Ответить
Сообщение
Какие?!
упс.. это я ошибся при переводе формулы в англоязычный вариант.

Формула работает, но я так понял, она считает кол-во видимых столбцов, вместо кол-ва встречающихся значений c1, c2 - c10 на видимых столбцах. Мне бы второе посчитать )

Автор - user0
Дата добавления - 01.08.2013 в 13:39
Serge_007 Дата: Четверг, 01.08.2013, 14:00 | Сообщение № 23
Группа: Админы
Ранг: Местный житель
Сообщений: 15647
Репутация: 2575 ±
Замечаний: ±

Excel 2016
Код
=СУММПРОИЗВ(ЗНАК(ЯЧЕЙКА("width";СМЕЩ(A1;;Ч(ИНДЕКС(СТОЛБЕЦ(A:J);)))))*(A2:J2<>""))
Код
=SUMPRODUCT(SIGN(CELL("width",OFFSET(A1,,N(INDEX(COLUMN(A:J),)))))*(A2:J2<>""))


ЮMoney:41001419691823 | WMR:126292472390
 
Ответить
Сообщение
Код
=СУММПРОИЗВ(ЗНАК(ЯЧЕЙКА("width";СМЕЩ(A1;;Ч(ИНДЕКС(СТОЛБЕЦ(A:J);)))))*(A2:J2<>""))
Код
=SUMPRODUCT(SIGN(CELL("width",OFFSET(A1,,N(INDEX(COLUMN(A:J),)))))*(A2:J2<>""))

Автор - Serge_007
Дата добавления - 01.08.2013 в 14:00
Александр Дата: Пятница, 11.04.2014, 09:27 | Сообщение № 24
Группа: Гости
=СУММПРОИЗВ(ЗНАК(ЯЧЕЙКА("width";СМЕЩ(A1;;Ч(ИНДЕКС(СТОЛБЕЦ(A:J);))))))
Вот это идеально подходит, только вместо А-J подставляй свои столбцы - и все!!! Большое спасибо.
 
Ответить
Сообщение=СУММПРОИЗВ(ЗНАК(ЯЧЕЙКА("width";СМЕЩ(A1;;Ч(ИНДЕКС(СТОЛБЕЦ(A:J);))))))
Вот это идеально подходит, только вместо А-J подставляй свои столбцы - и все!!! Большое спасибо.

Автор - Александр
Дата добавления - 11.04.2014 в 09:27
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сумма строки без скрытых столбцов
  • Страница 2 из 2
  • «
  • 1
  • 2
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2023 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!