Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Суммировать по трем критериям из двух разных ячеек - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Суммировать по трем критериям из двух разных ячеек (Формулы/Formulas)
Суммировать по трем критериям из двух разных ячеек
mileonn Дата: Понедельник, 02.05.2016, 16:09 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 33
Репутация: 0 ±
Замечаний: 0% ±

Добрый день! Всех с праздниками! Подскажите пожалуйста решение для такой задачи. Дан ряд уникальный значений, в моем примере - это название фруктов. В других колонках цены и условия для них. Если стоит "1" в колонке "условие 1", то выбирается сумма из колонки "первая цена", а если стоит "V" в колонке "условие 2", то выбирается сумма из колонки "договорная цена". Надо собрать сумму по уникальным значениям в зависимости от условий 1 и 2. Помогите пожалуйста, никак не можем придумать как решить! Если условие выбирается из одного столбца, тогда у меня получается, а из двух разных никак. Файл прикладываю. Спасибо.
К сообщению приложен файл: 1794597.xls(26Kb)
 
Ответить
СообщениеДобрый день! Всех с праздниками! Подскажите пожалуйста решение для такой задачи. Дан ряд уникальный значений, в моем примере - это название фруктов. В других колонках цены и условия для них. Если стоит "1" в колонке "условие 1", то выбирается сумма из колонки "первая цена", а если стоит "V" в колонке "условие 2", то выбирается сумма из колонки "договорная цена". Надо собрать сумму по уникальным значениям в зависимости от условий 1 и 2. Помогите пожалуйста, никак не можем придумать как решить! Если условие выбирается из одного столбца, тогда у меня получается, а из двух разных никак. Файл прикладываю. Спасибо.

Автор - mileonn
Дата добавления - 02.05.2016 в 16:09
buchlotnik Дата: Понедельник, 02.05.2016, 17:05 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 2049
Репутация: 613 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
наверняка можно элегантнее, пока так:
Код
=СУММПРОИЗВ(($A$2:$A$7=A11)*$D$2:$D$7*($E$2:$E$7="V"))+СУММПРОИЗВ(($A$2:$A$7=A11)*$C$2:$C$7*$B$2:$B$7*($E$2:$E$7=""))
К сообщению приложен файл: 6905195.xls(26Kb)


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru
 
Ответить
Сообщениенаверняка можно элегантнее, пока так:
Код
=СУММПРОИЗВ(($A$2:$A$7=A11)*$D$2:$D$7*($E$2:$E$7="V"))+СУММПРОИЗВ(($A$2:$A$7=A11)*$C$2:$C$7*$B$2:$B$7*($E$2:$E$7=""))

Автор - buchlotnik
Дата добавления - 02.05.2016 в 17:05
Manyasha Дата: Понедельник, 02.05.2016, 17:39 | Сообщение № 3
Группа: Модераторы
Ранг: Старожил
Сообщений: 1590
Репутация: 669 ±
Замечаний: 0% ±

Excel 2007, 2010
У меня вот так придумалось, правда массивная (вводить через ctrl+shift+enter)
Код
=СУММПРОИЗВ(($A$2:$A$7=A11)*ВЫБОР(($E$2:$E$7="V")+1;$B$2:$B$7;$D$2:$D$7))


marinamorozova_box@mail.ru
ЯД: 410013299366744 WM: R193491431804
 
Ответить
СообщениеУ меня вот так придумалось, правда массивная (вводить через ctrl+shift+enter)
Код
=СУММПРОИЗВ(($A$2:$A$7=A11)*ВЫБОР(($E$2:$E$7="V")+1;$B$2:$B$7;$D$2:$D$7))

Автор - Manyasha
Дата добавления - 02.05.2016 в 17:39
Pelena Дата: Понедельник, 02.05.2016, 18:22 | Сообщение № 4
Группа: Модераторы
Ранг: Экселист
Сообщений: 9889
Репутация: 2269 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
Ещё вариант
Код
=СУММПРОИЗВ(($B$2:$B$7*$C$2:$C$7+$D$2:$D$7*($E$2:$E$7="V"))*($A$2:$A$7=A11))

[p.s.]Почему бы эти два условия не записать в один столбец, если они взаимоисключающие? Тогда СУММЕСЛИМН() можно использовать[/p.s.]


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЕщё вариант
Код
=СУММПРОИЗВ(($B$2:$B$7*$C$2:$C$7+$D$2:$D$7*($E$2:$E$7="V"))*($A$2:$A$7=A11))

[p.s.]Почему бы эти два условия не записать в один столбец, если они взаимоисключающие? Тогда СУММЕСЛИМН() можно использовать[/p.s.]

Автор - Pelena
Дата добавления - 02.05.2016 в 18:22
mileonn Дата: Понедельник, 02.05.2016, 18:54 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 33
Репутация: 0 ±
Замечаний: 0% ±

Pelena, спасибо.
P.S.
Почему бы эти два условия не записать в один столбец, если они взаимоисключающие? Тогда СУММЕСЛИМН() можно использовать

С удовольствием, бы использовала эту функцию. Да я так и сделала, если честно. Но по условию этой задачи, будь она неладна, столбцов с условиями должно быть два. А первоначально я так и слила два условия в один столбец. Не понравилось, якобы не понятно тем кто использует файл, что надо сделать ((((.
 
Ответить
СообщениеPelena, спасибо.
P.S.
Почему бы эти два условия не записать в один столбец, если они взаимоисключающие? Тогда СУММЕСЛИМН() можно использовать

С удовольствием, бы использовала эту функцию. Да я так и сделала, если честно. Но по условию этой задачи, будь она неладна, столбцов с условиями должно быть два. А первоначально я так и слила два условия в один столбец. Не понравилось, якобы не понятно тем кто использует файл, что надо сделать ((((.

Автор - mileonn
Дата добавления - 02.05.2016 в 18:54
mileonn Дата: Понедельник, 02.05.2016, 18:55 | Сообщение № 6
Группа: Пользователи
Ранг: Новичок
Сообщений: 33
Репутация: 0 ±
Замечаний: 0% ±

buchlotnik, Manyasha, спасибо Вам большое сейчас попробую вставить в свой файл.
 
Ответить
Сообщениеbuchlotnik, Manyasha, спасибо Вам большое сейчас попробую вставить в свой файл.

Автор - mileonn
Дата добавления - 02.05.2016 в 18:55
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Суммировать по трем критериям из двух разных ячеек (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!