Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Суммировать по 2-м критериям. - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Суммировать по 2-м критериям. (Формулы/Formulas)
Суммировать по 2-м критериям.
Gorgaz Дата: Среда, 04.05.2016, 10:05 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Добрый день! Требуется помощь!

В примере данные.

Нужна формула, которая посчитает всю сумму по статье при условии, что платеж был по банку, типа: если статья совпадает и в столбе "Банк/касса" стоит банк, то плюсуем, если нет, то нет.

Заранее спасибо!
К сообщению приложен файл: 1273958.xlsx(10Kb)
 
Ответить
СообщениеДобрый день! Требуется помощь!

В примере данные.

Нужна формула, которая посчитает всю сумму по статье при условии, что платеж был по банку, типа: если статья совпадает и в столбе "Банк/касса" стоит банк, то плюсуем, если нет, то нет.

Заранее спасибо!

Автор - Gorgaz
Дата добавления - 04.05.2016 в 10:05
_Boroda_ Дата: Среда, 04.05.2016, 10:06 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 9375
Репутация: 3948 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Код
=СУММЕСЛИМН(D$6:D$11;B$6:B$11;"банк";C$6:C$11;F6)

еще
Код
=СУММПРОИЗВ(D$6:D$11*(B$6:B$11="банк")*(C$6:C$11=F6))

Вместо слова "банк" можно использовать ссылку на F$3
Код
=СУММЕСЛИМН(D$6:D$11;B$6:B$11;F$3;C$6:C$11;F6)

[p.s.]СУММЕСЛИМН быстрее СУММПРОИЗВ[/p.s.]
К сообщению приложен файл: 0279814_1.xlsx(10Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Код
=СУММЕСЛИМН(D$6:D$11;B$6:B$11;"банк";C$6:C$11;F6)

еще
Код
=СУММПРОИЗВ(D$6:D$11*(B$6:B$11="банк")*(C$6:C$11=F6))

Вместо слова "банк" можно использовать ссылку на F$3
Код
=СУММЕСЛИМН(D$6:D$11;B$6:B$11;F$3;C$6:C$11;F6)

[p.s.]СУММЕСЛИМН быстрее СУММПРОИЗВ[/p.s.]

Автор - _Boroda_
Дата добавления - 04.05.2016 в 10:06
китин Дата: Среда, 04.05.2016, 10:06 | Сообщение № 3
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3450
Репутация: 549 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
и вам не хворать ! так надо?
Код
=СУММПРОИЗВ($D$6:$D$11*($C$6:$C$11=$F6)*($B$6:$B$11=$F$3))
К сообщению приложен файл: Gorgaz.xls(26Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениеи вам не хворать ! так надо?
Код
=СУММПРОИЗВ($D$6:$D$11*($C$6:$C$11=$F6)*($B$6:$B$11=$F$3))

Автор - китин
Дата добавления - 04.05.2016 в 10:06
Pelena Дата: Среда, 04.05.2016, 10:07 | Сообщение № 4
Группа: Модераторы
Ранг: Экселист
Сообщений: 9873
Репутация: 2263 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
Код
=СУММЕСЛИМН($D$6:$D$11;$C$6:$C$11;F6;$B$6:$B$11;$F$3)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщение
Код
=СУММЕСЛИМН($D$6:$D$11;$C$6:$C$11;F6;$B$6:$B$11;$F$3)

Автор - Pelena
Дата добавления - 04.05.2016 в 10:07
Gorgaz Дата: Среда, 04.05.2016, 10:09 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Благодарю!
 
Ответить
СообщениеБлагодарю!

Автор - Gorgaz
Дата добавления - 04.05.2016 в 10:09
Gorgaz Дата: Среда, 04.05.2016, 12:15 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
В примере работает, а вот в рабочем файле выдает #ЗНАЧ! :(
 
Ответить
СообщениеВ примере работает, а вот в рабочем файле выдает #ЗНАЧ! :(

Автор - Gorgaz
Дата добавления - 04.05.2016 в 12:15
Gorgaz Дата: Среда, 04.05.2016, 12:22 | Сообщение № 7
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Вот файл, красным отметил на вкладке "РС".
[moder]Max 100кб


Сообщение отредактировал _Boroda_ - Среда, 04.05.2016, 12:27
 
Ответить
СообщениеВот файл, красным отметил на вкладке "РС".
[moder]Max 100кб

Автор - Gorgaz
Дата добавления - 04.05.2016 в 12:22
ArkaIIIa Дата: Среда, 04.05.2016, 12:22 | Сообщение № 8
Группа: Проверенные
Ранг: Ветеран
Сообщений: 858
Репутация: 114 ±
Замечаний: 0% ±

2010
Gorgaz
Диапазоны везде одинаковые поставили?
Вот на этом примере:
Код
=СУММЕСЛИМН($D$6:$D$11;$C$6:$C$11;F6;$B$6:$B$11;$F$3)

Диапазоны в трех частях формулы - с 6 строки по 11 (D6:D11, C6:C11, B6:B11). Так же и в рабочем файле, диапазоны должны быть одинаковые.
 
Ответить
СообщениеGorgaz
Диапазоны везде одинаковые поставили?
Вот на этом примере:
Код
=СУММЕСЛИМН($D$6:$D$11;$C$6:$C$11;F6;$B$6:$B$11;$F$3)

Диапазоны в трех частях формулы - с 6 строки по 11 (D6:D11, C6:C11, B6:B11). Так же и в рабочем файле, диапазоны должны быть одинаковые.

Автор - ArkaIIIa
Дата добавления - 04.05.2016 в 12:22
Gorgaz Дата: Среда, 04.05.2016, 12:27 | Сообщение № 9
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Вот в чем была проблема! Спасибо!
 
Ответить
СообщениеВот в чем была проблема! Спасибо!

Автор - Gorgaz
Дата добавления - 04.05.2016 в 12:27
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Суммировать по 2-м критериям. (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!