Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Функция ЕСЛИ c двумя условиями. Нужен пример - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Функция ЕСЛИ c двумя условиями. Нужен пример (Формулы/Formulas)
Функция ЕСЛИ c двумя условиями. Нужен пример
GP75 Дата: Среда, 04.05.2016, 10:33 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 52
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007
Здравствуйте форумчане. С наступающим Днём Великой Победы.
Можете помочь ещё с одним решением (формулой) из двух условий? Как это можно сделать? - подробнее в файле.
Заранее благодарствую
[moder]Исправляйте название темы - п.2 Правил форума
Что должно быть, если А1>23 и F2<4000. Если F1=2001? Если F2=4001?[/moder]

Дополнительно
1.Название темы подкорректировал, не судите строго2
2. Не соображу как поставить знак больше(меньше) равно Пример подкорректировал.
3. Если если А1>23 и F2<4000 - будет ошибка. (но такого условия не должно быть, так как соответственно А и F тоже будут по формулам считаться и такого условия не должно получиться в принципе, но с этим я справлюсь сам.
К сообщению приложен файл: 3732537.xlsx(11Kb)


Сообщение отредактировал GP75 - Среда, 04.05.2016, 10:53
 
Ответить
СообщениеЗдравствуйте форумчане. С наступающим Днём Великой Победы.
Можете помочь ещё с одним решением (формулой) из двух условий? Как это можно сделать? - подробнее в файле.
Заранее благодарствую
[moder]Исправляйте название темы - п.2 Правил форума
Что должно быть, если А1>23 и F2<4000. Если F1=2001? Если F2=4001?[/moder]

Дополнительно
1.Название темы подкорректировал, не судите строго2
2. Не соображу как поставить знак больше(меньше) равно Пример подкорректировал.
3. Если если А1>23 и F2<4000 - будет ошибка. (но такого условия не должно быть, так как соответственно А и F тоже будут по формулам считаться и такого условия не должно получиться в принципе, но с этим я справлюсь сам.

Автор - GP75
Дата добавления - 04.05.2016 в 10:33
_Boroda_ Дата: Среда, 04.05.2016, 10:53 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 9346
Репутация: 3922 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
На остальные вопросы Вы не ответили. Кстати, еще вопросы - могут ли быть А и F дробными? Что находится в Q:U - числа или текст? Впрочем, как хотите, что я из Вас вытягиваю всё, это мне нужно или Вам? Проверяйте
Код
=ВЫБОР((F1<2001)+(F1<4001)+ЕСЛИ(A1>23;3;(F1<10001)+(F1>=10001));Q1;R1;S1;T1;U1)
САм уже вижу, что неверно. Ща поправлю

Вот
Код
=ВЫБОР(ЕСЛИ(A1>23;5;(F1>2000)+(F1>4000)+(F1>10000)+1);Q$1;R$1;S$1;T$1;U$1)

Или вот
Код
=ВПР(9^9;Q$1:U$1;ЕСЛИ(A1>23;5;(F1>2000)+(F1>4000)+(F1>10000)+1))
К сообщению приложен файл: 3732537_1.xlsx(13Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеНа остальные вопросы Вы не ответили. Кстати, еще вопросы - могут ли быть А и F дробными? Что находится в Q:U - числа или текст? Впрочем, как хотите, что я из Вас вытягиваю всё, это мне нужно или Вам? Проверяйте
Код
=ВЫБОР((F1<2001)+(F1<4001)+ЕСЛИ(A1>23;3;(F1<10001)+(F1>=10001));Q1;R1;S1;T1;U1)
САм уже вижу, что неверно. Ща поправлю

Вот
Код
=ВЫБОР(ЕСЛИ(A1>23;5;(F1>2000)+(F1>4000)+(F1>10000)+1);Q$1;R$1;S$1;T$1;U$1)

Или вот
Код
=ВПР(9^9;Q$1:U$1;ЕСЛИ(A1>23;5;(F1>2000)+(F1>4000)+(F1>10000)+1))

Автор - _Boroda_
Дата добавления - 04.05.2016 в 10:53
GP75 Дата: Среда, 04.05.2016, 10:55 | Сообщение № 3
Группа: Пользователи
Ранг: Участник
Сообщений: 52
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007
Спасибо. Не судите строго за познания мои невеликие.
А и F могут быть дробными. В Q:U числа (там будут свои простенькие формулы)
 
Ответить
СообщениеСпасибо. Не судите строго за познания мои невеликие.
А и F могут быть дробными. В Q:U числа (там будут свои простенькие формулы)

Автор - GP75
Дата добавления - 04.05.2016 в 10:55
GP75 Дата: Среда, 04.05.2016, 11:04 | Сообщение № 4
Группа: Пользователи
Ранг: Участник
Сообщений: 52
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007
Работает!!! Спасибо большущее.!
 
Ответить
СообщениеРаботает!!! Спасибо большущее.!

Автор - GP75
Дата добавления - 04.05.2016 в 11:04
GP75 Дата: Понедельник, 06.06.2016, 22:55 | Сообщение № 5
Группа: Пользователи
Ранг: Участник
Сообщений: 52
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007
Запутался в простом решении по этой функции. Тоже 2 неизвестных (формулы) Что не так делаю?
Заранее спасибо и сорри уважаемым модераторам, что не создал новую тему, чтобы не "замусоривать" форум. В принципе вопрос по теме.
К сообщению приложен файл: primer.xlsx(16Kb)


Сообщение отредактировал GP75 - Понедельник, 06.06.2016, 22:56
 
Ответить
СообщениеЗапутался в простом решении по этой функции. Тоже 2 неизвестных (формулы) Что не так делаю?
Заранее спасибо и сорри уважаемым модераторам, что не создал новую тему, чтобы не "замусоривать" форум. В принципе вопрос по теме.

Автор - GP75
Дата добавления - 06.06.2016 в 22:55
SLAVICK Дата: Понедельник, 06.06.2016, 23:00 | Сообщение № 6
Группа: Модераторы
Ранг: Старожил
Сообщений: 1834
Репутация: 613 ±
Замечаний: 0% ±

2007,2010,2013,2016
Вас ничего не напрягает в формуле для А3?:
Цитата
=ЕСЛИ(A1>0;A3=(A1*B1+C1*D1)/E1;((B1+D1)/2))

может все же так:
Код
=ЕСЛИ(A1>0;(A1*B1+C1*D1)/E1;((B1+D1)/2))


Иногда все проще чем кажется с первого взгляда.
 
Ответить
СообщениеВас ничего не напрягает в формуле для А3?:
Цитата
=ЕСЛИ(A1>0;A3=(A1*B1+C1*D1)/E1;((B1+D1)/2))

может все же так:
Код
=ЕСЛИ(A1>0;(A1*B1+C1*D1)/E1;((B1+D1)/2))

Автор - SLAVICK
Дата добавления - 06.06.2016 в 23:00
GP75 Дата: Понедельник, 06.06.2016, 23:45 | Сообщение № 7
Группа: Пользователи
Ранг: Участник
Сообщений: 52
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007
Ну я лошара... Трижды Спасибо!
 
Ответить
СообщениеНу я лошара... Трижды Спасибо!

Автор - GP75
Дата добавления - 06.06.2016 в 23:45
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Функция ЕСЛИ c двумя условиями. Нужен пример (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!