Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Поиск в выпадающем списке (без элементов activeX) - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск в выпадающем списке (без элементов activeX) (Формулы/Formulas)
Поиск в выпадающем списке (без элементов activeX)
Noxikus Дата: Среда, 04.05.2016, 14:24 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Добрый день.
Существует следующий способ реализации поиска в выпадающем списке: https://www.youtube.com/watch?v=Jr34riKGveg
Кто-нибудь реализовывал таким способом? Получилось все реализовать, но это сделано лишь для одной ячейки в столбце. Как можно разнести на множество ячеек? Основная формула выглядит так:
Код
=ЕСЛИ(ЕЧИСЛО(НАЙТИ('Касса по КА и доходам'!$D$2;$K$2:$K$498));МАКС($J$1:J1)+1;0)
где D2 как раз ячейка, в которой будет работать поиск.
Пример во вложении. Поиск работает для Кассы в ячейки D2, список значений на листе Справочник и сам метод реализации поиска.

Спасибо.
К сообщению приложен файл: example.xlsm(55Kb)


Сообщение отредактировал Noxikus - Среда, 04.05.2016, 15:03
 
Ответить
СообщениеДобрый день.
Существует следующий способ реализации поиска в выпадающем списке: https://www.youtube.com/watch?v=Jr34riKGveg
Кто-нибудь реализовывал таким способом? Получилось все реализовать, но это сделано лишь для одной ячейки в столбце. Как можно разнести на множество ячеек? Основная формула выглядит так:
Код
=ЕСЛИ(ЕЧИСЛО(НАЙТИ('Касса по КА и доходам'!$D$2;$K$2:$K$498));МАКС($J$1:J1)+1;0)
где D2 как раз ячейка, в которой будет работать поиск.
Пример во вложении. Поиск работает для Кассы в ячейки D2, список значений на листе Справочник и сам метод реализации поиска.

Спасибо.

Автор - Noxikus
Дата добавления - 04.05.2016 в 14:24
Noxikus Дата: Четверг, 05.05.2016, 00:32 | Сообщение № 2
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Решение, с которым удалось скрестить данный способ и получить нужный результат -
http://www.planetaexcel.ru/forum....v-ya...
 
Ответить
СообщениеРешение, с которым удалось скрестить данный способ и получить нужный результат -
http://www.planetaexcel.ru/forum....v-ya...

Автор - Noxikus
Дата добавления - 05.05.2016 в 00:32
Nic70y Дата: Четверг, 05.05.2016, 07:50 | Сообщение № 3
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3678
Репутация: 762 ±
Замечаний: 0% ±

Excel 2013
Вы случайно не это
http://www.excelworld.ru/board/vba/tricks/find_in_database/9-1-0-27
ищете?


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
СообщениеВы случайно не это
http://www.excelworld.ru/board/vba/tricks/find_in_database/9-1-0-27
ищете?

Автор - Nic70y
Дата добавления - 05.05.2016 в 07:50
Noxikus Дата: Четверг, 05.05.2016, 16:48 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
К сожалению этот способ не подойдет, так как используются элементы activeX, которые не поддерживаются на MAC.
 
Ответить
СообщениеК сожалению этот способ не подойдет, так как используются элементы activeX, которые не поддерживаются на MAC.

Автор - Noxikus
Дата добавления - 05.05.2016 в 16:48
Nic70y Дата: Четверг, 05.05.2016, 17:19 | Сообщение № 5
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3678
Репутация: 762 ±
Замечаний: 0% ±

Excel 2013


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
СообщениеНе в курсе как там на Яблоке, предупреждать надо, однако

Автор - Nic70y
Дата добавления - 05.05.2016 в 17:19
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск в выпадающем списке (без элементов activeX) (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!