Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Поиск последнего значения - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск последнего значения (Формулы/Formulas)
Поиск последнего значения
Mezhik Дата: Пятница, 06.05.2016, 12:26 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 72
Репутация: 0 ±
Замечаний: 40% ±

Добрый день!
Подскажите, возможно ли при помощи функции ВПР произвести поиск последнего значения, а не первого? Если нет, то при помощи какой функции или формулы это можно сделать?
К сообщению приложен файл: 11111.xlsx(8Kb)
 
Ответить
СообщениеДобрый день!
Подскажите, возможно ли при помощи функции ВПР произвести поиск последнего значения, а не первого? Если нет, то при помощи какой функции или формулы это можно сделать?

Автор - Mezhik
Дата добавления - 06.05.2016 в 12:26
китин Дата: Пятница, 06.05.2016, 12:31 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3450
Репутация: 548 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
так надо?
Код
=ПРОСМОТР(1;1/($A$1:$A$7=D2);$B$1:$B$7)
К сообщению приложен файл: 21_11111.xlsx(8Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538


Сообщение отредактировал китин - Пятница, 06.05.2016, 12:32
 
Ответить
Сообщениетак надо?
Код
=ПРОСМОТР(1;1/($A$1:$A$7=D2);$B$1:$B$7)

Автор - китин
Дата добавления - 06.05.2016 в 12:31
_Boroda_ Дата: Пятница, 06.05.2016, 12:32 | Сообщение № 3
Группа: Модераторы
Ранг: Экселист
Сообщений: 9375
Репутация: 3948 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Код
=ПРОСМОТР(;-1/(A$1:A$7=D2);B$1:B$7)
К сообщению приложен файл: 11111_19.xlsx(8Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Код
=ПРОСМОТР(;-1/(A$1:A$7=D2);B$1:B$7)

Автор - _Boroda_
Дата добавления - 06.05.2016 в 12:32
buchlotnik Дата: Пятница, 06.05.2016, 12:47 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 2049
Репутация: 613 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
можно и заВПРить B)
Код
=ВПР(;ВЫБОР({1;2};-1/($A$1:$A$7=D2);$B$1:$B$7);2;1)
К сообщению приложен файл: 0168542.xlsx(8Kb)


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru
 
Ответить
Сообщениеможно и заВПРить B)
Код
=ВПР(;ВЫБОР({1;2};-1/($A$1:$A$7=D2);$B$1:$B$7);2;1)

Автор - buchlotnik
Дата добавления - 06.05.2016 в 12:47
Светлый Дата: Пятница, 06.05.2016, 12:50 | Сообщение № 5
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 226
Репутация: 56 ±
Замечаний: 0% ±

Excel 2007
Добрый день!
Можно так:
Код
=ИНДЕКС(B$1:B$7;МАКС((A$1:A$7=D2)*СТРОКА($1:$7)))

или даже так:
Код
=ИНДЕКС(B:B;МАКС((A:A=D2)*СТРОКА(A:A)))


Программировать проще, чем писать стихи.
 
Ответить
СообщениеДобрый день!
Можно так:
Код
=ИНДЕКС(B$1:B$7;МАКС((A$1:A$7=D2)*СТРОКА($1:$7)))

или даже так:
Код
=ИНДЕКС(B:B;МАКС((A:A=D2)*СТРОКА(A:A)))

Автор - Светлый
Дата добавления - 06.05.2016 в 12:50
Mezhik Дата: Пятница, 06.05.2016, 12:53 | Сообщение № 6
Группа: Пользователи
Ранг: Участник
Сообщений: 72
Репутация: 0 ±
Замечаний: 40% ±

Все формулы подходят! Всем большое спасибо!
 
Ответить
СообщениеВсе формулы подходят! Всем большое спасибо!

Автор - Mezhik
Дата добавления - 06.05.2016 в 12:53
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск последнего значения (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!